LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-15-2012, 07:50 AM   #61
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.16.0) UEFI enabled
Posts: 348

Rep: Reputation: 71
seems to me


since ext4 is the recommended filesystem when formatting disks in the slackware install dialogue.
It should be set as built-in for the generic kernel configuration.
Since this seems to be a very common "system won't boot" complaint.
Just a suggestion
Thanks
John
 
Old 07-15-2012, 08:57 AM   #62
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by AlleyTrotter View Post
since ext4 is the recommended filesystem when formatting disks in the slackware install dialogue.
It should be set as built-in for the generic kernel configuration.
Since this seems to be a very common "system won't boot" complaint.
But the vmlinuz-huge kernel supports ext4, so you can always boot this kernel. I'm using also the generic kernel, but have additionally an entry for vmlinuz-huge in my lilo.conf, so I can boot my system even if the configuration for the generic kernel is missing something. Here the part of my lilo.conf
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  initrd = /boot/initrd.gz
  append = "resume=/dev/sda9"
  root = /dev/sda5
  label = Slack64-current
  read-only
###
image = /boot/vmlinuz-huge-3.2.23
  root = /dev/sda5
  label = failsave
  read-only
# Linux bootable partition config ends
Markus
 
Old 07-15-2012, 09:05 AM   #63
Olek
LQ Newbie
 
Registered: Jul 2012
Location: Wroclaw Poland
Distribution: Slackware
Posts: 9

Rep: Reputation: Disabled
Quote:
Originally Posted by chytraeus View Post
Yeah, I see the same thing and now my slackware -current won't boot. I'm using lvm and I get some error like could not mount myvg to /mnt. Had to use systemrescue to boot slackware. I still don't have a fix for this. Anyone?
I have this problem too.
I made initrd like always
mkinitrd -c -k 3.2.23-smp -m reiserfs
and system not started - error is:
mount: mounting /dev/ on /mnt failed: No such device

Then I try
mount -t reiserfs /dev/sda2 /mtn
but
mount: mounting /dev/sda2 on /mnt failed: No such device

I don't now why?
ls /dev/sda*
/dev/sda /dev/sda1 /dev/sda2 /dev/sda3 /dev/sda4 /dev/sda5 /dev/sda6

mkinitrd -c -k 3.2.23-smp -m reiserfs -u
The same problem.

kernel-huge starts OK.
 
Old 07-15-2012, 09:06 AM   #64
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 437

Rep: Reputation: Disabled
Quote:
AlleyTrotter:
since ext4 is the recommended filesystem when formatting disks in the slackware install dialogue.
It should be set as built-in for the generic kernel configuration.
Since this seems to be a very common "system won't boot" complaint.
Just a suggestion
Thanks
John
The generic kernel has them built as modules so that the kernel is lighter and faster on boot. The fact that the filesystems aren't built-in is not likely to be the problem.
 
1 members found this post helpful.
Old 07-15-2012, 09:14 AM   #65
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by TommyC7 View Post
The generic kernel has them built as modules so that the kernel is lighter and faster on boot. The fact that the filesystems aren't built-in is not likely to be the problem.
But the drivers for the filesystem musst be built into the kernel, not as a module! that's very likely the reason when the system does not boot (with "no such device"). Therefore it is necessary to tell mkinitrd which modules are necessary when the system boots. For example here my mkinitrd.conf
Code:
# mkinitrd.conf.sample
# See "man mkinitrd.conf" for details on the syntax of this file
#
SOURCE_TREE="/boot/initrd-tree"
#CLEAR_TREE="0"
OUTPUT_IMAGE="/boot/initrd.gz"
KERNEL_VERSION="$(uname -r)"
KEYMAP="de"
MODULE_LIST="ext4:ahci"
#LUKSDEV="/dev/sda2"
#LUKSKEY="LABEL=TRAVELSTICK:/keys/alienbob.luks"
ROOTDEV="/dev/sda5"
ROOTFS="ext4"
RESUMEDEV="/dev/sda9"
#RAID="0"
#LVM="0"
#UDEV="1"
#MODCONF="0"
WAIT="1"
When a new kernel comes with current, I'll only have to boot the huge kernel and then buid a new initrd with the following command
Code:
mkinitrd -F -c
Booting with the huge kernel is necessary so that the uname-command in mkinitrd.conf has the correct value.

Markus
 
Old 07-15-2012, 09:33 AM   #66
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 437

Rep: Reputation: Disabled
Quote:
markush:
But the drivers for the filesystem musst be built into the kernel, not as a module!
For the current situation, it does seem that way. But I'm not sure if you're saying this is how it should always be, or if you're referring to only the current situation. I haven't used the new mkinitrd yet but my / filesystem is not built-in which is why I'm looking for some clarification.
Code:
$ grep CONFIG_EXT4_FS= /usr/src/linux/.config
CONFIG_EXT4_FS=m
 
Old 07-15-2012, 09:36 AM   #67
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
I've noticed that things have started being mounted with UUID for example /media/ed192c1c-d9fc-4e9d-b57c-723abdfbd6a4 as opposed to /media/disk this is really annoying. Is there a way to change it.

Also, when mounting this other drive I'm asked for my password. This used to be my root password now it is only accepting my ordinary user password. This feels like a potential security breach just waiting to happen.

samac
 
Old 07-15-2012, 09:46 AM   #68
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Quote:
Originally Posted by markush View Post
But the drivers for the filesystem musst be built into the kernel, not as a module!
No, they don't. That is one thing what the initrd is for, loading modules that are necessary but not built into the kernel.
I specified that ext4 should be built into the initrd when I created it, so this really shouldn't be the problem. I rather think that this is a problem with mkinitrd, since there is also an error-message about missing udevadm, which shouldn't be a problem since the init script is testing if udev is present.
 
Old 07-15-2012, 10:08 AM   #69
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by TobiSGD View Post
No, they don't. That is one thing what the initrd is for, loading modules that are necessary but not built into the kernel.
I specified that ext4 should be built into the initrd when I created it, so this really shouldn't be the problem. I rather think that this is a problem with mkinitrd, since there is also an error-message about missing udevadm, which shouldn't be a problem since the init script is testing if udev is present.
Well, I think I have wrote unclear what I meant. The drivers musst be compiled into the kernel or if one uses the generic kernel he has to tell mkinitrd explicitly that the ext4-module is needed.

BTW: after performing the upgrades from July 13 I am running the generic kernel 3.2.23 without any problems. I did what I wrote in my poste above.

Markus
 
Old 07-15-2012, 10:13 AM   #70
Ron@
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Rep: Reputation: Disabled
failed to execute '/lib/udev/vol_id' 'vol_id --export /dev/dm-0': No such file or directory

vol_id seems missing in the udevd package
 
Old 07-15-2012, 10:16 AM   #71
Olek
LQ Newbie
 
Registered: Jul 2012
Location: Wroclaw Poland
Distribution: Slackware
Posts: 9

Rep: Reputation: Disabled
Quote:
Originally Posted by Olek View Post
I have this problem too.
I made initrd like always
mkinitrd -c -k 3.2.23-smp -m reiserfs
and system not started - error is:
mount: mounting /dev/ on /mnt failed: No such device

Then I try
mount -t reiserfs /dev/sda2 /mtn
but
mount: mounting /dev/sda2 on /mnt failed: No such device

I don't now why?
ls /dev/sda*
/dev/sda /dev/sda1 /dev/sda2 /dev/sda3 /dev/sda4 /dev/sda5 /dev/sda6

mkinitrd -c -k 3.2.23-smp -m reiserfs -u
The same problem.

kernel-huge starts OK.
I found the problem.
There isn't symbolic link /boot/initrd-tree/lib/libz.so.1 -> libz.so.1.2.6

This link is only in /lib directory.

I made this link manualy and made new initrd by mkinitrd without the -c option.
Now generic kernel works!

Last edited by Olek; 07-15-2012 at 10:17 AM.
 
2 members found this post helpful.
Old 07-15-2012, 12:05 PM   #72
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,236

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by escaflown View Post
I had the same issue when I first upgraded too. I fount out it was because I was somehow missing libnl3. Everything's working fine now.
I checked the /var/log/packages file and libnl3 was installed, but I downloaded a fresh copy and re-installed it anyway. Unfortunately, it didn't solve the problem.


Quote:
Originally Posted by willysr View Post
also check /etc/udev/rules.d/70-persistent-net.rules as WLAN card name might get changed there just like in my case from wlan0 to wlan1
I checked the file and the card is properly listed as wlan0.

I un-installed (removepkg) the new version of NetworkManager (0.9.4) and re-installed the previous version (0.9.2) and upon reboot there was an error message saying networkmanager couldn't find libgnutls26.... something like that, it flew by quickly. Which reminds me, I do NOT like the way you are thrown to a new screen with only the 'welcome' and the sign-on prompt. Makes it almost impossible to read the last several lines of the boot process which are not in the dmesg file.

After seeing the error message I checked and gnutls-whatever is installed. So, I un-installed networkmanager-0.9.2 and installed wicd. Hopefully I'll figure out the problem soon as wicd is about as reliable as a politician.

Last edited by cwizardone; 07-15-2012 at 12:40 PM. Reason: Typo.
 
Old 07-15-2012, 12:15 PM   #73
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 867

Rep: Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750Reputation: 1750
Quote:
Originally Posted by cwizardone View Post
Which remains me, I do NOT like the way you are thrown to a new screen with only the 'welcome' and the sign-on prompt. Makes it almost impossible to read the last several lines of the boot process which are not in the dmesg file.
Me either, which is why I disabled that in /etc/inittab. If you move your .new file over the annoying behavior will cease.
 
4 members found this post helpful.
Old 07-15-2012, 12:35 PM   #74
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,236

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by volkerdi View Post
Me either, which is why I disabled that in /etc/inittab. If you move your .new file over the annoying behavior will cease.
Ah,so..... (He said, as the light dawned )
Thank you very much!
Greatly appreciated!
 
Old 07-15-2012, 12:55 PM   #75
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 312

Rep: Reputation: 59
Quote:
Originally Posted by mlangdn View Post
I get the feeling I am about to screw up.

Code:
ldconfig: /usr/lib64/libnssutil3.so is not a symbolic link

ldconfig: /usr/lib64/libnspr4.so is not a symbolic link

ldconfig: /usr/lib64/libplc4.so is not a symbolic link
These are not dead links, and they are also present in /usr/lib64/seamonkey-2.10.1
Something didn't go right, but it does not seem to be a problem yet. Got more lookin' to do.
I also get this, even at boot. And everything is screwed up. Cannot launch volumeicon, glxinfo, glxgears e.t.c.. Gaaaaah

*EDIT:

Well, I deleted all the files that are not symbolic, those can be found in the /usr/lib64/seamonkey-2.10.1/ instead. I'm not sure how those files were installed in the /usr/lib64 anyways... I hope this does not screw up something now.

For the glx-part, I reinstalled the NVIDIA-driver...

And now for the volumeicon I get this:
bash-4.2$ volumeicon
volumeicon: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

Last edited by Bindestreck; 07-15-2012 at 01:15 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Microsoft forms open source subsidiary on Friday the 13th LXer Syndicated Linux News 0 04-13-2012 06:50 PM
LXer: Linux Gets Gooey on Friday the 13th LXer Syndicated Linux News 0 02-13-2009 10:10 PM
LXer: One of those magic times: On Friday the 13th! LXer Syndicated Linux News 1 02-07-2009 09:43 AM
LQ Security Report - February 13th 2005 Capt_Caveman Linux - Security 4 02-13-2005 09:51 PM
LQ security report - Feb 13th 2004 unSpawn Linux - Security 5 02-13-2004 11:36 AM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration