LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-21-2012, 01:35 AM   #181
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17

Quote:
Originally Posted by cwizardone View Post
I've spent the last 24 hours trying to do a fresh install of 13.37 (64bit) and then "upgrade" (Ha) to -current. I've made at least 3 attempts from scratch. Might be four. At this point I'm so tired I don't remember. Each time there was a problem and I finally figured it out....
But this is the last straw... I had everything working well, except Xfce, but KDE 4.8.4 was working OK. NetworkManager still doesn't work, but wicd is doing the job for now.
Just when I thought all was nearly done, I fired up KDE and the whole desktop went upside down and backwards. You can see it start from the splash screen. It happens to both user and root.
Picture attached. I didn't crop out the HP logo so you can see this isn't some sort of trick.
I've had this problem before. You'll have to rebuild your nvidia drivers I suppose.
 
1 members found this post helpful.
Old 07-21-2012, 08:27 AM   #182
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
Quote:
Originally Posted by cwizardone View Post
I fired up KDE and the whole desktop went upside down and backwards. You can see it start from the splash screen. It happens to both user and root.
Picture attached. I didn't crop out the HP logo so you can see this isn't some sort of trick.
If you are using a binary video driver, have you reinstalled it?
 
1 members found this post helpful.
Old 07-21-2012, 08:39 AM   #183
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,228

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by TommyC7 View Post
No offense to you cwizardone (I know you're having a real problem), but that's hilarious. There seems to be a lot of things with SCSI drivers though, and I've run into one of them too it seems...
If you like that one, you'll love this one. This was back on 8 May 2012. I started a fresh install and went to the corner market for a few minutes. I came back, grabbed a cup of coffee, and sat down in front of the monitor to find the installation had frozen and this is what was on the screen. Seems there are some bugs or old data hidden in the installation software somewhere.
Attached Images
File Type: jpg gnome-of-slack-may82012.jpg (89.7 KB, 88 views)
 
Old 07-21-2012, 08:42 AM   #184
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,228

Rep: Reputation: 176Reputation: 176
@Alekow & Rpedrica,

I deleted the ~.kde directory and re-started. So far, so good.
 
Old 07-21-2012, 11:39 AM   #185
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.16.0) UEFI enabled
Posts: 348

Rep: Reputation: 71
Your not alone

Quote:
Originally Posted by cwizardone View Post
@Alekow & Rpedrica,

I deleted the ~.kde directory and re-started. So far, so good.
I had the upside down reverse screen a few months ago.
It happened when messing with the Nvidia driver.
I normally use nouveau.
I remember deleting the .kde directory and doing a:
"upgradepkg --reinstall" kde, x, and maybe l also. I really don't remember anymore. It certainly was shocking. I immediately thought some one was playing a cruel joke

john
 
1 members found this post helpful.
Old 07-21-2012, 01:14 PM   #186
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 133

Rep: Reputation: 19
/dev/root

Not sure if this is a result of the latest upgrades, everything is running smoothly here but noticed that the /dev/root link is not there anymore, found out when running lilo after compiling a custom 3.4 kernel, it failed since lilo.conf has "boot = /dev/root", workaround is easy but why has /dev/root disappeared?
Thanks.

Quote:
# ls -lh /dev/root
/bin/ls: cannot access /dev/root: No such file or directory
 
Old 07-21-2012, 02:06 PM   #187
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 861

Rep: Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680
Quote:
Originally Posted by dr.s View Post
Not sure if this is a result of the latest upgrades, everything is running smoothly here but noticed that the /dev/root link is not there anymore, found out when running lilo after compiling a custom 3.4 kernel, it failed since lilo.conf has "boot = /dev/root", workaround is easy but why has /dev/root disappeared?
Thanks.
How did "boot = /dev/root" end up in lilo.conf? Did liloconfig do that somehow?

Upstream udev dropped the /dev/root symlink because it was really never supposed to be used for anything. Frankly, I'm not sure why the kernel ever provided it in the first place. It used to know what the actual root partition was without requiring an initrd to figure it out, but perhaps that's because the kernel used to need to be prepped with "rdev", which is long obsolete.
 
Old 07-21-2012, 02:40 PM   #188
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Problem remains with mkinitrd: boot fail as rootdev is not mounted.

I did a fresh installatin of -current in its state after update dated Wed Jul 18 20:21:15 UTC 2012.

As / has an ext4 file system I made an initrd with the usual command:
Code:
mkinitrd -c -k 3.2.23-smp -m ext4
Updated /etc/lilo.conf, re-ran lilo, rebooted and just after loading the three modules needed for ext4 I see:
Code:
mounting /dev on /mnt failed: Block device required

Last edited by Didier Spaier; 07-21-2012 at 03:04 PM.
 
Old 07-21-2012, 02:40 PM   #189
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 133

Rep: Reputation: 19
Quote:
Originally Posted by volkerdi View Post
How did "boot = /dev/root" end up in lilo.conf? Did liloconfig do that somehow?

Upstream udev dropped the /dev/root symlink because it was really never supposed to be used for anything. Frankly, I'm not sure why the kernel ever provided it in the first place. It used to know what the actual root partition was without requiring an initrd to figure it out, but perhaps that's because the kernel used to need to be prepped with "rdev", which is long obsolete.
Running liloconfig fails on my machine with the message below, so I copied (a very old) lilo.conf, edited it manually and ran lilo. That old copy had "boot = /dev/root" in it.
Code:
# liloconfig 
liloconfig: couldn't open /tmp/lilotmp1: No such file or directory
 
Old 07-21-2012, 03:45 PM   #190
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Rep: Reputation: 17
Hello,

Quote:
Originally Posted by hotchili View Post
Hello,

since the big update, Kaffeine can't play video from my DVB-S Card.
It claims "No Device", but I can still watch DVB-S channels with mplayer.

Have already recompiled Kaffeine, but didn't help. If anyone has an idea...

EDIT: Found out more, this seems to be a bug in udev or kaffeine
https://bugs.gentoo.org/show_bug.cgi?id=372489

Kaffeine gets the path to the dvb device wrong...
just FYI, I upgraded udev to version 182 and kaffeine works fine again.

I had to make some small changes to the udev.SlackBuild:
--libexecdir=/lib/udev becomes --libexecdir=/lib (else everything ends up in /lib/udev/udev)

just before scsi_id is linked into /sbin:
[ ! -d $PKG/sbin ] && mkdir $PKG/sbin

after udevd gets moved to /sbin, had to move udevadm too:
mv $PKG/usr/bin/udevadm $PKG/sbin
rm -rf $PKG/usr/bin

In the docs section:
extras/keymap/README.keymap.txt becomes src/keymap/README.keymap.txt

And the patch rule_generator.diff.gz had to be reformatted but is more or less the same.

Last edited by hotchili; 07-21-2012 at 04:06 PM.
 
Old 07-21-2012, 03:57 PM   #191
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Could missing /dev/root and booting with in initrd failing be related

I did notice that I have:
Code:
bash-4.2# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        10G  6.8G  2.7G  72% /
/dev/sda3       103G   48G   51G  49% /13.37
tmpfs           1.5G     0  1.5G   0% /dev/shm
/dev/sda2        32G   30G  2.6G  92% /windows
bash-4.2#
Though the /dev/root link doesn't exist anymore, as pointed out by dr.s in post #186 of this thread.

Could booting with an initrd failing (see my post #188) be related to that?

EDIT
Code:
bash-4.2# cat /etc/fstab
/dev/sda6        swap             swap        defaults         0   0
/dev/sda5        /                ext4        defaults         1   1
/dev/sda3        /13.37           ext4        defaults         1   2
/dev/sda2        /windows         ntfs-3g     fmask=133,dmask=022 1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
bash-4.2#
So I don't know why "df -h" writes /dev/root instead of /dev/sda5

Last edited by Didier Spaier; 07-23-2012 at 02:27 AM. Reason: Typo in title corrected
 
Old 07-21-2012, 04:29 PM   #192
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Rep: Reputation: 17
This is from mkinitrd:
Quote:
and if "mount" returns /dev/root as the root device,
use readlink to resolve the device pointed to by the /dev/root
symlink
Maybe it tried to resolve /dev/root but fails and then gets something wrong.
cat /boot/initrd-tree/rootdev to see what mkinitrd set as rootdev.

You could try mkinitrd with -f ext4 -r /dev/sda5 and see if your initrd error goes away.
 
Old 07-21-2012, 05:02 PM   #193
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Quote:
Originally Posted by hotchili View Post
You could try mkinitrd with -f ext4 -r /dev/sda5 and see if your initrd error goes away.
Thanks hocthili, that did the trick.

I did "cat /boot/initrd-tree/rootdev" before running mkinitrd again and it returned /dev/

I guess you are right, at first mkinitrd tried to resolve /dev/root but failed as /dev/root did not exist.

EDIT I just looked at /sbin/mkinitrd and can confirm your assumption
Code:
# If $ROOTDEV and $ROOTFS are not set, assume we want the
# values for the currently mounted /
# (unless we find that values are already set in the initrd-tree):
if [ -z "$ROOTDEV" -a -z "$(cat $SOURCE_TREE/rootdev 2>/dev/null)" ]; then
  ROOTDEV=$(mount | grep ' on / ' | cut -f 1 -d ' ')
  if [ "$ROOTDEV" = "/dev/root" ]; then # find real root device
    ROOTDEV="/dev/$(readlink /dev/root)"
  fi
fi
In my case $ROOTDEV was not set and the source tree didn't exist yet, but "mount" returned /dev/root as / filesystem hence $(readlink /dev/root) was null and $ROOTDEV was set to /dev/

So the real problem seems to be "why do the mount command return /dev/root as filesystem for / here?"

PS for Pat: maybe the script could issue a warning in case $(readlink /dev/root) be null? Or look at /etc/fstab in that case?

PS2 I notice that whilst a generic kernel is used "mount" report the real device name for / (in my case /dev/sda5). Unfortunately chances are that mkinitrd be run whilst using a huge kernel...

Last edited by Didier Spaier; 07-21-2012 at 05:53 PM. Reason: Added EDIT ...
 
Old 07-22-2012, 10:12 AM   #194
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 374

Rep: Reputation: 55
Quote:
Originally Posted by catfoo View Post
My luks container never gets unlocked. If I try to run 'cryptsetup' from that shell, the error message is 'Cannot initialize crypto RNG backend.'

At this point I'm beginning to think that my kernel config is the problem. I'm seeing that some things I've always built as modules (i.e. ext4, mbcache, etc.) are now built into the kernel.
Quote:
Originally Posted by catfoo View Post
Up and running 3.4.6 now after using the default /boot/config-generic-smp-3.2.23-smp file.

I do find it curious that the new /boot/initrd-tree/dev folder still doesn't have the random and urandom nodes. I'll just assume it has to do with differences in the kernel configuration until someone tells me otherwise.

Thanks for the help.
Is CONFIG_DEVTMPFS disabled in the kernel that is failing ?

udevd (according to the manpage) should copy the devices from /lib/udev/devices so /dev/urandom should be in /dev. However, for some reason it doesn't get copied (at least in my case and yours) and cryptsetup fails. If CONFIG_DEVTMPFS is enabled (as it is in the generic slackware kernel) then the devices are present and everything works fine.
 
Old 07-22-2012, 12:25 PM   #195
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
devtmpfs is *required* - go ahead and enable it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Microsoft forms open source subsidiary on Friday the 13th LXer Syndicated Linux News 0 04-13-2012 06:50 PM
LXer: Linux Gets Gooey on Friday the 13th LXer Syndicated Linux News 0 02-13-2009 10:10 PM
LXer: One of those magic times: On Friday the 13th! LXer Syndicated Linux News 1 02-07-2009 09:43 AM
LQ Security Report - February 13th 2005 Capt_Caveman Linux - Security 4 02-13-2005 09:51 PM
LQ security report - Feb 13th 2004 unSpawn Linux - Security 5 02-13-2004 11:36 AM


All times are GMT -5. The time now is 11:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration