LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Fresh Slack64 Install Crashes on 'startx' (http://www.linuxquestions.org/questions/slackware-14/fresh-slack64-install-crashes-on-startx-861799/)

kwikness 02-10-2011 07:50 AM

Fresh Slack64 Install Crashes on 'startx'
 
Hey guys,


I just finished an install of Slack64 current and it's crashing when I try to start up KDE. I tried setting the VESA framebuffer to 'normal' in /etc/lilo.conf, but no dice.

Here's the log file: http://dev.kyleswebspace.com/shared/Xorg.0.log

GFX Card: Radeon HD 6850 (yeah I know.. this is probably the source of the conflict)

dijetlo 02-10-2011 08:55 AM

Code:

[  119.345] (EE) Failed to load module "fbdev" (module does not exist, 0)
Reading through the threads...there is a 64-bit driver for "Linux" here.

Ramurd 02-10-2011 08:59 AM

Could it be your video driver is 32 bit whereas your slack is 64? That will cause a segmentation fault, which is what made X crash when I quickly scanned your log.

colorpurple21859 02-10-2011 10:32 AM

will xfce run? If so try disabling deskop effects in KDE.

another thing to try: create a kms.conf file in /etc/modprobe.d with the following line.
Quote:

radeon modeset=1

adamk75 02-10-2011 02:32 PM

It would appear that there is some problem with the glx module when using the vesa driver. I see three possible solutions:

1) disable the glx module via an xorg.conf file. Since you're using the vesa driver, glx is pretty much useless anyway. I don't know that this will prevent the crash, but I'd say it's likely to work.
2) Update xf86-video-ati, mesa, and the kernel to versions that support 2D (and even some 3D) acceleration. I'm not quite sure what's needed, but clearly what's in -current is too old.
3) Use fglrx from AMD. dijetlo linked to that driver in his post.

Adam


All times are GMT -5. The time now is 05:34 PM.