Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-10-2011, 06:50 AM   #1
Registered: Apr 2006
Location: MA
Distribution: Slackware 13
Posts: 67

Rep: Reputation: 15
Fresh Slack64 Install Crashes on 'startx'

Hey guys,

I just finished an install of Slack64 current and it's crashing when I try to start up KDE. I tried setting the VESA framebuffer to 'normal' in /etc/lilo.conf, but no dice.

Here's the log file:

GFX Card: Radeon HD 6850 (yeah I know.. this is probably the source of the conflict)
Old 02-10-2011, 07:55 AM   #2
Senior Member
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,134
Blog Entries: 2

Rep: Reputation: Disabled
[   119.345] (EE) Failed to load module "fbdev" (module does not exist, 0)
Reading through the threads...there is a 64-bit driver for "Linux" here.
Old 02-10-2011, 07:59 AM   #3
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 561

Rep: Reputation: 76
Could it be your video driver is 32 bit whereas your slack is 64? That will cause a segmentation fault, which is what made X crash when I quickly scanned your log.
Old 02-10-2011, 09:32 AM   #4
Senior Member
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,668

Rep: Reputation: 216Reputation: 216Reputation: 216
will xfce run? If so try disabling deskop effects in KDE.

another thing to try: create a kms.conf file in /etc/modprobe.d with the following line.
radeon modeset=1
Old 02-10-2011, 01:32 PM   #5
Senior Member
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
It would appear that there is some problem with the glx module when using the vesa driver. I see three possible solutions:

1) disable the glx module via an xorg.conf file. Since you're using the vesa driver, glx is pretty much useless anyway. I don't know that this will prevent the crash, but I'd say it's likely to work.
2) Update xf86-video-ati, mesa, and the kernel to versions that support 2D (and even some 3D) acceleration. I'm not quite sure what's needed, but clearly what's in -current is too old.
3) Use fglrx from AMD. dijetlo linked to that driver in his post.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slack64 13 (fresh) Broadcom 4312 no wlan archangel.k978 Slackware 7 03-21-2010 06:42 PM
Startx Error - Fresh Gentoo 2006.1 install kruptos Linux - Newbie 1 09-14-2006 04:37 PM
slack 10, fresh install, konqueror crashes zenhues Slackware 0 07-13-2004 11:49 AM
startx crashes 19802974 Linux - Newbie 7 08-13-2002 03:07 AM
startx crashes divekar Linux - Software 1 11-22-2000 06:49 PM

All times are GMT -5. The time now is 03:19 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration