-   Slackware (
-   -   Fresh installation of Slackware 13 -64 and Slackbuilds/sbopkg (

arubin 08-28-2009 09:38 AM

Fresh installation of Slackware 13 -64 and Slackbuilds/sbopkg
I am planning on doing a fresh installation of slackware 13 for 64 bit.

Can I assume that all the environmental variables are set up so that Slackbuilds and/or sbopkg will work or do I need to tweak buildscripts or profiles?


gegechris99 08-28-2009 09:49 AM

There is a new FAQ on that deals with how to use SlackBuild scripts in a 64-bit system.


What is the easiest way to use the scripts on Slackware64?

* Set ARCH=x86_64 in your build environment; this can be done several different ways, but here are a few suggestions:
1. Manually specify it on the command line when running the script, e.g.
ARCH=x86_64 ./chemtool.SlackBuild
2. Manually set it in your shell environment prior to running build scripts, for example:
root@host# ARCH=x86_64
root@host# export ARCH
3. Edit your shell's inititialization files to set it, e.g. in $HOME/.bashrc or the equivalent
4. Create (or edit) a custom script in /etc/profile.d/, for example:
/etc/profile.d/ to set it systemwide
5. Roll your own solution if you don't like any of our suggestions :-)

arubin 08-28-2009 09:56 AM

Yes I saw that but I was not sure if that applied to 64 bit systems as they were in current/testing or whether the fresh new release of Slackware 13 would come with variables ready set.

gegechris99 08-28-2009 10:04 AM is always following the stable release and keeps slackbuilds from the previous ones as far back as 11.0 but not -current. So the FAQ is applicable to 13.0.

mattington 11-09-2009 01:10 PM

I was wondering this myself...

sbopkg displays the ARCH setting at the top right of the interface. It seems this is set for you by sbopkg, which makes sense.

TSquaredF 11-09-2009 01:43 PM

sbopkg uses "uname -m" to determine the machine type. You have to set it only if you want to build packages for another machine.

Lufbery 11-09-2009 02:31 PM

EDIT: TSquaredF beat me to it. :)

All times are GMT -5. The time now is 07:04 AM.