LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Fresh install RC5 - Nvidia gtx550 (http://www.linuxquestions.org/questions/slackware-14/fresh-install-rc5-nvidia-gtx550-4175428574/)

dgrames 09-22-2012 04:41 PM

Fresh install RC5 - Nvidia gtx550
 
Just a note, I did a fresh install of RC5. The display froze when the nouveau driver loaded. Had to reboot on the install disk to load the xf86-video-nouveau blacklist file.

Possibly could the nouveau driver be blacklisted by default.

Don

Didier Spaier 09-22-2012 06:16 PM

A Google search shows that many people have a problem with gtx550 + kernel 3.2.x + nouveau.

To get nouveau working you can either make & install a 3.4 or 3.5 kernel with one of the config files provided in /testing/source or upgrade libdrm + nouveau with the versions available in /testing. The former should work, the latter I am not sure but is faster to try.

dgrames 09-22-2012 08:05 PM

I installed the proprietary drivers. I just thought it might be easier to turn on the nouveau driver rather than trying to shut it off when the display locks on startup.

Don

jtsn 09-23-2012 01:26 AM

I think, drivers based on reverse engineering should be disabled by default.

Didier Spaier 09-23-2012 03:06 AM

Quote:

Originally Posted by jtsn (Post 4786916)
I think, drivers based on reverse engineering should be disabled by default.

Is that a philosophical or practical suggestion?

In the latter case, you will make happy the people who are in Don's situation, and unhappy the people who don't want to use the proprietary driver nor to fall back to vesa or nv.

And disable nouveau (for instance) by default is not that easy. You can blacklist it, as Don suggested, but that won't prevent it to be automatically loaded when X starts, unless you include an X config file in /etc/X11.

BTW in that directory xorg.conf-vesa is provided that you have just to rename to get that done.

Another way would be not to ship the the nouveau kernel module at all, but as I understand it is more in the spirit of Slackware to give users the choice to use it or not.

cascade9 09-23-2012 04:37 AM

Quote:

Originally Posted by Didier Spaier (Post 4786952)
In the latter case, you will make happy the people who are in Don's situation, and unhappy the people who don't want to use the proprietary driver nor to fall back to vesa or nv.

Falling back to the .nv driver is (AFAIK) impossible, or at least a Bad Idea, with 400 series or later cards (G405 is the exception, as its using an older GT 218 core, not a 'fermi' GF-XXX core).

Quote:

NVIDIA's open-source Linux efforts as it concerns their GPU support have historically been minimal. The xf86-video-nv driver has been around that provides very basic 2D acceleration and a crippled set of features besides that (no proper RandR 1.2/1.3, KMS, power management, etc) while the code has also been obfuscated to try to protect their intellectual property. However, NVIDIA has decided to deprecate this open-source driver of theirs. No, NVIDIA is not working on a new driver. No, NVIDIA is not going to support the Nouveau project. Instead, NVIDIA now just recommends its users use the X.Org VESA driver to get to NVIDIA.com when installing Linux so they can install their proprietary driver.

This xf86-video-nv announcement is coming as the GeForce 400 "Fermi" graphics cards launch. NVIDIA will not be providing open-source support for Fermi or any future NVIDIA products. NVIDIA will continue barely supporting xf86-video-nv only as it concerns existing GPUs and functionality and what they see "within reason" future versions of the X.Org Server. NVIDIA will also not support DisplayPort on any GPU with the open-source NVIDIA driver.
http://www.phoronix.com/scan.php?pag...kills_nv&num=1

Terminator3000 09-23-2012 04:47 AM

Disable Nouveau for Nvidia Slackware
 
You can find a way to permanently disable the nouveau drivers at

http://minimallinux.blogspot.co.uk/2...a-drivers.html

Its for Centos 6 but should work for Slackware also.

Didier Spaier 09-23-2012 05:27 AM

For Slackware to disable nouveau if you want to use a proprietary driver you can either do it manually, e.g.:
Code:

echo "blacklist nouveau" > eic/modprobe.d/blacklist-nouveau.conf
or even better just install the package xf86-video-nouveau-blacklist provided in /extra.
Additionally you will need to put a relevant config file in /etc/X11. The nvidia-xconfig utility can do it for you.

Terminator3000 09-23-2012 05:48 AM

Blacklist Nouveau for Nvidia
 
The disable-nouveau.conf file should contain the line

'blacklist nouveau options nouveau modeset=0'

and you should also append to the kernel line in grub.conf file

'rdblacklist=nouveau nouveau.modeset=0'

That should do it.

Didier Spaier 09-23-2012 06:15 AM

Quote:

Originally Posted by Terminator3000 (Post 4787035)
The disable-nouveau.conf file should contain the line

'blacklist nouveau options nouveau modeset=0'

and you should also append to the kernel line in grub.conf file

'rdblacklist=nouveau nouveau.modeset=0'

That should do it.

No.
(1) "options nouveau modeset=0" is useless as long is nouveau is blacklisted and if not it would be a bad idea as nouveau do need KMS.
(2) 'rdblacklist=nouveau nouveau.modeset=0' is useless as well and the bootloader used by Slackware by default is lilo, not grub.

Terminator3000 09-23-2012 06:38 AM

Blacklist Nouveau
 
Sorry, 'modeset=0' is definitely required for Centos 6 which I use, if it omitted then the unwanted nouveau drivers still load.

Terminator3000 09-23-2012 06:42 AM

Modeset
 
@Didier, can you clarify as to what 'modeset' actually refers to, to avoid further confusion ? Thanks

Didier Spaier 09-23-2012 07:09 AM

@Terminator3000: 'modeset' is a parameter for the 'nouveau' kernel driver. As written in output of "modinfo nouveau" :
Code:

parm:          modeset:Enable kernel modesetting (int)
If you wand to know more about kernel mode setting or KMS, see here. About nouveau, there.

And keep in mind that not all distributions work the same way.

Terminator3000 09-23-2012 07:23 AM

Modeset
 
Thanks

Terminator3000 09-23-2012 07:38 AM

Modeset/Nvidia
 
Taking a look at the links Didier sent, I noticed the following, which may have some bearing on the original problem in this thread.

'First, make sure your kernel configuration has CONFIG_FRAMEBUFFER_CONSOLE enabled. Most sane configurations have it built into the kernel, but you can have it as a module (fbcon.ko), too. In that case make sure this module is loaded before or along with nouveau.ko. Otherwise your virtual console appears frozen.

With recent nouveau, KMS is on by default, unless you disable it with modeset=0 option'

Just a thought.


All times are GMT -5. The time now is 05:25 PM.