LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Fresh Instalation Slackware 12.2 and FX 5950 U Problems (http://www.linuxquestions.org/questions/slackware-14/fresh-instalation-slackware-12-2-and-fx-5950-u-problems-691315/)

hellcops 12-17-2008 04:13 PM

Fresh Instalation Slackware 12.2 and FX 5950 U Problems
 
Hi , my friends.

I try to install the Drivers in my Slackware 12.2 but i have compile problems

extract tail fron nvidia-installer.log

make[3]: *** [_module_/tmp/selfgz2879/NVIDIA-Linux-x86-169.09-pkg1/usr/src/n
v] Error 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.

Drakeo 12-17-2008 04:28 PM

here is what you need to do go to http://slackbuilds.org/result/?search=nvidia&sv=12.2
get the package there nvidia has a patch for the 2.6.27 kernel. do not do it like i did and spend hours reading on nvidia patch files.just go here build it. if the nvida configure program does not install with the modules do like I did. cd /tmp/ nvida build file and run nvidia installer. this has to be done in runlevel 3 and as root. reboot have fun. so after you build the module and pktool it in. if you do not have the nvidia setings tool such as nvidia-setting and nvidia-xorgconf. then do like I said runlevel 3 as root cd /tmp and the name of your kernel build file. there you will see the compiled package. type ./nvidia-installer and then it is all as usuall. on my upgrade I did not have to do this because nvidias bionary tools were already installed but on a new install I had to do the plus remove gspca_main black list it then compile max's gspca to get my old cam to work good luck. I guess the reason why it did not install with the module is the build scripts.

hellcops 12-18-2008 08:25 AM

thanks my friend drakeo , I follow your recomendation but errors again.

(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

I try to load module manually with modprobe
bash-3.1# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.27.7/kernel/drivers/video/nvidia.ko): Invalid module format

:(

urka58 12-18-2008 12:32 PM

It seems your card is supported by this driver
http://www.nvnews.net/vbulletin/showthread.php?t=122423
No patches are necessary, it's a beta driver but it works fine for me
Hope this helps
Ciao

hellcops 12-18-2008 03:14 PM

I resolve:

1- Link in /boot vmlinuz, System.map y config to
System.map -> System.map-huge-2.6.27.7
config -> config-huge-2.6.27.7
vmlinuz -> vmlinuz-huge-2.6.27.7

2- rc.modules -> rc.modules-2.6.27.7
3- In the /extra folder:
patch-to-non-smp.sh
chmod +x patch-to-non-smp.sh
./patch-to-non-smp.sh

4- http://www.nvnews.net/vbulletin/showthread.php?t=122423 (10x Urka58)

5- Installl the drivers and ready

I have a single CPU non SMP, FX 5950U AGP video


All times are GMT -5. The time now is 03:08 PM.