LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-04-2002, 03:36 AM   #1
enzo250gto
Member
 
Registered: Oct 2001
Location: Tokyo, Japan
Distribution: Slackware
Posts: 105

Rep: Reputation: 15
framed buffer (needs to go)


I did not have this problem with Slack 8 (although I don't think its Slaks fault). I use to use WindowMaker but decided to give Enlightenment a try. To make it short. When I boot everything is fine and the mode appears to be normal. When I startx and then logout of X I cannot see the command line. It dumps me into what looks like a framed buffer of some sort. I can still type but I do not see what I'm typing. When I installed Linux I told it to do a standard console. Also to let you know, when I logout of Enlightenment and ALT F2 to the other ttys they also have the same problem. If I login here and try a pico file I can't see it. Thanks for any help.
 
Old 09-04-2002, 05:01 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
sorry? we ave already fully explained to you how to get rid of a framebuffer, please pay a little more attention to the advice you are given.
 
Old 09-04-2002, 03:09 PM   #3
enzo250gto
Member
 
Registered: Oct 2001
Location: Tokyo, Japan
Distribution: Slackware
Posts: 105

Original Poster
Rep: Reputation: 15
acid,
Not exactly. The advice you gave me was to edit LILO. Re-read the above post. How on earth does that have anything to do with LILO? It doesn't. When I boot Linux I am not in a framed buffer, when I run Enlightenment and then exit Enlightenment I'm all of a sudden in Framed buffer. I looked at the XF86Config file and it has is the screen section after my monitor a line about this. I cannot post that line at the moment but will when I get the chance.
 
Old 09-04-2002, 03:20 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Quote:
How on earth does that have anything to do with LILO? It doesn't.
I'm very sorry, but who are you to tell us that we are wrong? you don't even know what a framebuffer IS let alone how to get rid of it. how about accepting what the people here say for once? If you can tell my why i am wrong, with simply stating it sarcastically like ou have there, then maybe we'll redress the balance, until then WE ARE RIGHT, it IS to do with LILO!
 
Old 09-04-2002, 03:59 PM   #5
enzo250gto
Member
 
Registered: Oct 2001
Location: Tokyo, Japan
Distribution: Slackware
Posts: 105

Original Poster
Rep: Reputation: 15
I said you were wrong. Maybe you didn't read my post closely. Here is my lilo file bud and LIKE I SAID ITS NOT A FRAMED BUFFER AT STARTUP.
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda1
  label = Linux
  read-only
# Linux bootable partition config ends
Looks to me like my framed buffers are all commented.
LIKE I SAID THE PROBLEM IS ONLY AFTER STARTING X
Maybe this could be it
Code:
# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor     "My Monitor"
I know I'm being rude and will probably get a negative reaction back. But hey you are telling me I don't know what I'm talking about when this problem is happening right in front of me on my computer. I have been using this distro for over a year now and do have some pretty good working knowlegde of it. Maybe your a god and know everything but sorry I'm just trying to catch up and learn it as I go.
 
Old 09-04-2002, 04:08 PM   #6
enzo250gto
Member
 
Registered: Oct 2001
Location: Tokyo, Japan
Distribution: Slackware
Posts: 105

Original Poster
Rep: Reputation: 15
HOWTO

If anyone stumbles across this there is a framebuffer HOWTO located at http://www.tldp.org/HOWTO/Framebuffer-HOWTO.html

I read this and did not see the answer to the problem I am having.
 
Old 09-04-2002, 04:33 PM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
right, now we get some sense. you're actaully setting up your X server to run inside a framebuffer itself, which is something you'd really only do if your video card is unsupported, in which case X is drawn inside the framebuffer which is initialised during boot. is this to do with the dual head system? is there some reason you have this set up as such? there's unlikely to be a real reason to do that, but then if you knew about it then you'd know what the problem already is.
 
Old 09-04-2002, 05:58 PM   #8
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
Yeah i think Acid_Kewpie is right. Is this what a nested X server is?

Anyway an easy way to get rid of it as far as i can understand is to disable frame buffer support from the kernel and recompile. Or maybe first make a copy of your XF86Config file and re-create it with xf86config.
Does this happen only when you use Enlightenment? What version? Did you try Enlightenment IRC chanel for help?
Hope that helps!
-NSKL
 
Old 09-05-2002, 01:03 AM   #9
enzo250gto
Member
 
Registered: Oct 2001
Location: Tokyo, Japan
Distribution: Slackware
Posts: 105

Original Poster
Rep: Reputation: 15
Damn I types a long ass message hit post reply and doh! I needed to hit submit reply. Here we go again

acid,
Sorry for being a prick in the earlier post. Thanks for the reply, next time I'll give more info in the beginning.

acid & NSKL,
Here is the scoop on all this. In Slack 8.0 I would always run xf86config after install to get X to work. I also always used WindowMaker. Now I decided to upgrade to 8.1 when I did I choose enlightenment as default and when I rebooted after the install I could type startx and it would run Enlightenment no problem (this was not the case in 8.0 I always had to config X first). So these are the settings it gave me. Could I hand edit /etc/X11/XF86Config and get rid of the problem? My graphics card is ATI Radeon 64DDR VIVO (supported by 3rd party drivers). I haven't had the time to install this driver but I'm working on it.
acid you wrote
Quote:
n which case X is drawn inside the framebuffer which is initialised during boot. is this to do with the dual head system?
Ok this makes sense, when you use boot you mean Xs boot right? This I follow if thats what you mean, X boots the framebuffer to run in it. what do you mean by dual head? I haven't done dual monitors yet (next project). I haven't tried another X manager but will to see what happens. I'm also not very good at recompiles but did consider that (I want that to be last option). Thanks again for all the help thus far.
 
Old 09-05-2002, 01:22 AM   #10
enzo250gto
Member
 
Registered: Oct 2001
Location: Tokyo, Japan
Distribution: Slackware
Posts: 105

Original Poster
Rep: Reputation: 15
OK I just tried KDE and I still have the same problem.
 
Old 09-05-2002, 04:33 AM   #11
eggs
Member
 
Registered: Jun 2002
Location: Jackson, TN
Distribution: Arch Linux 0.6
Posts: 60

Rep: Reputation: 15
Quote:
Now I decided to upgrade to 8.1 when I did I choose enlightenment as default and when I rebooted after the install I could type startx and it would run Enlightenment no problem (this was not the case in 8.0 I always had to config X first). So these are the settings it gave me.
Thats because 8.1 uses XF86Config-fbdev as XF86Config after install so you have a gui available immediatly. However, if you want to actually use the hardware and thus no virtual framebuffer you must edit XF86Config. Personally, I like to use "/usr/X11R6/bin/XFree86 -configure" (caution: this may hang the system as it does before I download new nVidia drivers) as it will auto detect everything then all I have to do is go in and edit resolutions and minor stuff like that.
 
Old 09-05-2002, 05:37 AM   #12
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
OK so it happens with all Window managers, good, it means its not enlightenment's fault, but Yours
make a copy of XF86Config (something like XF86Config.old) and also rename XF86Config-fbdev to anything else. Now re-configure X with either XF86Config or in any other way. Hand hack some minor things in the new XF86Config if it is needed and try startx again. Now you should be running X using your new generated XF86Config. In my opinion it should work, good luck!

About kernel recompile, i highly reccomend you do it, especially in Slack (its easy, just read the HOW-TO or slack on-line book) so you include only the things you need. And you can keep your working kernel as well in case the old one doesnt work.
Hope that helps!

-NSKL
 
Old 09-05-2002, 02:59 PM   #13
enzo250gto
Member
 
Registered: Oct 2001
Location: Tokyo, Japan
Distribution: Slackware
Posts: 105

Original Poster
Rep: Reputation: 15
Thanks for all the help. I did recompile the kernel and when it did for some reason my network card is no longer up. I'm using a different machine for the time being but will let you know the result. I also did the "/usr/X11R6/bin/XFree86 -configure" which I had read in another post. I think I need the driver for my Radeon card and all my problems will go away, I hope.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Buffer I/O error linuxhippy Fedora 4 07-15-2005 06:25 AM
empty buffer cynthia Programming 4 09-20-2004 11:29 AM
IO Buffer Haafiz Linux - General 1 07-14-2004 04:24 PM
recv() buffer linuxanswer Programming 1 03-22-2004 01:11 PM
Frame buffer bkeating Linux - Newbie 6 04-22-2003 07:09 PM


All times are GMT -5. The time now is 07:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration