LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2002, 10:45 PM   #1
Jesus
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Rep: Reputation: 0
Question Framebuffer Console




I am having trouble getting the framebuffer console working on my box. During a new install, I select it and it works; after I recompile my kernel using 2.4.5, if I don't set vga = ask in lilo.conf, I don't get any video. Anyone know how to fix this?
 
Old 04-30-2002, 10:49 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
edit your lilo.conf file in /etc to read vga = whatever and then run /sbin/lilo to make the changes.. and that should make it so you don't have to type vga = whatever at the lilo prompt...
 
Old 04-30-2002, 10:51 PM   #3
Jesus
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Original Poster
Rep: Reputation: 0
If I change the vga= (anything except ask) then I get no video at all. I have lilo set up to boot my old kernel as well and if I set the vga = 791 then that one will work with the framebuffer, but not the new kernel. When I recompiled my kernel, there was no option for framebuffer in the Console area.
 
Old 05-01-2002, 06:43 AM   #4
l_9_l
Member
 
Registered: Dec 2001
Location: New Zealand,Auckland
Distribution: debian
Posts: 86

Rep: Reputation: 15
when you compile your kernel--make sure to enable :
*Code maturity level options
|-Prompt for development and/or incomplete code/drivers

then go to :
*Console drivers

you know what to do now,right?!

good luck
 
Old 05-01-2002, 11:12 AM   #5
Jesus
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Original Poster
Rep: Reputation: 0
I was able to enable framebuffer console after i did that, but i still get no video on boot. I'm using an ATI Radeon 8500, could that have something to do with it?
 
Old 05-01-2002, 03:19 PM   #6
jpweston
Member
 
Registered: Mar 2002
Location: Sacramento, CA
Distribution: Slackware 8.1; Debian 3.0
Posts: 222

Rep: Reputation: 30
I believe there's a setting under/near the frambuffer setting (in the kernel configuration screens) which refers to "Special Video mode" or "Special VGA Mode" - sorry, I'm at work w/o LINUX.

Check in there and see if you find something similar. Enable that and you should be good to go. I'll post the exact info. when I get home.

j.
 
Old 05-02-2002, 01:55 AM   #7
Jesus
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Original Poster
Rep: Reputation: 0
thanx for all of the help that last one got it and its running beautifully now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Console Framebuffer darkarcon2015 Slackware 9 07-16-2005 06:24 PM
Console resolution - framebuffer - won't go away. lymph Linux - General 1 02-15-2005 10:09 AM
having issues with 2.6 and console framebuffer ? untoldone Linux - Newbie 1 03-09-2004 08:22 PM
Framebuffer Console Help Crazed123 Linux - Software 5 07-29-2003 03:10 PM
Framebuffer Console jspenguin Linux - General 3 02-28-2003 09:21 AM


All times are GMT -5. The time now is 08:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration