LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Framebuffer Console (http://www.linuxquestions.org/questions/slackware-14/framebuffer-console-19891/)

Jesus 04-30-2002 10:45 PM

Framebuffer Console
 
:newbie:

I am having trouble getting the framebuffer console working on my box. During a new install, I select it and it works; after I recompile my kernel using 2.4.5, if I don't set vga = ask in lilo.conf, I don't get any video. Anyone know how to fix this?

trickykid 04-30-2002 10:49 PM

edit your lilo.conf file in /etc to read vga = whatever and then run /sbin/lilo to make the changes.. and that should make it so you don't have to type vga = whatever at the lilo prompt...

Jesus 04-30-2002 10:51 PM

If I change the vga= (anything except ask) then I get no video at all. I have lilo set up to boot my old kernel as well and if I set the vga = 791 then that one will work with the framebuffer, but not the new kernel. When I recompiled my kernel, there was no option for framebuffer in the Console area.

l_9_l 05-01-2002 06:43 AM

when you compile your kernel--make sure to enable :
*Code maturity level options
|-Prompt for development and/or incomplete code/drivers

then go to :
*Console drivers

you know what to do now,right?! :)

good luck

Jesus 05-01-2002 11:12 AM

I was able to enable framebuffer console after i did that, but i still get no video on boot. I'm using an ATI Radeon 8500, could that have something to do with it?

jpweston 05-01-2002 03:19 PM

I believe there's a setting under/near the frambuffer setting (in the kernel configuration screens) which refers to "Special Video mode" or "Special VGA Mode" - sorry, I'm at work w/o LINUX.

Check in there and see if you find something similar. Enable that and you should be good to go. I'll post the exact info. when I get home.

j.

Jesus 05-02-2002 01:55 AM

thanx for all of the help that last one got it and its running beautifully now


All times are GMT -5. The time now is 01:44 AM.