LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   For Pat aalib in current (http://www.linuxquestions.org/questions/slackware-14/for-pat-aalib-in-current-4175466581/)

gmgf 06-19-2013 03:23 AM

For Pat aalib in current
 
the aalib package has a dependency on the old gpm package version,

this dependency, make that gimp and gst-plugins-good have dependency on this old gpm version.

rebuild aalib package, gimp and gst-plugins-good package solve this little
problem.

gmgf 06-20-2013 03:07 AM

It seem, gst-plugins-good doesn't compil on recent kernel, it's related to change in v4l code.

Fedora have more patch, for fix this problem:

http://pkgs.fedoraproject.org/cgit/g...it/tree/?h=f19

but, probably v4l-utils need update v4l-utils-0.9.5 is available here:

http://linuxtv.org/downloads/v4l-utils/

BrZ 06-20-2013 01:11 PM

Quote:

Originally Posted by gmgf (Post 4975220)
It seem, gst-plugins-good doesn't compil on recent kernel, it's related to change in v4l code.

Fedora have more patch, for fix this problem:

http://pkgs.fedoraproject.org/cgit/g...it/tree/?h=f19

but, probably v4l-utils need update v4l-utils-0.9.5 is available here:

http://linuxtv.org/downloads/v4l-utils/

Upstream released this commit, but it end with some error like 'V4L2_CID_HCENTER_DEPRECATED' undeclared (first use in this function)', solved by this commit.

There is also this commit to 'fix compilation on older v4l2', but I can't confirm if it work...

ps: v4l-utils-0.9.5-x86_64 and linux-3.9.x

gmgf 06-21-2013 01:22 AM

Ok, i confirm gst-plugins-good-0.10.31, compil on current (kernel-3.9.5) with this fedora patch


http://pkgs.fedoraproject.org/cgit/g...es.patch?h=f19

gmgf 06-23-2013 12:05 AM

Ok, thanks Pat and Robby. it's solved on current. now


All times are GMT -5. The time now is 05:24 AM.