LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   fontconfig-compat32 package breaks VLC build (http://www.linuxquestions.org/questions/slackware-14/fontconfig-compat32-package-breaks-vlc-build-755837/)

Daedra 09-17-2009 04:55 AM

fontconfig-compat32 package breaks VLC build
 
I've just ran into this problem today. Whenever I try to compile VLC using alien bob's slackbuild on Slackware64 it finishes fine. But when I install the multilib packages I get the following error.

/usr/lib64/gcc/x86_64-slackware-linux/4.3.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/lib/libpthread.so when searching for -lpthread
/usr/lib64/gcc/x86_64-slackware-linux/4.3.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/lib/libpthread.a when searching for -lpthread
/usr/lib/libfontconfig.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[5]: *** [liblibass_plugin.la] Error 1
make[5]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.1/modules/codec'
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.1/modules/codec'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.1/modules/codec'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.1/modules'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.1'
make: *** [install] Error 2

I noticed /usr/lib/libfontconfig.so: could not read symbols: File in wrong format and my first impression was that the build is looking at the 32bit library and that is causing the build to fail. So im removed the fontconfig-compat32 package and it finished fine. All is good now I just thought I would post this incase anyone wanted to confirm the error.

Martinezio 09-17-2009 06:23 AM

I have similiar problems with building many packages - this is because of default search path for libtool: /usr/lib is sooner checked, than /usr/lib64, and when libtool find a library by name, it stops searching further - libtool doesn't check the compatibility while searching.
Currently, I've removed all paths from /etc/ld.so.conf, that pointed to 32-bit libraries.
For compatibility packaging, You should use the bash environment script from AlienBob's repository, and for native builds allways set --libdir option for configure script ;) For me - it helps.


All times are GMT -5. The time now is 06:33 PM.