LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-28-2013, 03:31 PM   #16
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912

Thanks Pat, that fixed it here

Quote:
Originally Posted by rg3 View Post
Same effect here. I can fix that by removing the link to 70-yes-bitmaps.conf and adding the one to 70-no-bitmaps.conf in /etc/fonts/conf.d.
I don't have a 70-yes-bitmaps.conf link in /etc/fonts/conf.d, but adding a 70-no-bitmaps.conf breaks terminus in my lxterminal.

Last edited by ponce; 02-28-2013 at 03:32 PM.
 
Old 02-28-2013, 03:37 PM   #17
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 877

Rep: Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827
Quote:
Originally Posted by ponce View Post
Thanks Pat, that fixed it here
Awesome. I think we have a new change on the TODO list.

Quote:
I don't have a 70-yes-bitmaps.conf link in /etc/fonts/conf.d, but adding a 70-no-bitmaps.conf breaks terminus in my lxterminal.
Scratch that idea then.
 
Old 02-28-2013, 03:59 PM   #18
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 514

Rep: Reputation: Disabled
I think I tracked down part of what I'm seeing. I removed all my user configuration files and relied on the system files in /etc/fonts/ alone.

The look of the fonts with the default config files, that is, only the ones that the fontconfig install script links in /etc/fonts/conf.d, is the same with the old and new package.

However, if I add the 10-autohint.conf link, the look of the font changes with the old package but apparently stays the same with the new package.

Edit: I took 4 screenshots.

http://rg3.name/fontconfig/new-with-autohint.png
http://rg3.name/fontconfig/new-without-autohint.png
http://rg3.name/fontconfig/old-with-autohint.png
http://rg3.name/fontconfig/old-without-autohint.png

Last edited by rg3; 02-28-2013 at 04:03 PM.
 
Old 02-28-2013, 04:42 PM   #19
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 651

Rep: Reputation: 92
Quote:
Originally Posted by volkerdi View Post
Maybe this as 70-no-helvetica.conf could help:
Certainly fixed the 'moth-eaten' look of fonts in Firefox for me, thanks
 
Old 02-28-2013, 04:56 PM   #20
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Customised Slackware64-14.1 with multilib
Posts: 237

Rep: Reputation: 55
I'm using the Infinality patchset here on Slack64 current as of 27 Feb. I had hinting on medium and I noticed a slight difference with the upgrade to fontconfig-2.10.2 so I switched hinting to full and the fonts look at least as good as they did before with Qt/Gtk/Tk apps.
 
Old 02-28-2013, 07:06 PM   #21
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 72

Rep: Reputation: 18
The 70-no-helvetica.conf makes things better almost everywhere,
but I still have some weird fonts on one website:

http://i.imgur.com/dVy4OEL.png
 
Old 03-01-2013, 03:04 AM   #22
SwiftTimber-Z80
LQ Newbie
 
Registered: Mar 2013
Posts: 20

Rep: Reputation: Disabled
I installed the recently rebuilt package, Hiragana and katakana japanese fonts are wierd and pixelated now. Kanji and other chinese characters are fine.
 
Old 03-01-2013, 03:14 AM   #23
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 877

Rep: Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827
Quote:
Originally Posted by SwiftTimber-Z80 View Post
I installed the recently rebuilt package, Hiragana and katakana japanese fonts are wierd and pixelated now. Kanji and other chinese characters are fine.
What directory are those fonts in?
 
Old 03-01-2013, 03:24 AM   #24
SwiftTimber-Z80
LQ Newbie
 
Registered: Mar 2013
Posts: 20

Rep: Reputation: Disabled
Quote:
Originally Posted by volkerdi View Post
What directory are those fonts in?
/usr/share/fonts/TTF I believe. Im using sans with gtk2, so in xfcepanel before the hirgana and katakana was smooth.
 
Old 03-01-2013, 03:48 AM   #25
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 877

Rep: Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827
Quote:
Originally Posted by SwiftTimber-Z80 View Post
/usr/share/fonts/TTF I believe. Im using sans with gtk2, so in xfcepanel before the hirgana and katakana was smooth.
No idea then, sorry. The first package had /usr/share/fonts and all subdirectories indexed (which led to problems), so my thought was that maybe they were in a subdirectory of /usr/share/fonts that's not listed in fonts.conf... but that one is.
 
Old 03-01-2013, 04:08 AM   #26
SwiftTimber-Z80
LQ Newbie
 
Registered: Mar 2013
Posts: 20

Rep: Reputation: Disabled
Quote:
Originally Posted by volkerdi View Post
No idea then, sorry. The first package had /usr/share/fonts and all subdirectories indexed (which led to problems), so my thought was that maybe they were in a subdirectory of /usr/share/fonts that's not listed in fonts.conf... but that one is.
Thank you, I just switched to a different font.
 
Old 03-01-2013, 07:53 AM   #27
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,521

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Code:
Fri Mar  1 05:41:39 UTC 2013
ap/groff-1.22.2-i486-1.txz:  Upgraded.
x/fontconfig-2.10.2-i486-2.txz:  Rebuilt.
  Fixed dangling symlink to 20-fix-globaladvance.conf (which was removed).
  Create the symlinks in doinst.sh before running fc-cache.
  Don't include /usr/share/fonts in the fonts.conf font directory list as that
  causes bitmapped fonts to be used.  Thanks to Iouri Kharon.
Nice to see the dangling symlink fixed. This was causing okular to not work for me.
 
Old 03-01-2013, 10:06 AM   #28
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 514

Rep: Reputation: Disabled
It looks like the reason for 10-autohint.conf not to work properly is that it uses mode="append". By creating the following ~/.conf/fontconfig/fonts.conf file I was able to get my fonts exactly as they were in the old package.

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <match target="font">
    <edit name="autohint" mode="assign"><bool>true</bool></edit>
    <edit name="hintstyle" mode="assign"><const>hintfull</const></edit>
    <edit name="rgba" mode="assign"><const>rgb</const></edit>
  </match>
</fontconfig>
 
Old 03-01-2013, 11:34 AM   #29
lonestar_italy
Member
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware
Posts: 65

Rep: Reputation: 0
hi pat,

well, with your latest package things are better, but still slightly different than before.

Here is what I mean:

fontsslack.png

Left side is with fontconfig 2.9.0, right side is with fontconfig 2.10.2-x86_64-2

I have a preference for the rendering on left side.
 
Old 03-01-2013, 12:11 PM   #30
Bazzaah
Member
 
Registered: Mar 2007
Distribution: Slackware64-current, Slackware64 14
Posts: 327

Rep: Reputation: 49
All's well here and looks back to normal, thanks Pat and team.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Glibc rpcsvc vanished in l/glibc-2.14.1-i486-2.txz Jeronimo Barros Slackware 16 02-14-2012 08:08 AM
No qt-doc after installation of qt-r1008952-i486-1.txz from dvd Squall90 Slackware 3 07-13-2010 11:52 PM
kdebase-workspace-4.3.4-i486-1.txz anyone? antitu Slackware 2 06-09-2010 03:21 PM
[SOLVED] slackpkg upgrade-all is not showing "bsd-games-2.13-i486-11.txz" piratesmack Slackware 2 05-16-2010 06:33 PM
[-CURRENT] QScintilla-2.4-i486-1.txz corrupted? raffaele181188 Slackware 3 10-29-2009 03:49 AM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration