LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   fontconfig-2.10.2-i486-1.txz and firefox/thunderbird (http://www.linuxquestions.org/questions/slackware-14/fontconfig-2-10-2-i486-1-txz-and-firefox-thunderbird-4175451882/)

burdi01 02-27-2013 06:57 AM

fontconfig-2.10.2-i486-1.txz and firefox/thunderbird
 
Current: After applying this morning's updates (Wed Feb 27 04:58:17 UTC 2013) the texts in Firefox and Thunderbird look somewhat "corroded" (thinner). I think fontconfig-2.10.2-i486-1.txz is the obvious candidate to blame.
Anyone (other than me ;)) seeing this?
:D

willysr 02-27-2013 07:04 AM

Yes, i have seen it too when i tried to write something on Echofon

lonestar_italy 02-27-2013 08:14 AM

Yes, fonts are looking "weird" everywhere, not just Firefox/Thunderbird.

GazL 02-27-2013 08:24 AM

Based on observation and playing around with the font setting in xfce, it seems that the defaults might have changed and fontconfig is using full or medium hinting by default, making the characters look anorexic.

I have put the following in my ~/.Xresources file
Code:

xft.antialias: true
Xft.hinting:    true
Xft.hintstyle:  hintslight

...and that seems to make the gtk based apps look like they used to - and much better to my eyes.

If you're using xfce or another desktop you might have to play with their respective font settings dialogs as they are likely to override the Xresources. I suspect you'll also find a option somewhere in /etc/fonts/conf.d to set the same values, but as I'm an old-school, basic window-manager kind of guy, the Xresources seem to do the job for me.

lonestar_italy 02-27-2013 09:06 AM

I noticed the new package is missing a file:

/etc/fonts/conf.avail/20-fix-globaladvance.conf

Copied it over from another machine, things seem slightly better but still not exactly back to how they were before upgrading the package.

ponce 02-27-2013 02:12 PM

2 Attachment(s)
Don't want to confuse things more, but I seem to have spotted a deprecation warning of the file /etc/fonts/conf.d/50-user.conf.

I removed it (it's a symlink), renamed also ~/.fonts.conf, rebooted and set Slight font hinting and antialiasing with lxappearance (I could have used for this also the ~/.Xresources file, like GazL hints above, because it's checked in my ~/.xinitrc file for LXDE): this seems to have fixed things here.

I've just one web page where I still see unhinted fonts (scaled), really dunno why http://github.com.

EDIT: added a sample of the effect when opening a new window (the small preview) and part of the webpage.

cgorac 02-28-2013 04:00 AM

I've noticed the same. In my case, the fix was to move ~/.fonts.conf to ~/.config/fontconfig/fonts.conf (I think ~/.fonts.conf is/was where anti-aliasing/hinting/etc. should be set, to be DE independent). It also fixes annoying warning emitted by /etc/fonts/conf.d/50-user.conf.

matusz 02-28-2013 05:11 AM

It didn't fix the problem for me. After downgrading fontconfig everything is fine.

burdi01 02-28-2013 06:01 AM

For XFCE 4.10 (which is what I use) the font properties are set via Start > Settings > Appearance > Fonts. These properties are kept in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml.
Changing these rendering settings has no effect on my ~/.fonts.conf file: it keeps saying "hintfull". (Manually) editing the file to read "hintslight" resolved the firefox/thunderbird font change.

Actually my ~/.fonts.conf file has not changed since 2011-05-03. Interesting might be which Feb 27 update (fontconfig, mesa, xorg-server ?) made firefox/thunderbird react differently.

To get rid of the nasty "reading configurations from ~/.fonts.conf is deprecated" messages I created a ~/.config/fontconfig/conf.d directory and moved my ~/.fonts.conf file to ~/.config/fontconfig/fonts.conf .
:D

rg3 02-28-2013 01:27 PM

My fonts changed too and I'm unable to get them as they were before. Tried all the tricks in the thread.

TommyC7 02-28-2013 01:48 PM

I don't know about anybody else, but in my $HOME directory I'm also getting a "fontconfig" directory which has a bunch of cache's since the fontconfig upgrade.

rg3 02-28-2013 02:49 PM

Quote:

Originally Posted by TommyC7 (Post 4901804)
I don't know about anybody else, but in my $HOME directory I'm also getting a "fontconfig" directory which has a bunch of cache's since the fontconfig upgrade.

I have that directory too, but the last modification date is from Feb 16, the same as the most recent file in there, so it seems unrelated to the fontconfig upgrade.

rg3 02-28-2013 02:53 PM

Quote:

Originally Posted by ponce (Post 4901033)
Don't want to confuse things more, but I seem to have spotted a deprecation warning of the file /etc/fonts/conf.d/50-user.conf.

I removed it (it's a symlink), renamed also ~/.fonts.conf, rebooted and set Slight font hinting and antialiasing with lxappearance (I could have used for this also the ~/.Xresources file, like GazL hints above, because it's checked in my ~/.xinitrc file for LXDE): this seems to have fixed things here.

I've just one web page where I still see unhinted fonts (scaled), really dunno why http://github.com.

EDIT: added a sample of the effect when opening a new window (the small preview) and part of the webpage.

Same effect here. I can fix that by removing the link to 70-yes-bitmaps.conf and adding the one to 70-no-bitmaps.conf in /etc/fonts/conf.d.

TommyC7 02-28-2013 03:08 PM

Quote:

I have that directory too, but the last modification date is from Feb 16, the same as the most recent file in there, so it seems unrelated to the fontconfig upgrade.
For mine it's Feb. 27th and I know for a fact I never had it before.

volkerdi 02-28-2013 03:26 PM

Quote:

Originally Posted by rg3 (Post 4901829)
Same effect here. I can fix that by removing the link to 70-yes-bitmaps.conf and adding the one to 70-no-bitmaps.conf in /etc/fonts/conf.d.

As far as I know, the Slackware fontconfig package has never linked either of those files in /etc/font/conf.d. I've been applying a patch to fonts.conf to keep fontconfig from using the 100dpi and 75dpi directories by default, but it wouldn't help if bitmapped fonts were in any of the other directories. Perhaps it would be better (and more flexible) to drop the patch and include a link to 70-no-bitmaps.conf?

I also had a report that the new fontconfig was trying to use the Helvetica font (Liberation fonts claims this one), and that could possibly be causing some of the font changes. Maybe this as 70-no-helvetica.conf could help:

Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Disable Helvetica, it doesn't look nice with everything else -->
  <selectfont>
    <rejectfont>
      <pattern>
        <patelt name="family"><string>Helvetica</string></patelt>
      </pattern>
    </rejectfont>
  </selectfont>
</fontconfig>

BTW, I've always thought that the default font choices in most browsers are somewhat subpar and have long set my own local font preferences. This might be why I didn't see much of a difference when I upgraded fontconfig here.


All times are GMT -5. The time now is 12:21 AM.