LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-01-2003, 08:55 AM   #1
zybreak
LQ Newbie
 
Registered: Feb 2003
Distribution: CRUX
Posts: 15

Rep: Reputation: 0
Unhappy Font problems


Hi

when i viewed a webpage in linux with mozilla i noticed that the font s appeared very small and not with the same font as it was displayed in windows, later i installed kylix where the fonts where also strange. How can i check if i have all the fonts necessary and do i have any True Type fonts installed?

I'm using Slackware 8.1 and installed the Freetype library.
 
Old 02-01-2003, 05:48 PM   #2
pesho_p
Member
 
Registered: Oct 2002
Location: 42 42' N, 23 19' E
Distribution: Slackware 8.1
Posts: 77

Rep: Reputation: 15
Quote:
I'm using Slackware 8.1 and installed the Freetype library.
You mean FreeType 2.1.x, right?
Did you enable bytecode interpreter before compile? If not then see README.UNX (or it was .UNIX?) and you'll see what I mean.

Quote:
when i viewed a webpage in linux with mozilla i noticed that the font s appeared very small and not with the same font as it was displayed in windows, later i installed kylix where the fonts where also strange. How can i check if i have all the fonts necessary and do i have any True Type fonts installed?
1. Are you shure that your Xft libraries are setup properly? I mean did you add something like:
Code:
# Font directories.
dir "/usr/X11R6/lib/X11/fonts/TTF"

match 
   any size < 14 
   any size > 8
   edit antialias=false;
in your '/etc/X11/XftConfig' (for Xft-1) and:

Code:
<!-- Font directory list --> 

<dir>/usr/X11R6/lib/X11/fonts/TTF</dir> 
<dir>/usr/share/fonts</dir> 
<dir>~/.fonts</dir> 

<!-- Disable antialiasing for fonts less than 14 points --> 

   <match target="pattern"> 
      <test qual="any" name="size" compare="less"> 
         <double>14</double> 
      </test> 
      <edit name="antialias" mode="assign"> 
         <bool>false</bool> 
      </edit> 
   </match> 

<!-- Don't allow fonts smaller than 6 points --> 

   <match target="pattern"> 
      <test qual="any" name="size" compare="less"> 
         <double>6</double> 
      </test> 
      <edit name="size" mode="assign"> 
         <double>6</double> 
      </edit> 
   </match>
in '/etc/fonts/fonts.conf' (for Xft-2 respectively)?

2. Do you have X's 'render' extension enabled and working? You can find out this by typing 'xdpyinfo | grep -c -i render' in command prompt. It must return '1'.

3. Are you shure that you're using Xft enabled Mozilla (./configure --enable-xft --add_here_your_other_options)? You can find such package for Slackware allredy compiled here or here (but I can't guarantee you that last package is Xft enabled).

4. Do you have some high quality TrueType fonts installed in '/usr/X11R6/lib/X11/fonts/TTF' (or sometimes 'truetype' as opposed to 'TTF')? Like those from Microsoft for example. You can find them here or here (last package even will do the dirty work by installing them for you ). Or mount your Windows partition (if you have one) and copy fonts from '%systemdir%/Fonts' (where %systemdir% is X:\Windows or X:\WINNT depending of your Windows version, but if you're running Windows 9x make SHURE that it is AT LEAST 95 OSR 2.x - if my memory serves me right - i.e. that fonts are Unicode)). Then you must run 'ttmkfdir' inside diectory holding your new fonts:

# ttmkfdir -o fonts.dir
# cp fonts.dir fonts.scale

and then add path to that directory in your XF86Config and XftConfig. Or, if you're usinf font server, you must add that path on top in '/etc/X11/fs/config'. It should look like this way, for example: 'catalogue=/usr/X11R6/lib/X11/fonts/TTF'. Then you must restart your font server of course.

5. Try to run your X with 'startx -- -dpi 96' or maybe even 'startx -- -dpi 133' (default value is 72 dpi (that is 'Dots Per Inch')). Under Windows, just for example, default value is 96 (so called 'Small Fonts").

6. Kinda stupid suggestion but... you can increase/decrease fonts sizes with Ctrl+'+' and Ctrl+'-' in Mozilla/Phoenix.

7. Change default fonts used by Mozilla: Edit -> Preferences -> Appearance -> Fonts. For example:

Proportional: Sans Serif
Serif: Tmes New Roman/Georgia
Sans-serif: Arila/Tahoma/Veranda
Monospace: Courier/Courier New
Fantasy: Webdings/Wingdings

ans so on. It's up to you

Well... that's it. Now you must have nice and smooth fonts on your Slackware setup. HTH

For your viewing pleasure: http://www.geocities.com/pesho_pv/index.html (2-nd image from top to bottom)

PS Sorry for my English but this is not my native language.
 
Old 02-02-2003, 07:30 AM   #3
zybreak
LQ Newbie
 
Registered: Feb 2003
Distribution: CRUX
Posts: 15

Original Poster
Rep: Reputation: 0
the FreeType i installed was that which came on the CD...

i have not done any file configurations myself so i will check all settings you recommended.

And Thanks for you reply, lets hope my fonts will get normal after a little configuration, (maby an update of FreeType?)
 
Old 02-02-2003, 07:59 AM   #4
zybreak
LQ Newbie
 
Registered: Feb 2003
Distribution: CRUX
Posts: 15

Original Poster
Rep: Reputation: 0
ok, i checked some things, i dont have this file '/etc/fonts/fonts.conf'

and the xdpyinfo | grep -c -i render returned 0

i dont have a folder named /usr/X11R6/lib/fonts/TrueType althou i have a /usr/X11R6/lib/fonts/TTF with a few lux* fonts.

my freetype library is version 1.3.1.

I got a little confused when u spoke of xft-2.

by this info, is there anything you can directly say that i need to do (im just a confused newbie who needs guidance)

and english isnt my natvie language either
 
Old 02-02-2003, 02:57 PM   #5
pesho_p
Member
 
Registered: Oct 2002
Location: 42 42' N, 23 19' E
Distribution: Slackware 8.1
Posts: 77

Rep: Reputation: 15
Quote:
ok, i checked some things, i dont have this file '/etc/fonts/fonts.conf'
This simply means that you don't have Xft 2.x (font configuration and customization library) installed on your system. You'll need this one in conjunction with FreeType 2.1.x (font engine), Xft enabled Mozilla and some high quality TrueType fonts if you want nice looking final result.
Quote:
and the xdpyinfo | grep -c -i render returned 0
This menas that you don't have 'render' extension (or it's not loaded) either
Quote:
i dont have a folder named /usr/X11R6/lib/fonts/TrueType althou i have a /usr/X11R6/lib/fonts/TTF with a few lux* fonts.
Aaah, I see. Plain Slackware installation without any modifications. No wonder that your fonts look strange (to say the least...).

Before we may continue can you please post your XF86Config and XftConfig files here (both can be found in '/etc/X11') or send them to 'pesho_pv at yahoo dot com'. Can you also tell me which desktop manager you're using? What is your video card? How you configure your X after installation. What Mozilla version are you using?

And don't worry; I'm newbie too (maybe no more than 7-8 months experience). Just don't give up, fight with problems one by one and in the final reckoning you'll succeed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new font problems.... Mr-Imbroglio Slackware 5 09-25-2005 08:16 PM
Font problems markb658 Red Hat 2 05-12-2005 03:00 PM
More font problems AndrewB Mandriva 3 03-25-2005 02:29 AM
Font pRoBLeMs :S the_sLiDe Linux - Software 6 11-30-2004 06:00 PM
Font problems... gpetzold Linux - Software 2 07-13-2003 02:56 PM


All times are GMT -5. The time now is 08:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration