LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2004, 02:40 AM   #1
cemer
LQ Newbie
 
Registered: Sep 2004
Posts: 7

Rep: Reputation: 0
Font problem at Slackware 10.0


Hi,

I have installed all available fonts in the Slackware 10.0 cd.
Although Cyrillic fonts are also shown as installed I could never
see them rendered. A box with 4 numbers is displayed instead.

What should I do to see them??
Please help!
Thanks
Cem


Here is the listing of my my fonts dir.

cemer@cemux:/usr/X11/lib/fonts$ ls -al
total 183
drwxr-xr-x 13 root root 352 2004-08-06 23:39 ./
drwxr-xr-x 16 root root 1008 2002-03-13 06:32 ../
drwxr-xr-x 2 root root 79760 2004-08-06 23:15 100dpi/
drwxr-xr-x 2 root root 79760 2004-08-06 23:14 75dpi/
drwxr-xr-x 2 root root 144 2004-08-06 23:14 CID/
drwxr-xr-x 2 root root 432 2004-08-06 23:14 Speedo/
drwxr-xr-x 2 root root 872 2004-07-12 16:13 TTF/
drwxr-xr-x 2 root root 1984 2004-07-12 16:13 Type1/
drwxr-xr-x 2 root root 2816 2004-08-06 23:39 cyrillic/
drwxr-xr-x 3 root root 1272 2004-08-06 23:14 encodings/
-rw-r--r-- 1 root root 190 2004-08-06 23:39 fonts.cache-1
drwxr-xr-x 2 root root 80 2004-08-06 23:14 local/
drwxr-xr-x 2 root root 17064 2004-08-06 23:14 misc/
drwxr-xr-x 2 root root 600 2004-08-06 23:14 util/
 
Old 09-03-2004, 03:50 AM   #2
kaon
Member
 
Registered: Dec 2003
Location: Hong Kong SAR
Distribution: Slackware 9.1, 10.x, slackware-current
Posts: 186

Rep: Reputation: 30
have u ran fc-cache, mkfontscale, mkfontdir for the font path?
 
Old 09-03-2004, 09:26 AM   #3
cemer
LQ Newbie
 
Registered: Sep 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Yep.

I've done that right after I realized I have the problem.
Please note that all the fonts here are installed together with
everything during the installation, since I opted for full install.

Here is the contents of fonts.cache-1:

cemer@cemux:/usr/X11/lib/fonts$ cat fonts.cache-1
"CID" 0 ".dir"
"TTF" 0 ".dir"
"misc" 0 ".dir"
"util" 0 ".dir"
"75dpi" 0 ".dir"
"Type1" 0 ".dir"
"local" 0 ".dir"
"Speedo" 0 ".dir"
"encodings" 0 ".dir"
"100dpi" 0 ".dir"
"cyrillic" 0 ".dir"

here is the contents of the Cyrillic directory:

cemer@cemux:/usr/X11/lib/fonts/cyrillic$ ls
crox1c.pcf.gz crox2hbo.pcf.gz crox4h.pcf.gz crox6hbo.pcf.gz koi6x9.pcf.gz
crox1cb.pcf.gz crox2ho.pcf.gz crox4hb.pcf.gz crox6ho.pcf.gz koi7x14.pcf.gz
crox1cbo.pcf.gz crox2t.pcf.gz crox4hbo.pcf.gz crox6t.pcf.gz koi7x14b.pcf.gz
crox1co.pcf.gz crox2tb.pcf.gz crox4ho.pcf.gz crox6tb.pcf.gz koi8x13.pcf.gz
crox1h.pcf.gz crox2tbo.pcf.gz crox4t.pcf.gz crox6tbo.pcf.gz koi8x16.pcf.gz
crox1hb.pcf.gz crox2to.pcf.gz crox4tb.pcf.gz crox6to.pcf.gz koi8x16b.pcf.gz
crox1hbo.pcf.gz crox3c.pcf.gz crox4tbo.pcf.gz fonts.alias koi9x15.pcf.gz
crox1ho.pcf.gz crox3cb.pcf.gz crox4to.pcf.gz fonts.cache-1 koi9x15b.pcf.gz
crox1t.pcf.gz crox3cbo.pcf.gz crox5h.pcf.gz fonts.dir koi9x18.pcf.gz
crox1tb.pcf.gz crox3co.pcf.gz crox5hb.pcf.gz fonts.scale koi9x18b.pcf.gz
crox1tbo.pcf.gz crox3h.pcf.gz crox5hbo.pcf.gz koi10x16b.pcf.gz koinil2.pcf.gz
crox1to.pcf.gz crox3hb.pcf.gz crox5ho.pcf.gz koi10x20.pcf.gz proof9x16.pcf.gz
crox2c.pcf.gz crox3hbo.pcf.gz crox5t.pcf.gz koi12x24.pcf.gz screen8x16.pcf.gz
crox2cb.pcf.gz crox3ho.pcf.gz crox5tb.pcf.gz koi12x24b.pcf.gz screen8x16b.pcf.gz
crox2cbo.pcf.gz crox3t.pcf.gz crox5tbo.pcf.gz koi5x8.pcf.gz
crox2co.pcf.gz crox3tb.pcf.gz crox5to.pcf.gz koi6x10.pcf.gz
crox2h.pcf.gz crox3tbo.pcf.gz crox6h.pcf.gz koi6x13.pcf.gz
crox2hb.pcf.gz crox3to.pcf.gz crox6hb.pcf.gz koi6x13b.pcf.gz

In the Cyrillic directory, fonts.cache-1 file is empty.
However, fonts.dir file has some contents like:

crox1c.pcf.gz -cronyx-courier-medium-r-normal--14-100-100-100-m-80-koi8-r
crox1cb.pcf.gz -cronyx-courier-bold-r-normal--14-100-100-100-m-80-koi8-r
crox1cbo.pcf.gz -cronyx-courier-bold-o-normal--14-100-100-100-m-80-koi8-r
(similar lines - truncated)

Thanks
Cem
 
Old 09-03-2004, 09:38 AM   #4
kaon
Member
 
Registered: Dec 2003
Location: Hong Kong SAR
Distribution: Slackware 9.1, 10.x, slackware-current
Posts: 186

Rep: Reputation: 30
Three things to check.

1) Make sure you have included the path that contains your Cyrillic fonts in /etc/X11/xorg.conf.

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
# If you don't have a floating point coprocessor and emacs, Mosaic or other
# programs take long to start up, try moving the Type1 and Speedo directory
# to the end of this list (or comment them out).
#

FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/" //This one

2) I am not sure about this one, but better check it out. I think you make need extra font module. (Sorry for that)

# This loads the font modules
Load "type1"
Load "freetype"
Load "speedo"

3) Look it up in ur lang.sh, make sure your system environment supports koi8.

Hopes this help.
 
Old 09-03-2004, 09:48 AM   #5
cemer
LQ Newbie
 
Registered: Sep 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Now I am looking at those modules.

Initially all I can say that, there is no "cyrillic" module:

cemer@cemux:/usr/X11R6/lib/modules/fonts$ ls -l
total 524
-r--r--r-- 1 root root 83052 2004-06-06 00:43 libbitmap.a
-r--r--r-- 1 root root 48484 2004-06-06 00:48 libfreetype.so
-r--r--r-- 1 root root 72104 2004-06-06 00:43 libspeedo.a
-r--r--r-- 1 root root 206232 2004-06-06 00:43 libtype1.a
-r--r--r-- 1 root root 116324 2004-06-06 00:43 libxtt.a

I don't know if it is the reason but I am searching the net to
find it out.

I am going to check the kernel configuration as well, in case
there is a KOI support and has not been compiled in.

Thanks
Cem
 
Old 09-03-2004, 09:51 AM   #6
kaon
Member
 
Registered: Dec 2003
Location: Hong Kong SAR
Distribution: Slackware 9.1, 10.x, slackware-current
Posts: 186

Rep: Reputation: 30
Quote:
I am going to check the kernel configuration as well, in case
there is a KOI support and has not been compiled in.
Tough I am a newbie, I believe kernel native language support should be one of the key to it.
 
Old 09-03-2004, 02:18 PM   #7
cemer
LQ Newbie
 
Registered: Sep 2004
Posts: 7

Original Poster
Rep: Reputation: 0
I've modified the rc.modules to load some nls modules at boot time.
They seem to be loaded successfuly. Here is lsmod info:

nls_koi8_ru 1668 0
nls_koi8_u 5120 1
nls_koi8_r 5120 0
nls_iso8859_9 4224 0
nls_utf8 1792 0

However still there is no luck with the display of the Russian chars.

I really don't know what to do else!

Please HELP!!!...
Cem


Here is the fc-list:

cemer@cemux:~$ fc-list
Luxi Serif:style=Regular
Utopia:style=Bold Italic
Bitstream Vera Sans Mono:style=Bold
Luxi Serif:style=Bold
Bitstream Vera Sans:style=Oblique
Luxi Mono:style=Bold
Utopia:style=Bold
Bitstream Vera Sans:style=Roman
Bitstream Charter:style=Bold Italic
Luxi Sans:style=Bold
Courier:style=Bold Italic
Luxi Sans:style=Regular
Courier:style=Regular
Cursor:style=Regular
Bitstream Charter:style=Regular
Bitstream Vera Sans Mono:style=Oblique
Courier 10 Pitch:style=Bold Italic
Luxi Mono:style=Regular
Bitstream Charter:style=Italic
Bitstream Vera Sans:style=Bold
Courier 10 Pitch:style=Italic
Utopia:style=Italic
Bitstream Vera Serif:style=Roman
Bitstream Vera Sans Mono:style=Bold Oblique
Luxi Serif:style=Oblique
Bitstream Vera Sans:style=Bold Oblique
Luxi Serif:style=Bold Oblique
Bitstream Vera Sans Mono:style=Roman
Luxi Mono:style=Oblique
Courier 10 Pitch:style=Regular
Luxi Sans:style=Oblique
Courier:style=Italic
Courier 10 Pitch:style=Bold
Luxi Sans:style=Bold Oblique
Bitstream Vera Serif:style=Bold
Luxi Mono:style=Bold Oblique
Courier:style=Bold
Utopia:style=Regular
Bitstream Charter:style=Bold
 
Old 09-03-2004, 03:32 PM   #8
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Do a "xfonsel" and play with "encdng" menu. You'll see that there are no fonts with cp125x on list. koi is also messed up. KDE and others further filter the list and you end up with no available cyrillic fonts to draw - chronic Slackware problem.

With all the hoopla about butiful Vera fonts, they are not unicode

You just need to get more TTF fonts with cyrillic in it.

If you have access to a "cyrillic-capable" computer, (and read some Russian)
- go http://fonts.gets.ru/
- download the Arial, Courier, Times sets (italic, bold, it-bold, normal)
- install in the ttf folder.
- See it they showup in xfontsel
- look at gorgeous fonts.

Last edited by suslik; 09-03-2004 at 03:34 PM.
 
Old 09-05-2004, 12:03 PM   #9
cemer
LQ Newbie
 
Registered: Sep 2004
Posts: 7

Original Poster
Rep: Reputation: 0
You are right about the cp125x encoding.
However, there is the "cronyx" font available with "r" encoding and
"koi8" registry.

Is it not Cyrillic? I can see Russian characters in the preview.
(But I cannot read Russian)

I will get new fonts and try them with xfontsel.
Thanks for the tip.
Cem

ADDITION:

Also I realized there are more KOI8 fonts already. They are visible
by the xfontsel. However, the "fc-list" command returns very small
subset of what is available at xfontsel.

I think KDE only uses the fonts which are visible through "fc-list".

Another point is, OpenOffice.org started working with the Russian
characters, although I have not installed any additional fonts yet...

Cem


Last edited by cemer; 09-05-2004 at 12:28 PM.
 
Old 09-05-2004, 05:53 PM   #10
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Quote:
Originally posted by cemer
You are right about the cp125x encoding.
However, there is the "cronyx" font available with "r" encoding and
"koi8" registry.
Is it not Cyrillic? I can see Russian characters in the preview.
(But I cannot read Russian)
The thing is, before that font gets to the screen, it has to filter through the QT, KDE, and become a unicode page in the process. The problem is not the complete absence of cyrillic fonts, but that the bad ones (only that kind comes with slack by default) are filtered out through the process, or, display horribly.

I managed to make the built-in cyrillic fonts work once, but found the days spent on it wasted. I.e. Looking at a mixed eng-russian web page english letters and numbers are well scaled and antialiased (those were probably Vera), cyrillic is small, horrid and scales only in increments of 4-5 point. Ugh..

Installing external unicode fonts is really the only way to cyrillic happiness.
 
Old 09-06-2004, 05:22 AM   #11
cemer
LQ Newbie
 
Registered: Sep 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Here is the report:

finally I solved the problem, but in an unexpected way:

I found some new fonts to install and installed to the X11 directory.
However, they did not work!

I started playing with KDE and saw the Fonts link between the
Devices and LAN Browser links. I decided to give it a try.
I copied fonts from the X11 directory to Personal fonts dir.
All fonts were copied automatically to .fonts and then I started
to see anything in Russian!...

Apparently installation into personal fonts directory is better
working than the installation into the X11 directory manually.
There is something missing in the installation to X11 via
"fc-cache, mkfontscale, mkfontdir", but I don't know what.

Afterwards, I removed all the NLS modules from the kernel
and rebooted. Nothing broken. Apparently I don't need the
NLS modules for a successful KDE environment.

Thanks all the help.
Cem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Logo Font!?? FreakboY Slackware 6 11-18-2011 05:49 PM
Slackware 10.1 console font problem? Hosiah Slackware 2 06-17-2005 12:25 AM
Slackware 10.1 and a serious font problem c0m4 Slackware 6 05-18-2005 09:39 AM
Slackware 9.1 Font issues ncognito Slackware 2 12-04-2003 08:31 AM
font issues in Slackware 9.0 gnumber9 Slackware 1 04-07-2003 04:42 AM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration