LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2010, 01:12 PM   #1
SpelledJ
Member
 
Registered: Jun 2006
Location: Birmingham, AL
Distribution: Slackware64-13.1, 12.1
Posts: 119

Rep: Reputation: 20
font issues on slackware64-current


I've installed slackware64-current from a 1/31/10 iso created by Eric's mirror-slackware-current script and my rsync mirror. I'm having a lot of problems getting fonts to look readable. Firefox looks particularly bad both in the UI and rendering fonts inside pages themselves. Black on white text has a lot of red/orange and blue fringing that reminds me of the Apple II from 30 years ago.

I've recompiled freetype with all three patches from the -current slackbuild. I've got anti-aliasing enabled in KDE with no exclusions and RGB hinting. I've tried slight, medium, and full and can't tell much difference among them. I didn't notice much improvement from the base install to after I rebuilt freetype.

I've tried following Dugan Chen's guide under "Rebuilding your font rendering subsystem" but can't even get past the freetype re-compile using his slackbuild and the 2.3.11 sources. I thought this might be a -current vs. stable 13.0 issue, or possibly differences between the 2.3.9 freetype in current and the 2.3.11 that Dugan suggests. The configure step seems to work okay, but make stops at target "unix".

Other details - I have an ATI Radeon HD4670 and I'm using the radeonhd open source driver. I haven't used the closed source fglrx driver yet because it appears to require multilib and I haven't set it up yet. I'm using a 17" LCD monitor at 1280x1024 also.

Any suggestions? Anyone used Dugan's freetype-2.3.11 slackbuild on current? Would the fglrx driver help?
 
Old 02-17-2010, 01:34 PM   #2
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 504

Rep: Reputation: Disabled
EDIT: Wrong thread.

Last edited by rg3; 02-17-2010 at 01:36 PM.
 
Old 02-17-2010, 02:29 PM   #3
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Can you post the error message in the compile output?

And if it says something like "see this file for more details," then can you post the relevant parts from that file as well?

Last edited by dugan; 02-17-2010 at 02:30 PM.
 
Old 02-17-2010, 03:05 PM   #4
SpelledJ
Member
 
Registered: Jun 2006
Location: Birmingham, AL
Distribution: Slackware64-13.1, 12.1
Posts: 119

Original Poster
Rep: Reputation: 20
I'm away from my slackware box right now, but I'll post the actual error this evening. IIRC, it was "make: nothing to do for target `unix'", but I'll verify and post some output. Thanks for checking in on this, Dugan.
 
Old 02-17-2010, 05:41 PM   #5
gauchao
Member
 
Registered: Dec 2009
Distribution: SLACKWARE 14.1 64bit
Posts: 157

Rep: Reputation: 24
Quote:
Black on white text has a lot of red/orange and blue fringing that reminds me of the Apple II from 30 years ago.
Come on, that was nice, wasn't it? (Sorry for the joke; Apple ][ was my all-time favourite PC)

Best wishes!
 
Old 02-17-2010, 06:14 PM   #6
SpelledJ
Member
 
Registered: Jun 2006
Location: Birmingham, AL
Distribution: Slackware64-13.1, 12.1
Posts: 119

Original Poster
Rep: Reputation: 20
Heh heh, sorry Gauchao - I was a Commodore64 man. Er, kid.

Dugan -
Two mistakes on my part:

1. I gave the wrong error message earlier. It was:
Code:
checking build system type... i486-slackware-linux-gnu                                                                                                       
checking host system type... i486-slackware-linux-gnu                                                                                                        
checking for gcc... gcc                                                                                                                                      
checking for C compiler default output file name...                                                                                                          
configure: error: in `/tmp/SBo/freetype-2.3.11/builds/unix':                                                                                                 
configure: error: C compiler cannot create executables                                                                                                       
See `config.log' for more details.                                                                                                                           
make: *** [setup] Error 77
I hadn't noticed the config.log message earlier - I found it and discovered:
Code:
configure:2539: gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
conftest.c:1: error: CPU you selected does not support x86-64 instruction set
Which made me realize mistake #2: I used your Slackbuild as-is and forgot to change the ARCH to x86_64. This is my first 64-bit x86 machine and I'm not in the habit of watching for those differences yet.

After changing the ARCH, it built fine and installed. I need to restart X and continue building your other packages so I'll give an update later.
 
Old 02-17-2010, 06:36 PM   #7
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Which made me realize mistake #2: I used your Slackbuild as-is and forgot to change the ARCH to x86_64. This is my first 64-bit x86 machine and I'm not in the habit of watching for those differences yet
I just set this line in /etc/profile so I always have that covered :
Code:
export ARCH="x86_64"
Saves you remembering to check when compiling anything.
 
Old 02-17-2010, 09:56 PM   #8
SpelledJ
Member
 
Registered: Jun 2006
Location: Birmingham, AL
Distribution: Slackware64-13.1, 12.1
Posts: 119

Original Poster
Rep: Reputation: 20
Okay, all done. Dugan, all of the packages built and installed just fine on -current. I installed the webcore package and the Droid fonts and it made a huge improvement. I've still got a lot of tweaking to do. I had everything looking good and then I started fiddling with the font settings in Firefox. I've now got things a little smaller than I can comfortably read. But, I think the backend rendering is working very well. Thanks for your packaging efforts. That was very easy to set up.

Also thanks for the tip about putting ARCH in /etc/profile, bgeddy. That will probably save me some headaches as I finish setting up my new rig.
 
Old 02-18-2010, 06:59 AM   #9
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 419

Rep: Reputation: 45
@Dugan Chen

I found something wrong with your freetype.SlackBuild, in about line 80:
Code:
   80 if [ $USE = "ubuntu"  ]; then
   81   echo -e "\033[1mApplying Cleartype patches...\033[0m"
   82   patch -p1 < "${FILESDIR}"/${P}-ubuntu.patch
   83   echo -e "\033[1mAll Cleartype patches applied\033[0m"
   84 fi
Why apply "Cleartype" patches when use "ubuntu"? Ok, it's all about messages and is trivial.

And 10-no-sub-pixel.conf is in /etc/fonts/conf.avail rather than /etc/fonts/conf.d

Last edited by grissiom; 02-18-2010 at 07:07 AM.
 
Old 02-18-2010, 09:16 AM   #10
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Quote:
Originally Posted by grissiom View Post
@Dugan Chen

I found something wrong with your freetype.SlackBuild, in about line 80:
Code:
   80 if [ $USE = "ubuntu"  ]; then
   81   echo -e "\033[1mApplying Cleartype patches...\033[0m"
   82   patch -p1 < "${FILESDIR}"/${P}-ubuntu.patch
   83   echo -e "\033[1mAll Cleartype patches applied\033[0m"
   84 fi
Why apply "Cleartype" patches when use "ubuntu"? Ok, it's all about messages and is trivial.
I did notice that about a month ago, but forgot to post the fixed version. Thanks for reminding me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] libmp4v2-v1.5.0.2 in slackware64-current escaflown Slackware 5 02-14-2010 04:06 PM
[SOLVED] slackware64-current and Amarok2 issues ... max242 Slackware 3 11-10-2009 04:20 AM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 06:50 PM
Getting packages for Slackware64-current. glore2002 Slackware 13 08-25-2009 06:28 PM
Slackware64-current on a second HD. glore2002 Slackware 7 08-23-2009 11:38 AM


All times are GMT -5. The time now is 10:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration