LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Fn key does not control backlight on Acer Aspire One D270-1410 (http://www.linuxquestions.org/questions/slackware-14/fn-key-does-not-control-backlight-on-acer-aspire-one-d270-1410-a-945631/)

CW_OP 05-17-2012 11:49 PM

Fn key does not control backlight on Acer Aspire One D270-1410
 
I installed Slackware 13.37 on a Acer Aspire One D270-1410.
The Fn + Left or Right arrow should adjust screen brightness.
In KDE or Xfce the screen brightness controls do not work.
However the brightness graph does come up on the screen in KDE.

I went into system settings,shortcuts and gestures,global keyboard shortcuts, and set the monitor brightness key settings in custom option. However this did not work.

I have a INTEL VGA graphics controller. I tried xbacklight -set 50 on the command line but it did nothing.
Any ideas?

Babertje 05-18-2012 01:13 AM

boot/reboot your laptop open bootloader in edit-mode ( e on grub ) and insert "acpi_backlight=vendor" (without quotes) at the kernel line

CW_OP 05-18-2012 10:02 PM

I am new to linux i have never messed with boot loader.
 
Thanks for your reply I looked at the lilo boot loader section in the slackbook website. It mentions running liloconfig or editing the /etc/lilo.conf file and running lilo to save your changes.

Is this what you meant by boot loader?

And should i replace "acpi_backlight=vendor" with "acpi_backlight=Acer" since thats my vendor?

san 05-19-2012 07:07 AM

"vendor" should be sufficient, see https://bbs.archlinux.org/viewtopic.php?id=74829

reboot your machine, once the lilo screen appears hit <TAB>, then enter
Code:

$LABEL acpi_backlight=vendor
LABEL will be something like Linux, Slackware, 3.3.5 or whatever is displayed at the top of the screen.

in case it works, edit /etc/lilo.conf; adding a line containing
Code:

append="acpi_backlight=vendor"
if there already is such a line, just add the parameter.

save and run /sbin/lilo; then reboot.

onebuck 05-19-2012 08:25 AM

Member response
 
Hi,

I will add that you should be cautious by the use of 'append' within a image stanza;
Quote:

excerpt from 'man lilo.conf';
KERNEL OPTIONS (image=)
If the booted image is a Linux kernel, then one may pass command line parameters to this kernel.

addappend=<string>
(22.6) The kernel parameters from the specified string, are concatenated to the parameter(s) from an append= specification (see
below). The string must be enclosed within double quotes. Usually, the previous append= will specify parameters common to all
kernels by appearing in the top, or global, section of the configuration file and addappend= will be used to add local parameter(s)
to an individual image. Addappend= may be used only once per "image=" section.

append=<string>
Appends the options specified to the parameter line passed to the kernel. This is typically used to specify hardware parameters
that can't be entirely auto-detected or for which probing may be dangerous. Multiple kernel parameters are separated by a blank
space, and the string must be enclosed in double quotes. A local append= appearing withing an image= section overrides any global
append= appearing in the top section of the configuration file. Append= may be used only once per "image=" section. To concatenate
parameter strings, use "addappend=". Example:

append="mem=96M hd=576,64,32 console=ttyS1,9600"
If you read the above definition for 'addappend' and you wish to include the kernel parameter within the stanza for a particular boot image to allow the additional passing by concatenating the parameter to a global kernel parameter(s). If you use the append within the stanza then global parameter will be over written by the append within the stanza.

chirag07 03-12-2013 07:36 AM

Brightness key does not work for me too.
 
hello,
i have installed ubuntu on one of my drive and then i have installed slackware in another drive and i have not installed lilo.
with the help of grub of ubuntu i am able to boot slackware but i am not able decrease the brightness.

acpi_backlight=vendor

works for me fine iiin ubuntu...but as i don`t have grub in slackware...can you please suggest me how to reduce the brightness of my laptop.i have acer aspire 5750z model laptop.


All times are GMT -5. The time now is 05:12 AM.