LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-11-2005, 04:57 PM   #1
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Rep: Reputation: 30
fluxbox, black screen after 10 minutes


Running FluxBox (the one that comes with Slack10.1), and after 10 minutes of inactivity my screen goes black. If I move the mouse, it comes back. I'd prefer if it just never went black at all (or maybe set it to 2 hours or something). I have apm disabled in rc.modules, so I don't know what else this could be. Any ideas?

PS: I DO have KDE installed (just qt, arts, libs, base, and network packages), but I don't run it as my wm. I checked kcontrol, but didn't see anything related to this (screensaver is disabled in there). Might I have to install the kdeadmin package (if KDE is the culprit here, I mean)?
 
Old 04-11-2005, 05:02 PM   #2
Berto
Member
 
Registered: Sep 2003
Location: Stevenson, WA, USA
Distribution: Slackware
Posts: 232

Rep: Reputation: 30
Run the command "xscreensaver -demo" and take a look at the settings tab.

PS APM doesn't affect your monitor turning off, that's DPMS; which can be disabled in your .xinitrc or .xsession file and putting in the command "xset -dpms" or something (run "man xset" for a full list of options, or "xset -help"

Last edited by Berto; 04-11-2005 at 05:05 PM.
 
Old 04-11-2005, 05:11 PM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
That a configuration of the X server. If you want to disable it you've to edit your /etc/X11/xorg.conf.
You can find information about this with man xorg.conf and going to the ServerFlags section, it says the default BlankTime it's 10 minutes. I don't know how to disable because the only option is the delay time, but I guess passing 0 should do it.
Take a look at your xorg.conf if you've a Section "ServerFlags" and if you don't create it and make it look like:
Code:
Section "ServerFlags"
Option "BlankTime"  "0"
EndSection
You can also set this while X is running with the xset command (see it's man page).

Last edited by gbonvehi; 04-11-2005 at 05:12 PM.
 
Old 04-11-2005, 05:31 PM   #4
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Original Poster
Rep: Reputation: 30
I opened up xscreensaver -demo and it said the screensaver daemon wasn't running. So for now I am going with the xorg.conf option "BlankTime". I'll update you guys with what happens in 10 minutes
 
Old 04-11-2005, 05:53 PM   #5
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Quote:
Originally posted by gbonvehi
That a configuration of the X server. If you want to disable it you've to edit your /etc/X11/xorg.conf.
You can find information about this with man xorg.conf and going to the ServerFlags section, it says the default BlankTime it's 10 minutes. I don't know how to disable because the only option is the delay time, but I guess passing 0 should do it.
Take a look at your xorg.conf if you've a Section "ServerFlags" and if you don't create it and make it look like:
Code:
Section "ServerFlags"
Option "BlankTime"  "0"
EndSection
You can also set this while X is running with the xset command (see it's man page).
Curious... Do you think DPMS can be disabled with the false option? Here's my (old), but still working great video setup. Maybe I'll try to add and see if it works.

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "RIVA TNT2"
Driver "nv"
Option "DPMS" "false"
EndSection

KC
 
Old 04-11-2005, 06:03 PM   #6
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Original Poster
Rep: Reputation: 30
yeah, so the BlankTime option works. I have it set to 0 for now. Thanks very much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
Startx results in a black screen with VGA and screen errors kwosource Linux - Newbie 4 03-11-2005 03:58 PM
Screen goes blank after about 10 minutes jmax24 Linux - General 3 04-19-2004 09:05 PM
screen blackens after few minutes ichbinesderelch Linux - General 1 08-19-2003 11:36 AM
Screen goes black every few minutes Seph64 Linux - General 2 02-15-2003 02:00 AM


All times are GMT -5. The time now is 06:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration