LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-10-2003, 07:34 PM   #1
m32
Member
 
Registered: Feb 2003
Location: Cedar Park, TX
Distribution: Slackware 9.0, RH 9
Posts: 39

Rep: Reputation: 15
Fluxbox and KDM/GDM on Slack 8.1


Have installed fluxbox in preparation for the fact that if I ever go beyond 8.1, I'm going to lose enlightenment. (sob)

I can run it if I type xinit /usr/local/bin/fluxbox.

But that is the only way I'm successful with it. I've tried to start from kdm or gdm, but no luck with either. FWIW, I think gdm looks nicer (at least the dropline version). With gdm, I at least get the fluxbox option to show up in the choices, but then when choosing it, the screen goes blank for a while, and then kicks back to gdm.

Here's what I've tried, based on searches in this forum.

KDM:

Added " fluxbox)
exec /usr/local/bin/fluxbox
;;

to the Xsession file. AS stated before it doesn't show up as an option.

Under /etc/X11/xinit I added an xinitrc.fluxbox file that I essentially copied from the others, except changing the wm to fluxbox.

In gdm/Sessions/ , I added a Fluxbox file containg /usr/local/bin/fluxbox. It at least shows up in the choices, but like I said, doesn't run.


Thanks for any tips. Of course, running it, I still have a slight preference for e (except for the crappy fonts), but would at least like to try and figure this out.
 
Old 04-10-2003, 07:43 PM   #2
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Rep: Reputation: 30
See the thread I started titled:

Got Fluxbox?

Someone shared their .xinit with me.
 
Old 04-10-2003, 08:24 PM   #3
m32
Member
 
Registered: Feb 2003
Location: Cedar Park, TX
Distribution: Slackware 9.0, RH 9
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by hecresper
See the thread I started titled:

Got Fluxbox?

Someone shared their .xinit with me.
No, that doesn't add the fluxbox option to kdm, or reallly solve the gdm issue. Yes, that's a nice tip for having the default change when I type "startx" but that doesn't address my issue here.
 
Old 04-10-2003, 08:37 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,971
Blog Entries: 11

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Edit your
/opt/kde/share/config/kdm/kdmrc

and add
fluxbox to the line
SessionTypes =

Edit your
/usr/X11R6/lib/X11/xdm/Xsession

and add
fluxbox)
exec fluxbox
;;

to the case statement with all the other
window-managers ... :)


HIH!


Cheers,
Tink
 
Old 04-10-2003, 08:52 PM   #5
m32
Member
 
Registered: Feb 2003
Location: Cedar Park, TX
Distribution: Slackware 9.0, RH 9
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Tinkster
Edit your
/opt/kde/share/config/kdm/kdmrc


Thanks, Tinkster. That was what did it. Didn't know where that drop down list was being generated. Now I do. Thanks for your help.
 
Old 04-10-2003, 08:54 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,971
Blog Entries: 11

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Pleasure mate ... :)

Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GDM to KDM Pr_009 Fedora 1 11-23-2005 05:14 AM
Kdm -> Gdm thesystem Ubuntu 1 10-11-2005 08:02 PM
kdm,gdm darkangel29 Linux - General 2 09-25-2005 12:26 AM
how to use gdm instead of kdm? mking007 Suse/Novell 5 10-15-2004 11:01 PM
gdm overwrites /etc/gdm/Session/fluxbox _flaab_ Mandriva 0 12-21-2003 10:58 AM


All times are GMT -5. The time now is 12:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration