LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-06-2012, 12:40 PM   #1
VolvoxNo9
LQ Newbie
 
Registered: Dec 2010
Posts: 6

Rep: Reputation: 0
Flash Player Plugin 11 takes ages to load at some occasions


Hi

This is about the flash-player-plugin.
I am running Slackware32 13.37 on a Samsung R510-Aura T5750 Melroi laptop.
uname -a says 2.6.37.6-smp #2 SMP Sat Apr 9 23:39:07 CDT 2011 i686 Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz GenuineIntel GNU/Linux

I built and installed the SlacklBuilds package of the flash-player-plugin for version 11.2.202.235, which is the newest this day.

The problem is, that this version sometimes starts to load for app. 20 seconds which it shouldn't. For example before playing a video or after playing a video or when resizing a video etc.
During this load time the whole opera/seamonkey browser is stuck and sometimes all other processes are stuck as well. Then I am forced to wait until it goes on.
Other problems: Sometimes after some key actions (which I couldn't figure out yet) the colors are somehow swapped too (like red-blue or something). Then when I open a terminal I can see the contents of the flash-plugin in front of the black terminal, which is wrong.

So obviously the whole flash plugin is broken. I had this with older versions of flash-player-plugin 11 already.

What can I do against this?
I don't want to install version 10 because there are security flaws.

Do you have this problem and how do you handle it?

If you need more information, I'm glad to help out!

Thanks in advance
 
Old 06-06-2012, 09:07 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
I googled quickly and it looks like your laptop has nVidia graphics, which was my guess. If it does *not* have an nVidia graphics card then ignore everything I say. A recent Flash 11 update broke hardware acceleration on nVidia cards so people looked like smurfs and videos would cover everything. You can disable hardware acceleration entirely by placing the following in /etc/adobe/mms.cfg:
Code:
OverrideGpuValidation=true
EnableLinuxHWVideoDecode=0
Or see here which supplies a patch for the nVidia drivers (or more specifically libvdpau). This is really Adobe's fault, not nVidia's, and the requirement to patch vdpau is frankly insulting; however, since Adobe has proudly declared it is abandoning Linux, you have few options available. I don't know how the patch affects other applications but you can try it and hope for the best if you want to maintain hardware acceleration of Flash content (which would be a good idea on a laptop).
 
Old 06-07-2012, 01:39 PM   #3
VolvoxNo9
LQ Newbie
 
Registered: Dec 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Hey

Thank you for your help, but I'm afraid, I did something wrong, because all errors are still there.
I tried editing /etc/adobe/mms.cfg, but it didn't exist, so I created it freshly being root and rebooted.

Are the rights okay?

drwxr-xr-x 2 root root 4096 Jun 7 19:01 adobe

-rw-r--r-- 1 root root 55 Jun 7 19:02 mms.cfg

Is the content okay?

PHP Code:
bash-4.1# cat /etc/adobe/mms.cfg 
OverrideGpuValidation=true
EnableLinuxHWVideoDecode
=0

bash
-4.1
I have the feeling, that my new file was not looked up at all.

What did I do wrong?

EDIT: Yes, my graphics cards is a GeForce 9200M GS.

Last edited by VolvoxNo9; 06-07-2012 at 07:02 PM.
 
Old 06-07-2012, 08:08 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
I don't see anything wrong but just in case right-click on a flash video and make sure hardware acceleration is turned off in the settings. If it still doesn't work there's always the patch to try, but the above solution did work for me in Slackware 13.37 using Alien Bob's flashplayer-plugin package.
 
Old 06-08-2012, 12:41 PM   #5
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 145

Rep: Reputation: 47
On my system with a GeForce 9300M GS and nVidia 295.53, I have the following in /etc/adobe/mms.cfg:
OverrideGpuValidation=true
EnableLinuxHWVideoDecode=1

in .bash_profile:
export VDPAU_NVIDIA_NO_OVERLAY=1

If I disable Hardware acceleration I get blue skin in flash videos
 
Old 06-08-2012, 02:11 PM   #6
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 215

Rep: Reputation: 65
I also have the blue-tinted videos with Flashplayer 11.2.
(9600 GT and the 295.49 proprietary driver)

There's a good thread on the issue over at the Arch forums.

I used the work-around first mentioned in post #119...
https://bbs.archlinux.org/viewtopic....98365#p1098365

I also modified the libvdpau script from slackbuilds.org
to apply a patch from git to bring libvdpau-0.4.1 up to commit 426251,
then apply the "fix" from the libvdpau mailing list.
http://lists.freedesktop.org/archive...ay/000022.html

I'll attach the SlackBuild. In case someone might find it useful.

It adds a configuration file (/etc/vdpau_wrapper.cfg) that shouldn't need any editing,
and requires the libvdpau-0.4.1 source tarball.
Attached Files
File Type: txt libvdpau.tar.gz.txt (6.4 KB, 17 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
YaST2 takes ages to load General Suse/Novell 15 06-07-2007 10:08 AM
copying from pc to usb-connected mp3-player takes ages; suse 10.0 ungua Suse/Novell 2 03-28-2006 07:00 AM
X takes ages and ages to load! dcdbutler Slackware 9 03-23-2005 08:53 AM
mozilla takes ages to load and mouse crashes in flulbox hubabuba Linux - Software 1 12-12-2004 11:44 AM
Webpages/Email takes ages to load after period of inactivity Robstro Linux - Networking 1 05-26-2004 02:31 AM


All times are GMT -5. The time now is 10:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration