LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-24-2008, 03:47 AM   #31
firebird
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 41

Rep: Reputation: 15
Possible solution for Opera


I have the same problem with Opera 9.61 (flash won't load). Later I found that the real problem is flash10 needs libnss3.so, which is provided by firefox but not opera.

I updated /etc/ld.so.conf to add:
Code:
/usr/lib/firefox
And then run (as root):
Code:
ldconfig
After that, Opera can load flash without problem.

I'm not on my slackware box right now, so I'm not quite sure about the directory name Please verify before you make change. I should also mention I'm using -current.

Last edited by firebird; 10-24-2008 at 03:51 AM. Reason: Add information about slackware release.
 
Old 10-24-2008, 05:30 AM   #32
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Quote:
Originally Posted by firebird View Post
I updated /etc/ld.so.conf to add:
Code:
/usr/lib/firefox
And then run (as root):
Code:
ldconfig
Nice, it works perfectly now with Opera. Not so much luck with Konqueror as it causes nspluginviewer to crash. But no big deal, I disable plugins on Konqueror for my everyday browsing. Thanks for the tip (and to con aslo, opera -debugplugin shows the same problem).
 
Old 10-24-2008, 08:40 AM   #33
rangertang
LQ Newbie
 
Registered: Aug 2008
Posts: 27

Rep: Reputation: 15
Uhm...I have a problem with Flash 10.0.12.36 plugin in my Konqueror.
At first, I cannot install the plugin from the official install package. So I installed FireFox 3.0.3, and then installer functioned. But another problem is the Flash can work in FireFox but cannot work in Konqueror. I checked Konqueror's configuration and find the Flash path, /usr/lib/firefox/plugins, is in the plugin folder list. I click the "Scan for Plugins" button, still no use.
Anyone successfully installed Flash 10.0.12.36 plugin in Konqueror? Please tell me how. Thanks!
 
Old 11-12-2008, 10:47 PM   #34
ashik.rock
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Rep: Reputation: 0
hello,


i installed mozilla firefox

i am runing oracle its only run in firefox

so its ask plugins

how can i install plugin's

plz tell me any one urgent recurment sir
 
Old 11-18-2008, 06:54 AM   #35
veeall
Member
 
Registered: May 2007
Location: Estonia
Distribution: Slackware 12.1, slackware64-current
Posts: 255

Rep: Reputation: 43
Quote:
Originally Posted by rangertang View Post
Uhm...I have a problem with Flash 10.0.12.36 plugin in my Konqueror.
At first, I cannot install the plugin from the official install package. So I installed FireFox 3.0.3, and then installer functioned. But another problem is the Flash can work in FireFox but cannot work in Konqueror. I checked Konqueror's configuration and find the Flash path, /usr/lib/firefox/plugins, is in the plugin folder list. I click the "Scan for Plugins" button, still no use.
Anyone successfully installed Flash 10.0.12.36 plugin in Konqueror? Please tell me how. Thanks!
Ive been using kmplayer for latest flash in konqueror, see http://kmplayer.kde.org/news.php
and http://www.kde-apps.org/content/show...ID=ca03e058b90 brief how-to in comments.
 
Old 02-08-2009, 05:45 AM   #36
El Nigromante
Member
 
Registered: Aug 2008
Distribution: Slackware 12.2, Slackware 13.0
Posts: 40

Rep: Reputation: 17
Quote:
Originally Posted by veeall View Post
Ive been using kmplayer for latest flash in konqueror, see http://kmplayer.kde.org/news.php
and http://www.kde-apps.org/content/show...ID=ca03e058b90 brief how-to in comments.
Hi, I have sucessfully set up flash in konqueror (Slackware 12.2), following the instructions in:

http://mikearthur.co.uk/2007/12/konq...e-flash-howto/

For this to work, you need to compile kmplayer with npp support. You can do it modifying the slackbuild (found at http://slackbuilds.org/repository/12...edia/kmplayer/ ):

Code:
--- kmplayer.SlackBuild 2009-02-08 11:43:48.000000000 +0100
+++ /usr/doc/kmplayer-0.10.0c/kmplayer.SlackBuild       2009-02-07 14:39:22.000000000 +0100
@@ -63,9 +63,10 @@
   --prefix="$KDEPREF" \
   --enable-shared=yes \
   --enable-static=no \
-  --without-gstreamer \
+  --enable-npplayer=yes \
   --build=$ARCH-slackware-linux \
   --host=$ARCH-slackware-linux

 make
 make install DESTDIR=$PKG
 
  


Reply

Tags
flash, konqueror, opera, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio missing in Flash Player Plugin netjack Ubuntu 3 11-25-2007 01:41 PM
Flash player plugin problem saravanavelu Linux - General 4 06-05-2007 07:49 AM
Problem with Flash player Plugin chakribobby Linux - Software 4 01-29-2007 09:22 PM
About flash player plugin satimis Fedora 5 05-12-2006 10:51 AM
Mplayer Plugin for firefox VS Flash Player waelaltaqi Linux - Software 3 01-28-2006 06:08 AM


All times are GMT -5. The time now is 05:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration