LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Flash audio player stops working in slackware 13.37 (http://www.linuxquestions.org/questions/slackware-14/flash-audio-player-stops-working-in-slackware-13-37-a-913267/)

kanzer 11-13-2011 01:13 AM

Flash audio player stops working in slackware 13.37
 
I have azap installed the latest version of flash player and from the first time you install it worked well,
The problem is that at any moment cease to hear the flash player in firefox, sometimes sound, sometimes not
if I put in the terminal and playing a video on youtube

Code:

root@localhost:~#firefox
I get the following:

Code:

ALSA lib pcm_dmix.c: 1018: (snd_pcm_dmix_open) unable to open slave
thanks for your help

cfdisk 11-14-2011 06:09 AM

The rule of thumb in such situation is reinstall/upgrade.

1.Make sure you have the latest FF version. It's 8.0, otherwise get it:

Code:

# slackpkg update


# slackpkg upgrade-all

2. Adobe patches its Flash like crazy. Get the latest Adobe Flash Player version 11.1.102.55 tarball

http://get.adobe.com/flashplayer/

untar it and then put this file "libflashplayer.so" into ".mozilla/firefox/vh153zah.default/plugins/" folder

Restart FF.

Take care.

brianL 11-14-2011 06:14 AM

Quote:

Originally Posted by cfdisk (Post 4523535)
Get the latest Adobe Flash Player version 11.1.102.55 tarball

http://get.adobe.com/flashplayer/

untar it and then put this file "libflashplayer.so" into ".mozilla/firefox/vh153zah.default/plugins/" folder

Restart FF.

Take care.

No. Put libflashplayer.so in /usr/lib/mozilla/plugins.

cfdisk 11-14-2011 08:22 AM

Quote:

No. Put libflashplayer.so in /usr/lib/mozilla/plugins
Well, it's a matter of security taste.

I won't put such a vulnerable piece of, ahem, Swiss cheese, into a root-privileged folder.

There are enough unpatched zero-day Flash exploits for the rest of our lives. :D

kanzer 11-15-2011 11:32 AM

Quote:

Originally Posted by cfdisk (Post 4523535)
The rule of thumb in such situation is reinstall/upgrade.

1.Make sure you have the latest FF version. It's 8.0, otherwise get it:

Code:

# slackpkg update


# slackpkg upgrade-all

2. Adobe patches its Flash like crazy. Get the latest Adobe Flash Player version 11.1.102.55 tarball

http://get.adobe.com/flashplayer/

untar it and then put this file "libflashplayer.so" into ".mozilla/firefox/vh153zah.default/plugins/" folder

Restart FF.

Take care.

I do the work when

but after rebooting again runs out of audio and gives me the same error

cfdisk 11-15-2011 10:22 PM

Disable all FF add-ons/extentions/plugins except Flash and see the difference.

If you are still unable to figure out what's going on, try Chrome. There is a long discussion on another thread about Chrome vs FF, check it out for details.

Take care.

ruario 11-16-2011 12:43 AM

Quote:

Originally Posted by cfdisk (Post 4523622)
Well, it's a matter of security taste.

I won't put such a vulnerable piece of, ahem, Swiss cheese, into a root-privileged folder.

There are enough unpatched zero-day Flash exploits for the rest of our lives. :D

It makes zero difference from a security perspective. The plugin is going to run with the privileges of the user running the browser, no matter what directory you put it in. You aren't any more or less secure just because you kept the file in your home directory.

brianL is correct. Put it in /usr/lib/mozilla/plugins then it can be used by all browsers on your system. They pretty much all look in that directory, e.g. if you had Opera installed it would also find the plugin if it was in /usr/lib/mozilla/plugins/.

ottavio 11-16-2011 06:52 AM

Quote:

Originally Posted by kanzer (Post 4522690)
I have azap installed the latest version of flash player and from the first time you install it worked well,

How have you installed it? And, according to Adobe's instruction, have you deleted the old plugin(s)? That could be the key.

brianL 11-16-2011 07:10 AM

If you use the SlackBuild to install it, you'll find libflashplayer.so goes in /usr/lib/mozilla/plugins. How much more proof do you need to show that is the right place for it?

kanzer 11-16-2011 12:53 PM

still does not work

I have installed "flash player Linux 11.1.102.55 Mozilla, Firefox, SeaMonkey" and "firefox 8.0"

in console error:

Code:

ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
others details:
Code:

bash-4.1# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)


Code:

bash-4.1# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and:

Code:

bash-4.1# aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=Intel
    HDA Intel, STAC92xx Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Digital
    IEC958 (S/PDIF) Digital Audio Output


cfdisk 11-18-2011 11:27 AM

Joint the fight! Uninstall the Flash Player plugin.

http://occupyflash.org/

onebuck 11-18-2011 12:02 PM

Hi,

Quote:

Originally Posted by cfdisk (Post 4527651)
Joint the fight! Uninstall the Flash Player plugin.

http://occupyflash.org/

Not the place for this type of post. Your post has nothing to contribute to the Original Post. Possibly open a new thread in <General> : This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

ottavio 11-19-2011 03:41 AM

Quote:

Originally Posted by cfdisk (Post 4527651)
Joint the fight! Uninstall the Flash Player plugin.

http://occupyflash.org/

Nice resource. I didn't know I could view some videos on Youtube only with html5. I am running Firefox Nightly (9.0.x), I have disabled Flash and I can still watch about 50% of videos I'm interested in. I wish we could rid of Flash as soon as possible.

cfdisk 11-19-2011 04:37 AM

@kanzer

Hey, man, where are you hiding?
Don't you see that I got my face slapped while trying to assist you? :banghead:

I gave you some ideas about disabling possibly conflicting FF add-ons and trying Chrome, which you missed either ignored.

Come on, solve you problem and make me believe that we live in the perfect world. :rolleyes:

kanzer 11-19-2011 01:50 PM

disable it and just let the supplements and flash and still does not work


All times are GMT -5. The time now is 08:15 AM.