LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-05-2008, 10:12 AM   #1
auntyjack
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Rep: Reputation: 0
fish:// broken after upgrade to 12.1


Hi
I regularly use fish:// from konqueror and kate for remote access and editing. After upgrading from 12.0 to 12.1 i permanently get:

An error occurred while loading fish://aunty@192.168.0.4:
The process for the fish://192.168.0.4 protocol died unexpectedly.

when trying to connect from the upgraded machine. It doesn't make any difference if i try to connect as a different user, or to a different machine.

When I sit at one of the other machines - which are still running 12.0 - i can connect to the 12.1 box perfectly well, as well as to other 12.0 machines.

any clues much appreciated,
aunty
 
Old 10-05-2008, 12:04 PM   #2
Road_map
Member
 
Registered: Jan 2007
Distribution: Slackware
Posts: 341

Rep: Reputation: 31
You can try to comment all lines in ~/.ssh/known_hosts file.
 
Old 10-07-2008, 08:01 AM   #3
auntyjack
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
nahh it's not that. i can do a normal ssh shell login from the 12.1 machine without any problems.
 
Old 10-09-2008, 03:47 PM   #4
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,453

Rep: Reputation: Disabled
It's not really an answer to your question, but sshfs (available at slackbuilds.org) should allow you to achieve the same goal.

Brian
 
Old 10-23-2008, 10:21 PM   #5
auntyjack
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
thanx for that brian. just got back to it. the sshfs works beautifully - .tgz available at linuxpackages.

fish:// still not working tho . . . odd !!

aunty
 
Old 10-23-2008, 11:37 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,475

Rep: Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530
I'm no expert with fish, but what happens when you try fish://localhost?

Are you running the remote ssh daemon on a non-standard port?

Last edited by Woodsman; 10-23-2008 at 11:40 PM.
 
Old 10-24-2008, 07:11 AM   #7
auntyjack
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Ahh . . good thought, but alas . . .
An error occurred while loading fish://localhost:
The process for the fish://localhost protocol died unexpectedly.
also, am using standard ports for everything.

Last edited by auntyjack; 10-24-2008 at 07:12 AM.
 
Old 10-24-2008, 07:49 AM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,322

Rep: Reputation: 71
is it slackware 12.1 stable or current version
I upgraded slackware 10.0 to 12.1 (stable) and fish:// in konqueror works here...
I deleted the old ~/.kde dir from 10.0 though (my /home is on separate partition so .kde was still here after the upgrade)
 
Old 10-24-2008, 08:06 PM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,475

Rep: Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530
Im using 12.1 fully patched and fish works here. However, looks like this is a common problem for some folks:

http://bugs.kde.org/show_bug.cgi?id=145123

Just some more jabs in the dark:

1. Exit KDE/X and delete all ~/.DCOPserver* files.
2. Empty ~/.ICEauthority and ~.Xauthority (cat /dev/null > .ICEauthority)
3. While not in KDE/X, delete the cache files: ~/.kde/cache-$HOSTNAME/ksycoca
4. Temporarily rename ~/.kde to ~/.kde-old and then start KDE. This should expose whether the problem is related to your KDE settings.

One person suggested a work-around of setting the environment variable KDE_FORK_SLAVES=true.
 
Old 10-25-2008, 02:13 PM   #10
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,242

Rep: Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614
I'm using 12.1 upgraded from 12.0 and fully patched, and fish isn't working for me. I didn't delete .kde though, so that's probably the problem. Since I'm not interested in fish at this moment I won't bother deleting or moving ~/.kde, but I will say that launching konqueror with
Code:
$ KDE_FORK_SLAVES=true konqueror &
does allow fish to work.
 
Old 10-25-2008, 04:07 PM   #11
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,475

Rep: Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530
Curiouser and curiouser. The fish protocol works for me (12.1/3.5.9) and I do not have the KDE_FORK_SLAVES environment variable set on my box.
 
  


Reply

Tags
fish, konquerer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware upgrade - make broken satinet Slackware 15 05-14-2006 01:11 AM
broken ssh after sid upgrade JJX Debian 2 03-29-2006 11:42 PM
broken upgrade mbreith Linux - Software 2 02-08-2006 03:46 PM
Broken X after upgrade barkers Debian 3 10-20-2005 09:36 AM
gbde broken after upgrade. dica *BSD 0 11-30-2004 02:59 AM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration