LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-26-2009, 07:18 AM   #1
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Rep: Reputation: 32
Firefox icon bouncing while loading from GUI.


If I start Firefox from GUI, it starts with its small icon bouncing from a while until it stops and becomes the pointing arrow. No error message is shown. But if I start Firefox from terminal, it starts instantly without showing that bouncing icon so, I guess, there is a mistake somewhere.

Any help will be welcome.

Thanks!
 
Old 08-26-2009, 07:39 AM   #2
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
Part of kde. Have a look for "start-up notification"
 
Old 08-26-2009, 07:39 AM   #3
Michielvw
Member
 
Registered: May 2005
Location: Leicester,UK
Distribution: Slackware
Posts: 108

Rep: Reputation: 19
If I get what you are talking about, this is a KDE thing, called "Enable Launch Feedback" (you haven't said what DE/WM you were using or what slackware version).

Basically it's just a graphical representation what is happening. The reason why this doesn't happen when you launch Firefox from the command line is that the "enable launch feedback" is part of the KDE-dekstoppyness. When you launch from the command line this doesn't even come in play.

Hope that helps

-M
 
Old 08-26-2009, 07:44 AM   #4
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by Michielvw View Post
If I get what you are talking about, this is a KDE thing, called "Enable Launch Feedback" (you haven't said what DE/WM you were using or what slackware version).

Basically it's just a graphical representation what is happening. The reason why this doesn't happen when you launch Firefox from the command line is that the "enable launch feedback" is part of the KDE-dekstoppyness. When you launch from the command line this doesn't even come in play.

Hope that helps

-M
Thanks. I am running Slackwar64-Current (signature) with KDE.
 
Old 08-26-2009, 07:46 AM   #5
Michielvw
Member
 
Registered: May 2005
Location: Leicester,UK
Distribution: Slackware
Posts: 108

Rep: Reputation: 19
Quote:
Originally Posted by glore2002 View Post
Thanks. I am running Slackwar64-Current (signature) with KDE.
I blame it on having less than 4 pots of coffee. ;-). I think the general idea is pretty much the same though. I'll have to run KDE4 later and have a poke around.
 
Old 08-26-2009, 07:46 AM   #6
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by mRgOBLIN View Post
Part of kde. Have a look for "start-up notification"
Thanks for the tip. How can I change those settings to avoid the bouncing ball when starting firefox?
 
Old 08-26-2009, 07:49 AM   #7
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by Michielvw View Post
I blame it on having less than 4 pots of coffee. ;-). I think the general idea is pretty much the same though. I'll have to run KDE4 later and have a poke around.
:-) I need 4 pots or more to get my brain engine up and running too!!!! When you run KDE, please, let me know if you find out the solution.

Thanks again,
 
Old 08-26-2009, 07:51 AM   #8
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
To completely disable the bouncing cursor for all programs -
System Settings - Desktop - Launch Feedback - Change Bouncing Cursor to No Busy Cursor.

To disable just for Firefox -
Right-click the K icon (Menu) and chose Menu Editor - drill down to Firefox - uncheck Enable launch feedback.
 
Old 08-26-2009, 10:24 AM   #9
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Thumbs up

Quote:
Originally Posted by disturbed1 View Post
To completely disable the bouncing cursor for all programs -
System Settings - Desktop - Launch Feedback - Change Bouncing Cursor to No Busy Cursor.

To disable just for Firefox -
Right-click the K icon (Menu) and chose Menu Editor - drill down to Firefox - uncheck Enable launch feedback.
Very clear. Thank you!

I had to disable bouncing ball for all programs. Then it worked. When I disabled just for firefox, the ball was still bouncing.

Last edited by glore2002; 08-27-2009 at 06:46 AM.
 
Old 02-05-2010, 01:48 PM   #10
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
I know this is a bit old but---the issue on my current setup is that Firefox and T'bird both have the "bouncing ball" for maybe 20 seconds after startup. With--eg--OOo, it goes away immediately.

I can however set the timeout shorter....

The puzzle is why the Mozilla apps behave so differently
 
Old 02-05-2010, 02:30 PM   #11
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 215

Rep: Reputation: 65
I posted a link to a patch that will get startup notification working with Firefox/SeaMonkey
on KDE (and I assume Gnome and XFCE).
http://www.linuxquestions.org/questi...-fixed-770773/

You'll have to patch and recompile if you really want this feature.

It was supposed to be fixed in FF 3.6, but wasn't.
The Mozilla devs don't seem to think this simple fix is worth implementing.
They don't seem to spend much time troubleshooting Linux issues.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12.2 and bouncing firefox icon arubin Slackware 10 12-18-2008 07:19 AM
KDE Bouncing Icon Distortion sloik2000 Linux - Software 5 06-18-2007 07:15 PM
Bouncing programs icons keep bouncing for ages blastradius Ubuntu 2 09-10-2005 02:49 AM
Loading Authentication Icon linmix Fedora 0 05-05-2005 05:26 PM
How to create front-end icon (GUI) satimis Programming 1 11-22-2003 04:58 PM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration