LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-12-2010, 01:52 PM   #1
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Rep: Reputation: 38
Firefox default fonts will not display on webpages


Recently I was creating an image in GIMP when I needed to add a new font. I went to my mounted XP drive and copied the file I wanted over into /usr/X11R6/share/fonts/TTF then I went to the font installer as root and installed the font system wide. After that I reloaded GIMP and the font was available. A little while later I went to browse the internet and when I loaded up firefox, it showed a properly formatted and spaced page with no text on it at all. If I highlighted a line, the invisible text would copy to the clipboard properly and I could read it that way. I figured it might've been a just a FF issue, but when I loaded up Seamonkey, I wound up with the same problem. I'm using Firefox 3.0.16 and Seamonkey 2.0.1. I tried going into the preferences and changing the default font, but no matter what I change it to, it doesn't fix it. Slack 1.2 running kernel 2.6.27.31-smp. I use slapt-get to stay up to date and as far as I can tell i have the latest patches and pkgs.

Any idea what I can do, or where I should look? I tried searching the mozilla forums first but I couldn't find an answer. Since I am certain this is a Linux configuration issue, I figured it would be best to post here.

Thanks.

Code:
bash-3.1$ fc-cache -rv
/usr/share/fonts/OTF: caching, new cache contents: 23 fonts, 0 dirs
/usr/share/fonts/TTF: caching, new cache contents: 91 fonts, 0 dirs
/usr/share/fonts/Type1: caching, new cache contents: 64 fonts, 0 dirs
/usr/share/fonts/Speedo: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cyrillic: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/misc: caching, new cache contents: 59 fonts, 0 dirs
/home/mpyusko/.fonts: caching, new cache contents: 178 fonts, 0 dirs
/usr/local/share/fonts: caching, new cache contents: 0 fonts, 0 dirs
/var/cache/fontconfig: not cleaning unwritable cache directory
/home/mpyusko/.fontconfig: cleaning cache directory
/home/mpyusko/.fontconfig: invalid cache file: 86108b4576346ee5cd1d1a664483e2cf-x86.cache-2
/home/mpyusko/.fontconfig: invalid cache file: f15590528d26889972c71dde4e354730-x86.cache-2
/home/mpyusko/.fontconfig: invalid cache file: f886e5737138f50f6847651b046dfd48-x86.cache-2
/home/mpyusko/.fontconfig: invalid cache file: 9c060e9b329ee6e380032be3c452d763-x86.cache-2
fc-cache: succeeded
bash-3.1$
 
Old 02-13-2010, 07:29 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,262

Rep: Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660
MS fonts will often trash Firefox ( Seamonkey ), it seems.
http://www.linuxquestions.org/questi...ighlight=fonts

Suggest : Delete alien fonts = MS , anywhere in /usr/****
And clear the "fonts cache" or whatever stores the information.

Gimp has a fonts/ directory for extras :
/home/<username>/.gimp-2.X/fonts/

Which takes care, that the fonts are invisible for other app's.
.....
 
Old 02-18-2010, 10:09 AM   #3
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Original Poster
Rep: Reputation: 38
Sweeeeeeeet! Thanks for the advice.

I went through /usr/X11R6/share/fonts/TTF and compared the modification dates and times to the ones from XP. Then I deleted the matches (It took like one minute). Then I ran fc-cache again and everything is back to normal.

Thanks again!
 
  


Reply

Tags
firefox, fonts, ttf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iceweasel crashes if I enable webpages to load their fonts saivinob Debian 0 10-13-2007 07:07 AM
Firefox not display using chosen fonts slackiz Linux - Desktop 2 03-06-2007 12:14 AM
Konqueror won't display webpages mdkuser99 Linux - Software 3 03-07-2006 10:54 PM
Ugly fonts on some webpages in Firefox.. RoaCh Of DisCor Linux - Software 3 01-08-2005 09:07 PM
Tryetype fonts weirdness with webpages. Vermu Linux - General 0 07-05-2003 08:35 PM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration