LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-12-2009, 04:25 AM   #1
nir_hp
LQ Newbie
 
Registered: Oct 2004
Location: israel
Distribution: slackware
Posts: 19

Rep: Reputation: 0
Firefox blinks when full-screen.


Hi,

When I whatch firefox on fullscreen it blinks...

anyonw know the solution to this?

I use Nvidia 7600 GT with the latest driver version (if it matters...)
 
Old 11-12-2009, 04:38 AM   #2
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
It is caused by compiz, when you disable it you won't have this issue anymore.

just out of curiosity, post your /etc/X11/xorg.conf
 
Old 11-12-2009, 04:58 AM   #3
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
ok, did some sniffing around and found this. look at the 2nd comment.

it goes like this:
Code:
You can disable unredirecting the following way:
1. open ~/.kde/share/config/kwinrc in an editor
2. go to section [Compositing]
3. Add following line:
UnredirectFullscreen=false
4. Save file and restart kwin (alt+f2 and kwin --replace)
 
Old 11-12-2009, 04:58 AM   #4
nir_hp
LQ Newbie
 
Registered: Oct 2004
Location: israel
Distribution: slackware
Posts: 19

Original Poster
Rep: Reputation: 0
how to disable it?
Attached Files
File Type: txt xorg.txt (1.8 KB, 2 views)
 
Old 11-12-2009, 05:07 AM   #5
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
dont need to disable it, try the second solution i gave.

anyways, run this from your terminal, reboot and then see what happens!
Code:
nvidia-xconfig --use-events \
--render-extension --render-accel --randr-rotation --cool-bits=1 \
--multisample-compatibility --multigpu='Auto' --flip --damage-events \
--dynamic-twinview --enable-acpi-hotkeys --composite \
--allow-glx-with-composite --add-argb-glx-visuals

Last edited by slackd; 11-12-2009 at 05:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox suddenly launches in full screen dflo404 Linux - Software 3 10-19-2009 02:47 PM
Firefox in full screen mode mikedeatworld Linux - Software 2 03-31-2009 11:01 AM
firefox full screen B-Boy Linux - Software 1 08-15-2008 06:00 AM
Full screen Firefox with bash aabfm Linux - Software 7 02-26-2008 01:38 PM
Firefox full screen mikedeatworld Linux - Software 6 08-16-2004 03:42 PM


All times are GMT -5. The time now is 11:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration