LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Firefox blinks when full-screen. (http://www.linuxquestions.org/questions/slackware-14/firefox-blinks-when-full-screen-768622/)

nir_hp 11-12-2009 04:25 AM

Firefox blinks when full-screen.
 
Hi,

When I whatch firefox on fullscreen it blinks...

anyonw know the solution to this?

I use Nvidia 7600 GT with the latest driver version (if it matters...)

slackd 11-12-2009 04:38 AM

It is caused by compiz, when you disable it you won't have this issue anymore.

just out of curiosity, post your /etc/X11/xorg.conf

slackd 11-12-2009 04:58 AM

ok, did some sniffing around and found this. look at the 2nd comment.

it goes like this:
Code:

You can disable unredirecting the following way:
1. open ~/.kde/share/config/kwinrc in an editor
2. go to section [Compositing]
3. Add following line:
UnredirectFullscreen=false
4. Save file and restart kwin (alt+f2 and kwin --replace)


nir_hp 11-12-2009 04:58 AM

1 Attachment(s)
how to disable it?

slackd 11-12-2009 05:07 AM

dont need to disable it, try the second solution i gave.

anyways, run this from your terminal, reboot and then see what happens!
Code:

nvidia-xconfig --use-events \
--render-extension --render-accel --randr-rotation --cool-bits=1 \
--multisample-compatibility --multigpu='Auto' --flip --damage-events \
--dynamic-twinview --enable-acpi-hotkeys --composite \
--allow-glx-with-composite --add-argb-glx-visuals



All times are GMT -5. The time now is 02:57 AM.