LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-22-2008, 03:18 AM   #1
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,220

Rep: Reputation: 177Reputation: 177
Firefox 3.0 + Email links = No Thunderbird?


I just tested this with the official Slackware-current package and my own compiled version of firefox. When ever I click an email link, craigslist for instance, nothing happens, thunderbird doesn't automatically launch like it used to. I checked my about:config mailto settings and they are set for thunderbird. Is anyone else having this problem?
 
Old 06-22-2008, 07:43 AM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,037

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
By default, Firefox (and Thunderbird) don't have what you need to open links in one to the other. Here's two Java(script?) files you can add to your Firefox and Thunderbird prefs.js files so cross-links will work:
Code:
# firefox.js -- append to prefs.js file in .mozilla/firefox tree
#
# To get Thunderbird to handle mail
#
user_pref("network.protocol-handler.app.mailto","/usr/bin/thunderbird");
and
Code:
# thunder.js -- append to prefs.js file in .thunderbird tree
#
# To get Firefox to handle web links
#
user_pref("network.protocol-handler.app.http","/usr/bin/firefox");
user_pref("network.protocol-handler.app.https","/usr/bin/firefox");
user_pref("network.protocol-handler.app.ftp","/usr/bin/firefox");
Shut down both Firefox and Thunderbid then
Code:
cd .mozilla/firefox
cd whatever.default
vi prefs.js
<append the firefox.js above>

cd .thunderbird
cd whatever.default
vi prefs.js
<append the thunder.js above>
You may want to change the path to firefox and thunderbird if they're not installed or linked in /usr/bin.

Hope this helps.
 
Old 06-22-2008, 01:30 PM   #3
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
hmmm I'll have to test this (I don't have T-bird on this machine). Supposedly the Slackware Firefox build script's thunderbird patch is supposed to make it so that T-bird is selected as the default mail handler.

Either way it should be easy to change in the Firefox prefs.
 
Old 06-22-2008, 02:57 PM   #4
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
I can confirm this behavior as well.

When first clicking an email address in Firefox 3 I was prompted with this dialog box asking me to select my preferred email application. However subsequent attempts to send an email yields no response.

I installed Firefox 3 using the official package from the Slackware repository.

I'll tinker with it for a while using tronayne's suggestions above, or I may just go back to FF2. To be honest I didn't really have a need to upgrade anyway except for the lure of a 'bright and shiny' new toy. That'll teach me.

Dig
 
Old 06-22-2008, 04:43 PM   #5
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,037

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
Well, be all that as it may, ya either stick those preference lines in if they ain't there or she ain't gonna do what you want 'er to. Up to y'all...
 
Old 06-22-2008, 09:13 PM   #6
hemp4fuel
Member
 
Registered: Jun 2003
Location: Topeka, KS
Distribution: Slackware
Posts: 192

Rep: Reputation: 45
Quote:
Originally Posted by tronayne View Post
Well, be all that as it may, ya either stick those preference lines in if they ain't there or she ain't gonna do what you want 'er to. Up to y'all...
I followed your directions but still get nothing.
 
Old 06-22-2008, 10:25 PM   #7
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,632

Rep: Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429
If you've got a webmail account then you don't need Thunderbird to handle mailto links anymore. For example, here's how you set Firefox up to use gmail for your mailto links:
http://lifehacker.com/392287/set-fir...r-mailto-links

(Incidentally, Thunderbird mailtos started working for me after I did this!).

While I'm at it, here's how you do it for Fastmail:
http://www.emaildiscussions.com/showthread.php?p=453627

Last edited by dugan; 06-22-2008 at 10:29 PM.
 
Old 06-22-2008, 11:06 PM   #8
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
Quote:
Originally Posted by tronayne View Post
By default, Firefox (and Thunderbird) don't have what you need to open links in one to the other. Here's two Java(script?) files you can add to your Firefox and Thunderbird prefs.js files so cross-links will work:
Code:
# firefox.js -- append to prefs.js file in .mozilla/firefox tree
#
# To get Thunderbird to handle mail
#
user_pref("network.protocol-handler.app.mailto","/usr/bin/thunderbird");
[...]
You should not need to do this as it is already handled by the patch in the Slackware mozilla-firefox package. Here's the thunderbird patch from the slackBuild.
Code:
zcat mozilla-firefox-thunderbird.diff.gz
--- ./defaults/pref/firefox.js.orig	2008-05-29 15:21:26.000000000 -0500
+++ ./defaults/pref/firefox.js	2008-06-17 12:17:37.000000000 -0500
@@ -385,6 +385,7 @@
 pref("browser.xul.error_pages.expert_bad_cert", false);
 
 // We want to make sure mail URLs are handled externally...
+pref("network.protocol-handler.app.mailto", "/usr/bin/thunderbird");
 pref("network.protocol-handler.external.mailto", true); // for mail
 pref("network.protocol-handler.external.news", true);   // for news
 pref("network.protocol-handler.external.snews", true);  // for secure news
Looking in about:config and setting the filter to mailto I can see something like
Code:
gecko.handlerService.schemes.mailto.0.name			Yahoo! Mail
gecko.handlerService.schemes.mailto.0.uriTemplate		http://compose.mail.yahoo.com/?To=%s
gecko.handlerService.schemes.mailto.1.name
gecko.handlerService.schemes.mailto.1.uriTemplate
gecko.handlerService.schemes.mailto.2.name
gecko.handlerService.schemes.mailto.2.uriTemplate
gecko.handlerService.schemes.mailto.3.name
gecko.handlerService.schemes.mailto.3.uriTemplate
network.protocol-handler.app.mailto				/usr/bin/thunderbird
network.protocol-handler.expose.mailto				true
network.protocol-handler.external.mailto			true
network.protocol-handler.warn-external.mailto			false
As the Lifehacker article says, only Yahoo is setup by default. The other three (I'm sure you can add more) slots can be your gmail, etc handlers. Perhaps this feature (including the T-bird handler) doesn't work until it is turned on.

For those of you that just got this working please show your mailto about:config entries.
 
Old 06-23-2008, 12:05 AM   #9
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,632

Rep: Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429
I deleted my .mozilla and .firefox directories, then downloaded the official Firefox 3 binary from mozilla.org and ran that. When I went to Edit->Preferences->Applications,there was a place to set the application to handle mailto links. When I tried to do so, Firefox crashed.

Well, okay, it froze for a few minutes (literally minutes) and then displayed then the "Select Helper Application" dialog.

Can anyone here reproduce this?

EDIT: Yes, I'm getting this consistently.

Last edited by dugan; 06-23-2008 at 01:21 AM.
 
Old 06-23-2008, 12:31 PM   #10
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
I build firefox 3 from source and using thunderbird as the default mailto works here. I do exactly what the slackware patch does only I echo the line to the end of firefox.js

Code:
# Make thunderbird the default mailto handler
echo '
// use Thunderbird as the default external email app
pref("network.protocol-handler.app.mailto", "/usr/bin/thunderbird");' >> \
   $PKG/usr/lib/$PKGNAME/defaults/pref/firefox.js
I use Gnome and if I haven't changed the default apps in "Prefered Applications", a mailto link will open with evolution. Once I change that, firefox starts opening thunderbird instead. So.... That might indicate that it doesn't work...

Is firefox handling it or is my DE? Would seem to be the later. But, I get no crashes like dugan does. Again, I build from source tho.
 
Old 06-24-2008, 06:33 AM   #11
kennyz
LQ Newbie
 
Registered: May 2006
Posts: 4

Rep: Reputation: 0
I maintain the Firefox3 package for Linuxpackages.net, and I am seeing the same problems with the binary release from mozilla.org on a Slackware 12.1 system.

1. Thunderbird no longer opens when I click on a mailto: URL. The preference setting in firefox.js is correct, which is:

pref("network.protocol-handler.app.mailto", "/usr/bin/thunderbird");


2. The Preferences -> Applications panel is empty.


These are probably related in some way.

I have a default Slackware 12.1 system, which is KDE only. I then built orbit2, gconf, gnome-mime-data, and gnome-vfs, since I've read some articles that indicated that those GNOME packages need to be installed.

Nothing changed. Clicking on a mailto: URL still yields nothing, and the Applications panel is still empty.

I really need to solve this, as Slackware users depend on my packages.

Where does the Applications panel retrieve its information from? How can I debug this to determine why no action is being taken when I click on a mailto: URL?

I appreciate any help you can provide.

Thanks,

Ken Zalewski
 
Old 06-24-2008, 08:00 AM   #12
Toods
Member
 
Registered: Dec 2005
Location: UK
Distribution: Slackware 12.1
Posts: 249

Rep: Reputation: 32
The 'Gtk-CRITICAL ..... errors seen when KDE is closed and reported by several people are probably related to this and someone with the 'know-how' should file a bug report on Bugzilla.

Bill.
 
Old 06-24-2008, 09:06 AM   #13
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,632

Rep: Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429
The blank applications panel is a known bug:
http://bugs.gentoo.org/show_bug.cgi?id=228665

I've also read that GNOME needs to be installed, but when I built Firefox from source on a system with Gnome Slacky installed, I got the bug above. When I applied the patch and tried again, I got the crashing I mentioned in my previous post. Interestingly, I did NOT get the blank applications panel when I tried the binary from mozilla.org --- but I did get the crashes.
 
Old 06-24-2008, 04:41 PM   #14
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,220

Original Poster
Rep: Reputation: 177Reputation: 177
Still searching for the answer myself. I can't find a fix either. Oh well the search continues
 
Old 06-24-2008, 05:38 PM   #15
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,632

Rep: Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429
I'll be trying a few more tests, but I think the correct thing to do at this point is to acknowledge that Firefox 3.0 has showstopping bugs, go back to Firefox 2, and then wait for the new version of Firefox 3.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
clicking on links in thunderbird e-mails, firefox can't handle php scripts mbvpixies78 Linux - Software 11 01-02-2008 09:44 AM
Lost links between Firefox and Thunderbird Paraply Linux - Newbie 2 07-17-2007 09:19 PM
Thunderbird- links don't work in downloaded email Earl Parker II Linux - Software 2 01-29-2006 08:33 AM
Links in Thunderbird do not open Firefox on KDE chakatz Linux - Software 4 01-08-2006 09:31 AM
Handling Links with Firefox, Thunderbird, and Gaim apachedude Linux - Software 1 02-11-2005 08:07 AM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration