LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-07-2009, 04:57 PM   #1
AlphaSigmaOne
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 118

Rep: Reputation: 16
Firefox 3.0 and Flash 10.


So I finally upgraded to 12.2. today and with Firefox 3.0, obviously.

However, I seem to be having some problems with with Flash.

I installed it via a build script from Slackbuilds and tested it with youtube and everything seemed okay.

However, I've since experienced a few bugs/crashes. I tried playing a few radio streams that are flash based, but once they started Firefox just locked up. I also tried loading the site for the Star Trek movie. The trailer wouldn't even load, and when I tried to enter the main site, Firefox just closed itself down.

I even tried removing the build package and installing the binary right from adobe, but that didn't seem to make any difference.
 
Old 04-07-2009, 06:06 PM   #2
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.0, 13.1, 13.37, 14.0, 64-14, -current
Posts: 1,506

Rep: Reputation: 499Reputation: 499Reputation: 499Reputation: 499Reputation: 499
Is this on an older system?

I also had flash problems with FF3 on a couple of older systems.

They would work well on youtube but not other sites, and sometimes crash just as you describe.

I found that I had to revert to a flash 9 player on one system to get get it to work at all, and flash 10 works on the other but with some reduced capability (speed, smoothness on non-youtube sites). This was an HP, 1.3ghz PIV, 256mb RAM.

I also found that using the Nvidia driver for the TNT2 helped a lot - I had been using nv, if that applies to you.

EDIT: These were all SW 12.1 by the way, which I upgraded FF from 2 to 3 on.

Last edited by astrogeek; 04-07-2009 at 06:08 PM.
 
Old 04-07-2009, 07:17 PM   #3
swiger
LQ Newbie
 
Registered: Nov 2008
Location: Stuart, Florida USA
Distribution: slackware64-current
Posts: 5

Rep: Reputation: 0
Turn off Hardware Acceleration

Try turning off Hardware Acceleration in Flash settings.
 
Old 04-08-2009, 04:44 AM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
I've also had crashes with it, but I recently realized I didn't really need flash for playing games, so I just switched to gnash (much more stable now, but does not work with every video).
 
Old 04-08-2009, 09:34 AM   #5
AlphaSigmaOne
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 118

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by swiger View Post
Try turning off Hardware Acceleration in Flash settings.
That was actually one of the first things I tried.

I might try and revert back to version 2. I don't really like this one. I've also noticed it seems to hang a lot in KDE.

I actually prefer Konqueror, but flash pretty much doesn't work at all in that.
 
Old 04-08-2009, 03:53 PM   #6
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
I needed to update my video driver to get things working smoothly again.
 
Old 04-08-2009, 11:24 PM   #7
AlphaSigmaOne
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 118

Original Poster
Rep: Reputation: 16
Well, I used the corresponding script from slackbuilds for my card. I'm pretty sure it's the newest one available.

I tried Opera which seems to be okay for a while. Then after I play a few videos or what-not, the sounds starts to crackle and a bit after that it locks.
 
Old 07-06-2009, 09:58 PM   #8
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,139
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Hi all, I'm revisiting this thread because I'm having problems too.

I've got Slackware 12.2 on an AMD computer with 4 GB of RAM and an Nvidia video card.

I'm having whole computer crashes (X freezes, CTRL-Alt-Backspace doesn't work, I can't switch to another virtual terminal).

I've isolated the problems, I think, to when I run Flash in Firefox 3. I did not have the problems until I installed the latest Nvidia driver (and kernel module) from Slackbuilds.org. (The Flash player plugin is from Slackbuilds too.) When I was using the nv driver, Flash worked fine.

One suggestion above was to turn off hardware acceleration for Flash? How do I do that? Is there a global setting, or do I have to turn it off for each movie/radio stream?

Does anyone have any other suggestions?

Thank you,

-Drew
 
Old 07-07-2009, 12:02 AM   #9
swiger
LQ Newbie
 
Registered: Nov 2008
Location: Stuart, Florida USA
Distribution: slackware64-current
Posts: 5

Rep: Reputation: 0
Turn off hardware acceleration for Flash;

Hey Lufbery,

From your Browser, i.e., Firefox, start Flash Player (http://www.humorsphere.com/fun/8787/colortest.swf). Right click, settings, clear the check box "Enable hardware acceleration". If you use a right click mouse then left click inside your Flash Player session. :-)
 
Old 07-08-2009, 09:15 AM   #10
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,139
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Okay, so I turned off hardware acceleration and Flash pretty much stopped working, but the computer did not crash so much.

So I have a few choices:

1) Use FF 3.0 with the nv drivers and Adobe Flash Player plug-in -- this worked nearly perfectly, but I don't have 3D acceleration for things like Google Earth.

2) Use FF 3.0 with the latest Nvidia drivers and Adobe Flash Player plug-in -- this is the current setup that causes crashes. If I avoid flash completely, this works fine.

3) Uninstall the Flash Player -- This also stops the crashes.

4) Use an alternative Flash player? -- I'm trying to get Gnash up and running, but that's not going well.

5) Use another browser with the Adobe Flash Player and Nvidia drivers -- I'll see if the same thing happens with Konqueror and Seamonkey.

6) Fix the dang problem!

The last is my preferred choice. Does anyone have any idea how to fix the problem? Is there some sort of error log I could comb to help diagnose the problem?

Thanks,
 
Old 07-10-2009, 04:00 AM   #11
Daehtop
LQ Newbie
 
Registered: Jun 2009
Location: southeast Missouri
Distribution: Slackware 12.2
Posts: 4

Rep: Reputation: 1
Quote:
Originally Posted by Lufbery View Post
Hi all, I'm revisiting this thread because I'm having problems too.

I've got Slackware 12.2 on an AMD computer with 4 GB of RAM and an Nvidia video card.

I'm having whole computer crashes (X freezes, CTRL-Alt-Backspace doesn't work, I can't switch to another virtual terminal).

I've isolated the problems, I think, to when I run Flash in Firefox 3. I did not have the problems until I installed the latest Nvidia driver (and kernel module) from Slackbuilds.org. (The Flash player plugin is from Slackbuilds too.) When I was using the nv driver, Flash worked fine.

One suggestion above was to turn off hardware acceleration for Flash? How do I do that? Is there a global setting, or do I have to turn it off for each movie/radio stream?

Does anyone have any other suggestions?

Thank you,

-Drew
Flash global settings page
http://www.macromedia.com/support/do...lp/help01.html
I have also have similar problems currently using FireFox 3.5 and Nvidia 185 driver on slack 12.2 (flash locking up in fullscreen on both this setup and with FF3.0 and nvidia 180 driver) if anyone find solution it would be appreciated. So far the best i could do to get full screen flash was to run without the nvidia driver (use driver that came on original slackware install).
i have tried to disable hardware acceleration with the global settings page but it won't let me unselect it :/


figured out my problem maybe it will help you out!!!
found the fix for full screen here
http://webupd8.blogspot.com/2009/07/...videos-in.html
I will repeat this info here incase the link breaks at a later date
Quote:
How To Fix Full-Screen Flash Videos in Linux & Firefox (or Swiftfox)

By default, Firefox (or Swiftfox) crashes when trying to view a full-screen video on say... YouTube. At least for me it used to crash until I found a fix and from what I've understand it's got something to do with the graphic card drivers and it's affecting both nVidia and ATI. If that is the case for you also, you may want to read on.

To fix the full-screen flash videos bug, you need to preload a library called libGL.so.1 when you start Firefox or Swiftfox. Here is how to do it:

1. Create a new file in your home folder, let's call it fix_flash.sh and paste this:
Code:
#!/bin/sh
## replace firefox-3.6 with what you use, e.g. firefox, firefox-3.5, swiftfox
LD_PRELOAD=/usr/lib/libGL.so.1 firefox-3.5
Like the script says, replace "firefox-3.5" with the command used to launch your Firefox (depending on the version, etc). If you don't know the command, go to Applications > Internet and right click the version of Firefox you want to fix (Firefox, Minefield or whatever) and click "Add to panel". Then a new icon (launcher) will be displayed on your panel; right click that icon and select "Properties" -> you will then see the command used to launch your Firefox version in the "Command" field (never mind the %u):


If you use Swiftfox, replace "firefox-3.5" in the file with "swiftfox" (without the quotes).

2. Make fix_flash.sh executable
Use your terminal to navigate to where fix_flash.sh is located and type this in the terminal:
Code:
chmod +x fix_flash.sh
3. Now either edit your panel Firefox/Swiftfox icon or add a new icon and in the command field, put this:
Code:
/path_to_file/fix_flash.sh %u
Obviously, replace "path_to_file" with the path to the fix_flash.sh file.

4. Close Firefox / Swiftfox and run it using the newly created launcher (icon), then go to YouTube or a similar website and click the full-screen button. Everything should be ok now, no more crashes!

Props to: Posted by Andrew | 03 July, 2009

Last edited by Daehtop; 07-10-2009 at 04:37 AM. Reason: found solution
 
Old 07-11-2009, 08:43 AM   #12
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,139
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by Daehtop View Post
I have also have similar problems currently using FireFox 3.5 and Nvidia 185 driver on slack 12.2 (flash locking up in fullscreen on both this setup and with FF3.0 and nvidia 180 driver) if anyone find solution it would be appreciated. So far the best i could do to get full screen flash was to run without the nvidia driver (use driver that came on original slackware install).
This is a bummer. I may try to install the 185 drivers and see if they help.
 
Old 07-11-2009, 05:53 PM   #13
RaptorX
Member
 
Registered: Jun 2009
Location: Emden, Germany
Distribution: Slackware 12.2, Slax 6.1
Posts: 254

Rep: Reputation: 37
Quote:
figured out my problem maybe it will help you out!!!
found the fix for full screen here
http://webupd8.blogspot.com/2009/07/...videos-in.html
That worked for me!!. It stopped the flash crashes on FF 3.5 + Nvidia 185.18.14.

it seems to be that FlashPlayer 10 does not load LibGL.o automatically and firefox needs that lib up...
 
Old 07-12-2009, 01:40 AM   #14
Daehtop
LQ Newbie
 
Registered: Jun 2009
Location: southeast Missouri
Distribution: Slackware 12.2
Posts: 4

Rep: Reputation: 1
Quote:
Originally Posted by Lufbery View Post
This is a bummer. I may try to install the 185 drivers and see if they help.
this should work for older versions of the nvidia driver also (as long as "libGL.so.1" exist) i'm just not willing to revert to the older driver to confirm it.
FYI after discussing with Andrew i discovered instead of using a startup script you can alternatively (don't use both) add this line to the firefox startup script (slack 12.2 "/usr/bin/firefox") you just have to add it each time you upgrade firefox
add this to 2nd line not 1st
Code:
export LD_PRELOAD=/usr/lib/libGL.so.1
 
Old 07-13-2009, 09:46 AM   #15
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
I upgraded to flash 10 on ff 3.5. Adding the "export" line as posted by Daehtop worked for me. I am using NVIDIA 185.18.14.
 
  


Reply

Tags
crash, flash, fullscreen, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash in Firefox nomorelonghorn Linux - Newbie 6 01-04-2009 09:07 PM
Firefox-flash lowbrow *BSD 3 03-29-2008 09:28 AM
Flash in Firefox digerati1338 Debian 2 03-06-2008 07:27 PM
Flash for Firefox? carlosinfl Debian 4 12-18-2005 08:23 PM
FireFox and Flash rb2k Linux - Software 4 02-12-2004 04:34 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration