LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-12-2004, 04:50 PM   #1
blk96gt
Member
 
Registered: Jun 2004
Location: Nacogdoches, TX
Distribution: Ubuntu 7.04
Posts: 230

Rep: Reputation: 30
Question Finally got KDE 3.2.2 installed, but now have a font error when starting Konsole


After I had first installed KDE 3.2.2, I kept getting the libXinerama.so.1 error, and after some searching I got that fixed. I solved that problem by doing this:
d /usr/X11R6/lib
ld --whole-archive -share -o libXinerama.so.1 libXinerama.a
ln -s libXinerama.so.1 libXinerama.so
/sbin/ldconfig
Well now KDE comes up and everything, but whenever I open up konsole, I get this error:
Font '-misc-console-medium-r-normal--16-160-72-72-c-80-iso10646-1' not found. I didn't have this problem before when i was using KDE 3.1.4. Anyone have any suggestions?
 
Old 06-12-2004, 05:14 PM   #2
Menestrel
Member
 
Registered: Oct 2003
Location: Bucharest
Distribution: Debian Sarge, Slackware Current, Ubuntu
Posts: 183

Rep: Reputation: 30
I solved this problem by adding to /etc/fonts.conf the path /opt/kde/share/fonts in the part where you have all the paths to fonts.
after this I also edited XF86config and added the line FontPath "/usr/X11R6/lib/X11/fonts/local/" in the files section. After that I run fc-cache -v. In kde select linux fonts for konsole
 
Old 06-12-2004, 05:51 PM   #3
blk96gt
Member
 
Registered: Jun 2004
Location: Nacogdoches, TX
Distribution: Ubuntu 7.04
Posts: 230

Original Poster
Rep: Reputation: 30
It fixed it by adding the /opt/kde/share/fonts line to the /etc/fonts/fonts.conf file. The line in XF86Config was already there, so I just ran that command and opened up console and didn't have the error. But now I have another question. The prompt is different looking than it was before, and I have no colors when using ls. The prompt looks like this:
bash-2.05b#
which to me looks like the default bash prompt when it doesnt load the .bashrc file, or one of those bash files. Am I on the right track? Thanks for the help.
 
Old 06-12-2004, 10:26 PM   #4
blk96gt
Member
 
Registered: Jun 2004
Location: Nacogdoches, TX
Distribution: Ubuntu 7.04
Posts: 230

Original Poster
Rep: Reputation: 30
Well I figured out the problem with the prompt and the colors after a quick search. All I had to do was when I call konsole ad the -ls switch to the end.
 
Old 06-16-2004, 01:27 PM   #5
asmith
LQ Newbie
 
Registered: May 2004
Location: bulgaria
Posts: 8

Rep: Reputation: 0
I've got the same problem and many more.
The konsole font is messed, even with the default for me option -ls
The run command doesn't work, I don't have right click menu on the desktop.
Can't you help me.
And where do you set the konsole font that you mentioned?
 
Old 08-03-2004, 01:29 AM   #6
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 768

Rep: Reputation: 92
To cure this problem do the following:-
Copy all the fonts from /opt/kde/share/fonts to /usr/X11R6/lib/X11/fonts.
Run command /usr/X11R6/bin/fc-cache
Open KDE control centre and login to admin>fonts as administrator.
Log out again and you should find it is now OK
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
linux font in KDE KONSOLE (how to make it work) Erik_FL Slackware 1 10-04-2005 08:12 PM
VESA, font, QPixmap and BadWindow errors when starting KDE 3.3 artificialGekko Linux - Software 0 03-21-2005 09:13 AM
Konsole Font COlors in KDE????? mepisfreak Linux - General 2 01-17-2005 02:26 PM
installed kde 3.2 and konsole colors lost true_atlantis Linux - Software 2 02-07-2004 03:42 PM
KDE: error when starting Konsole georg9 Slackware 9 08-07-2003 02:47 PM


All times are GMT -5. The time now is 01:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration