LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ffmpeg slackbuilds.org script failure (http://www.linuxquestions.org/questions/slackware-14/ffmpeg-slackbuilds-org-script-failure-819923/)

TL_CLD 07-15-2010 03:44 AM

ffmpeg slackbuilds.org script failure
 
Hey all,

When I try to compile ffmpeg for Slackware 13.1 x86_64 using the slackbuilds.org script, I have to comment these lines:

Code:

( cd $PKG/usr/man
  find . -type f -exec gzip -9 {} \;
  for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)

If I don't comment them, the builds fails with this error:

Code:

./ffmpeg.SlackBuild: line 194: cd: /tmp/SBo/package-ffmpeg/usr/man: No such file or directory
:)

Alien Bob 07-15-2010 04:11 AM

It is not the script's fault.
You probably ran "su" to become root in order to compile the package. However, this does not provide a fully compatible root shell... your environment is incomplete.

If you use "su -" to become root instead, then you will have root's full shell environment, so that the ffmpeg.SlackBuild script will work correctly (and the man pages will be created).

Eric

dc_eros 07-15-2010 04:12 AM

Are you using su or su - ?

Use "su -", according to slackBuilds guidelines.

Edit: Oops sorry, too slow here :D

TL_CLD 07-15-2010 04:23 AM

Actually I did this:

$ kdesu "konsole -e $SHELL -l"

Or rather I have that as a shortcut on my main KDE panel. I thought the -l option made sure I had a complete environment.

TL_CLD 07-15-2010 05:46 AM

I've just tried compiling it again, this time using "su - root". The result:

Code:

./ffmpeg.SlackBuild: line 194: cd: /tmp/SBo/package-ffmpeg/usr/man: No such file or directory

Alien Bob 07-15-2010 06:49 AM

In that case, you have probably not installed the TeX package. That is required to build the man pages. A full installation of Slackware should provide it.

Eric

andrew.46 07-15-2010 08:50 PM

I was a frequent offender of the incorrect use of 'su' instead of 'su -' when using slackbuild scripts in the past. Before I corrected myself of this habit I used the following in my own FFmpeg build, which I stole from alienBOB some time ago:

Code:

if ! $(which texi2html 2>/dev/null) ; then
  export PATH=$PATH:/usr/share/texmf/bin
fi

But of course the use of 'su -' is the more correct usage :).

Andrew

TL_CLD 07-16-2010 12:45 AM

Quote:

Originally Posted by Alien Bob (Post 4033809)
In that case, you have probably not installed the TeX package. That is required to build the man pages. A full installation of Slackware should provide it.
Eric

That was it. I had installed texlive, but for some odd reason that didn't work.

After having reinstalled tetex, the ffmpeg package now builds without error.

Thanks. :)


All times are GMT -5. The time now is 03:38 PM.