LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-23-2005, 08:03 PM   #1
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Rep: Reputation: 47
Fetchmail doesn't fetch


I'm trying to set up fetchmail to check my POP3 internet account and download the messages. So far, I'm able to get it to check my mail but it won't download the emails. This is what happens:

bash-3.00$ fetchmail -v
fetchmail: 6.2.5 querying incoming.verizon.net (protocol POP3) at Mon 23 May 2005 08:59:42 PM EDT: poll started
fetchmail: POP3< +OK Messaging Multiplexor (Sun Java(tm) System Messaging Server 6.2 Patch 0.04 (built Dec 24 2004)) <42927c7e.2020f4e0@vms100.mailsrvcs.net>
fetchmail: POP3> CAPA
fetchmail: POP3< +OK list follows
fetchmail: POP3< TOP
fetchmail: POP3< PIPELINING
fetchmail: POP3< UIDL
fetchmail: POP3< RESP-CODES
fetchmail: POP3< AUTH-RESP-CODE
fetchmail: POP3< USER
fetchmail: POP3< SASL PLAIN CRAM-MD5
fetchmail: POP3< IMPLEMENTATION MMP-6.2p0.04 Dec 24 2004
fetchmail: POP3< .
fetchmail: POP3> AUTH CRAM-MD5
fetchmail: POP3< + PDQyOTI3YzdmLjIwMjBmNGUwQHZtczEwMC5tYWlsc3J2Y3MubmV0Pg==
fetchmail: POP3> bGludXhoaXBweSBlZDYyY2ZkZGI5OThiMzdmN2M4OTg1ZDY1NDg2NzJmYg==
fetchmail: POP3< +OK Maildrop ready
fetchmail: POP3> STAT
fetchmail: POP3< +OK 1 685
fetchmail: POP3> LAST
fetchmail: POP3< +OK 0
1 message for linuxhippy at incoming.verizon.net (685 octets).
fetchmail: POP3> LIST 1
fetchmail: POP3< +OK 1 685
fetchmail: POP3> TOP 1 99999999
fetchmail: POP3< +OK
reading message linuxhippy@incoming.verizon.net:1 of 1 (685 octets)
fetchmail: SMTP connect to localhost failed
fetchmail: POP3> QUIT
fetchmail: POP3<
fetchmail: SMTP transaction error while fetching from incoming.verizon.net
fetchmail: 6.2.5 querying incoming.verizon.net (protocol POP3) at Mon 23 May 2005 08:59:46 PM EDT: poll completed
fetchmail: Query status=10 (SMTP)
fetchmail: normal termination, status 10

My ~/.fetchmailrc is:

poll incoming.verizon.net with proto POP3
user linuxhippy there with password XXXXXXX is linuxhippy here

My username on my pc is linuxhippy.

Any ideas why it won't download?
 
Old 05-23-2005, 08:07 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
It seems it's trying to connect to a SMTP server which I assume would be your own smtp server to deliver it inside your computer.
I can't help you further because I didn't want to read too much to download mail so used getmail instead
 
Old 05-24-2005, 08:21 AM   #3
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
I was able to get fetchmail to fetch-I needed sendmail to be running which I started with pkgtool and made sure I had a file for mail delivery:

touch /var/spool/mail/linuxhippy
chown linuxhippy.users /var/spool/mail/linuxhippy
chmod 660 /var/spool/mail/linuxhippy

Now I'd like to make a symbolic link to my current email directory (/mnt/hda5/inbox/) to the file /var/spool/mail/linuxhippy. I don't seem to be able to do this by ln -s /mnt/hda5/inbox /var/spool/mail/linuxhippy-is it possible to link a directory to a file?

Sylpheed saves each email as a separate file into /mnt/hda5/inbox while sendmail uses a single file.
 
Old 05-24-2005, 09:41 AM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You can't link ad irectory to a file. The difference that you see is that the spoolfile is a mbox type of mail box, and Sylpheed seems to be using a Maildir box.
Set Sylpheed to save the mails as mbox which is what the spool file uses.

Last edited by gbonvehi; 05-24-2005 at 09:42 AM.
 
Old 05-24-2005, 11:27 AM   #5
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
Good idea to change settings in Sylpheed. Under Configuration>Common Preferences I checked local spool and put in /var/spool/mail/linuxhippy. Now I use fetchmail and mutt to get and view mail in CLI and then Sylpheed in GUI moves my new messages to it's directory and makes individual files...it files them.

Can I have fetchmail play a wav file when there are new messages?
 
Old 05-24-2005, 12:51 PM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Depending on how you run fetchmail, basically a script listed here should work: http://lists.gnu.org/archive/html/bu.../msg00029.html
Code:
#!/bin/sh
#Run fetchmail without output and see if it runs ok
if /usr/bin/fetchmail > /dev/null 2>&1; then
  #If return code was succesfull, we've got mail, play a sound
  play sound.wav
fi

Last edited by gbonvehi; 05-24-2005 at 01:30 PM.
 
Old 05-24-2005, 05:37 PM   #7
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
thanks!
 
Old 08-27-2005, 08:51 PM   #8
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
Quote:
Originally posted by gbonvehi
Depending on how you run fetchmail, basically a script listed here should work: http://lists.gnu.org/archive/html/bu.../msg00029.html
Code:
#!/bin/sh
#Run fetchmail without output and see if it runs ok
if /usr/bin/fetchmail > /dev/null 2>&1; then
  #If return code was succesfull, we've got mail, play a sound
  play sound.wav
fi
This script seems to work real well, but how can I make fetchmail run in daemon mode in this script so that a sound is played whenever a message is in my internet mailbox? Usually fetchmail -d 60 would tell fetchmail to check every 60 seconds...but I want it to play a sound. When I put -d 60 in this script it only runs once.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fetchmail doesn't want to fetch my messages jogurt666 Linux - Software 1 09-07-2005 03:13 PM
using fetchmail to fetch messages for Citadel system trancephorm Linux - Software 2 07-24-2005 04:18 AM
fetch package? xpcandrew Linux - Newbie 1 02-01-2005 01:32 AM
a broken package, cannot RE-fetch?! b0uncer Arch 2 09-29-2004 09:23 AM
installing fetch mihailolja Linux - Newbie 1 03-10-2004 08:23 AM


All times are GMT -5. The time now is 01:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration