LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-21-2007, 05:17 PM   #1
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Rep: Reputation: 16
feh problems


I'm trying to set my background in Fluxbox and for some reason feh is not working... Im stumped.

Its telling me -
Quote:
error while loading shared file libraries: libgiblib.so.1 : cannot open shared object file : no such file or directory
I installed glib though. When I do a whereis libgiblib.so.1 it returns with /usr/lib/libgiblib.so.1 /usr/lib/libgiblib.so

I added /usr/lib to my $PATH (not sure if this would help) still no success. Can anyone help a poor soul? =)
 
Old 08-21-2007, 05:59 PM   #2
jukebox55
Member
 
Registered: Aug 2007
Distribution: slackware 11
Posts: 101

Rep: Reputation: 15
try adding the line '/usr/lib' to '/etc/ld.so.conf', then in a terminal run 'ldconfig'.

Last edited by jukebox55; 08-21-2007 at 06:01 PM.
 
Old 08-22-2007, 04:00 PM   #3
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
No luck it still wont recognize it. This is weird. Ive tried reinstalling the glib package too. Again no luck. Anyone? =(
 
Old 08-22-2007, 05:02 PM   #4
h4kteur
LQ Newbie
 
Registered: Apr 2006
Posts: 13

Rep: Reputation: 0
Quote:
Originally Posted by Th3_J3st3R View Post
I'm trying to set my background in Fluxbox and for some reason feh is not working... Im stumped.

Its telling me -


I installed glib though. When I do a whereis libgiblib.so.1 it returns with /usr/lib/libgiblib.so.1 /usr/lib/libgiblib.so

I added /usr/lib to my $PATH (not sure if this would help) still no success. Can anyone help a poor soul? =)

You need to install giblib before feh. I've made a slackbuild for giblib and a slackbuild for feh.

You must run the slackbuild a user and not as root, if you have fakeroot the slackbuild will use fakeroot if not you will be asked to type your root password.
 
Old 08-22-2007, 09:32 PM   #5
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
h4kteur:
Thanks for those. I ran your giblib slackbuild which worked with no problems. Then feh is giving me this problem.

Code:
*** The giblib-config script installed by giblib could not be found 
*** If giblib was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GIBLIB_CONFIG environment variable to the
*** full path to giblib-config.
configure: error: Cannot find giblib: Is giblib-config in the path?
Im not sure how to solve this.. I don't know what PREFIX is.
 
Old 08-23-2007, 01:48 AM   #6
h4kteur
LQ Newbie
 
Registered: Apr 2006
Posts: 13

Rep: Reputation: 0
It may sound stupid but did you install giblib before running feh's slackbuild ?

type as root :
upgradepkg --install-new --reinstall /tmp/build/giblib-1.2.4-i486-1_SBn.tgz to install giblib and
upgradepkg --install-new --reinstall /tmp/build/feh-1.3.4-i486-1_SBn.tgz to install feh once compiled.

Last edited by h4kteur; 08-23-2007 at 05:17 AM.
 
Old 08-23-2007, 01:40 PM   #7
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
Thanks so much h4kteur. The problem was I didn't know that the script created packages that are stored in /tmp/build ... well I know now. I don't use slackbuilds as much as I should. I go to linuxpackages.net mostly. Anyways thanks again for all the help!
 
Old 06-07-2009, 05:16 AM   #8
lostidentity
LQ Newbie
 
Registered: Jan 2009
Location: UK
Posts: 8

Rep: Reputation: 0
Hi,

I'm having a similar issue. I do not have root access on the system and I installed the files on my home directory. I've installed giblib and feh was installed without any problems.

I type the following to set my background

Code:
feh –bg-scale `dcop kdesktop KBackgroundIface currentWallpaper 1`
and I get the following error when I do that
Code:
error while loading shared file libraries: libgiblib.so.1 : cannot open shared object file : no such file or directory
I installed the libraries in the following directory

/home/user/my_programs/lib/

Any ideas?

Thanks.
 
Old 06-07-2009, 12:53 PM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
Quote:
Originally Posted by lostidentity View Post
I installed the libraries in the following directory

/home/user/my_programs/lib/

Any ideas?

Thanks.
That's definitely why it doesn't find them. You will likely have to add that directory to '/etc/ld.so.conf' and then run 'ldconfig' as root. That might work.

I don't see why you don't install libraries to /usr/lib where they belong, it'll save you a lot of potential trouble later on.
 
Old 06-07-2009, 12:55 PM   #10
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 99
Quoth lostidentity:
Quote:
I do not have root access on the system
 
Old 06-07-2009, 01:26 PM   #11
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
Oh, I see, sorry I missed that small bit

Well, I'm not sure what to do in that case, I'll think about it...
 
Old 06-07-2009, 03:11 PM   #12
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
He can still use LD_LIBRARY_PATH.
 
Old 06-08-2009, 01:44 AM   #13
lostidentity
LQ Newbie
 
Registered: Jan 2009
Location: UK
Posts: 8

Rep: Reputation: 0
Hi,

Thanks for all the replies. Sorry I'm still very new to Linux so you'd have to describe it a bit for me.

Do I need to uninstall feh, change the libraries in the Makefile and install again?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fbsetbg and feh soldan Linux - Newbie 3 11-27-2006 06:20 AM
How to wget a random file from a website, then use FEH to view it. xmrkite Linux - Software 3 10-17-2006 01:26 PM
fbsetbg wont recognize feh is installed in fluxbox 0.9.13 debiant Linux - Software 4 08-07-2006 10:36 PM
LXer: CLI Magic: Feh for image viewing LXer Syndicated Linux News 0 07-31-2006 03:54 PM
How do I switch from Esetroot to feh??? Southpaw76 Linux - Software 3 12-13-2005 06:14 PM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration