LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-27-2013, 03:26 PM   #1
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 225

Rep: Reputation: 33
Feb 22nd update for current breaks touchpad on HP Elitebook


With the X updates, the touchpad no longer functions in KDE. The touchpad works fine in kdm and on the cli. I don't have another WM installed to test and do my lack of knowledge of other WM, it is easier for me to roll back X than setup a new WM. There are no errors in the system or X logs. I thought it was an issue with synaptics, however rolling back only synaptic did not correct the issue. Creating a custom synaptic config file in xorg.conf.d was a no go as well. Any suggestion on a fix or how I can troubleshoot this?

I have since rolled back to a previous version of X and all is well again.
 
Old 03-09-2013, 10:12 PM   #2
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 225

Original Poster
Rep: Reputation: 33
I suspect this was not a common issue since this was the first time one of my post have gone unanswered. I finally had some time to dig deeper and was able to fix the problem, so here goes for anyone else who might need help.

The no touchpad in KDE was entirely a KDE issue and not entirely the fault of the recent updates. Actually, it is a combination of elitebook keymap of the kernel and KDE. The file ~/.kde/share/config/ktouchpadenablerrc contains the setting to enable/disable the touchpad. The issue is there is nowhere in the GUI (at least I could not find it) to enable/disable touchpad. I installed kcm_touchpad which added the touchpad setting to the Input Devices configuration but kcm_touchpad created the new file "kcmtouchpadrc" in the KDE config directory and does not modify the "ktouchpadenablerrc" file.

So how did I wind up in this mess? On the elitebook, the fn+f11 key is incorrectly mapped to KEY_TOUCHPAD_OFF (fn+f11 on the elitebook is suppose to adjust the ambient light sensitivity). I frequently use the fn+f9/f10 to adjust my screen brightness, so sometimes I accidentally hit fn+f11. This was not an issue before the X update on Feb22 as it seems KDE did not honour its own setting with the older version of X. Logging in with a new user narrowed this problem down to my KDE settings. Grepping for "touchpad" in the config directory turned up the pesky file. Removing it or changing "touchpadEnabled=true" restored the touchpad after logging back into KDE.

The issue can be replicated by:
1. Pressing fn+f11 generates a KDE notification that touchpad is disable and "touchpadEnabled=false" is set in ktouchpadenablerrc (the disable is immediate).
2. Since there is no key combination to enable touchpad (or gui setting) editing or removing ktouchpadenablerrc and logging back into KDE restores the touchpad.
 
Old 03-17-2013, 10:45 PM   #3
ava1ar
LQ Newbie
 
Registered: Sep 2009
Location: Guttenberg, NJ
Distribution: Arch Linux
Posts: 1

Rep: Reputation: 0
Hi, faced same issues on my HP laptop. In addition to your findings, I investigated following:

1. Problem caused by ktouchpadenabler KDED module, which is included in one of the latest KDE updates;
2. I did not found how to configure it, but found how to disable it: just modify /usr/share/kde4/services/kded/ktouchpadenabler.desktop to set X-KDE-Kded-autoload=false and relogin to kde (do not forget to set touchpadEnabled=true in ~/.kde/share/config/ktouchpadenablerrc).

After this action, Fn+F11 works as expected and do not affect touchpad anymore.

Last edited by ava1ar; 03-17-2013 at 10:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sunday July 22nd The lots of shiny stuff update and a udev story inph Slackware 4 07-23-2012 03:18 AM
LXer: Fuduntu Weekly Update - Feb 12, 2011 LXer Syndicated Linux News 0 02-12-2011 02:40 PM
Observation of Feb -current vs March -current Hangaber Slackware 14 03-12-2010 08:26 AM
[SOLVED] Slack-current change logs--changeless in Feb? letitgo Slackware 45 03-03-2010 12:47 PM
Slackware-Current (Feb 9) with HTTP/FTP installer, and SSHD. theoffset Slackware 3 02-09-2008 12:04 PM


All times are GMT -5. The time now is 04:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration