LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Feb 22nd update for current breaks touchpad on HP Elitebook (http://www.linuxquestions.org/questions/slackware-14/feb-22nd-update-for-current-breaks-touchpad-on-hp-elitebook-4175451958/)

tux_dude 02-27-2013 03:26 PM

Feb 22nd update for current breaks touchpad on HP Elitebook
 
With the X updates, the touchpad no longer functions in KDE. The touchpad works fine in kdm and on the cli. I don't have another WM installed to test and do my lack of knowledge of other WM, it is easier for me to roll back X than setup a new WM. There are no errors in the system or X logs. I thought it was an issue with synaptics, however rolling back only synaptic did not correct the issue. Creating a custom synaptic config file in xorg.conf.d was a no go as well. Any suggestion on a fix or how I can troubleshoot this?

I have since rolled back to a previous version of X and all is well again.

tux_dude 03-09-2013 10:12 PM

I suspect this was not a common issue since this was the first time one of my post have gone unanswered. I finally had some time to dig deeper and was able to fix the problem, so here goes for anyone else who might need help.

The no touchpad in KDE was entirely a KDE issue and not entirely the fault of the recent updates. Actually, it is a combination of elitebook keymap of the kernel and KDE. The file ~/.kde/share/config/ktouchpadenablerrc contains the setting to enable/disable the touchpad. The issue is there is nowhere in the GUI (at least I could not find it) to enable/disable touchpad. I installed kcm_touchpad which added the touchpad setting to the Input Devices configuration but kcm_touchpad created the new file "kcmtouchpadrc" in the KDE config directory and does not modify the "ktouchpadenablerrc" file.

So how did I wind up in this mess? On the elitebook, the fn+f11 key is incorrectly mapped to KEY_TOUCHPAD_OFF (fn+f11 on the elitebook is suppose to adjust the ambient light sensitivity). I frequently use the fn+f9/f10 to adjust my screen brightness, so sometimes I accidentally hit fn+f11. This was not an issue before the X update on Feb22 as it seems KDE did not honour its own setting with the older version of X. Logging in with a new user narrowed this problem down to my KDE settings. Grepping for "touchpad" in the config directory turned up the pesky file. Removing it or changing "touchpadEnabled=true" restored the touchpad after logging back into KDE.

The issue can be replicated by:
1. Pressing fn+f11 generates a KDE notification that touchpad is disable and "touchpadEnabled=false" is set in ktouchpadenablerrc (the disable is immediate).
2. Since there is no key combination to enable touchpad (or gui setting) editing or removing ktouchpadenablerrc and logging back into KDE restores the touchpad.

ava1ar 03-17-2013 10:45 PM

Hi, faced same issues on my HP laptop. In addition to your findings, I investigated following:

1. Problem caused by ktouchpadenabler KDED module, which is included in one of the latest KDE updates;
2. I did not found how to configure it, but found how to disable it: just modify /usr/share/kde4/services/kded/ktouchpadenabler.desktop to set X-KDE-Kded-autoload=false and relogin to kde (do not forget to set touchpadEnabled=true in ~/.kde/share/config/ktouchpadenablerrc).

After this action, Fn+F11 works as expected and do not affect touchpad anymore.


All times are GMT -5. The time now is 06:11 PM.