LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-22-2006, 08:08 PM   #1
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Rep: Reputation: 30
Fat32 Read Only?


I used to write to my fat32 partition. Here is my fstab that I changed a few times trying to get it to work.

Quote:
/dev/hda7 /home/extra vfat rw,users,umask=000 0 0
Now I can't. I tried to delete a file as root and it say's I can't because its a Read Only Disc. Can anyone help?

Last edited by natewlew; 06-22-2006 at 08:13 PM.
 
Old 06-22-2006, 08:24 PM   #2
cereal83
Member
 
Registered: Feb 2004
Location: Canada
Distribution: Slackware
Posts: 478

Rep: Reputation: 30
/dev/hda7 /home/extra vfat ro,users,umask=000 0 0
 
Old 06-22-2006, 08:57 PM   #3
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks for your help!

That didn't seem to work.

I ran dmesg:

Quote:
FAT: bogus logical sector size 0
UMSDOS: msdos_read_super failed, mount aborted.
FAT: bogus logical sector size 0
FAT: bogus logical sector size 0
Filesystem panic (dev 03:07).
FAT error
Directory 8: bad FAT
I guess somethings wrong with the drive.
 
Old 06-22-2006, 09:42 PM   #4
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
FAT error should pretty much tell you it's a problem with the filesystem.

Running fsck.msdos on the partition might help. Or it might destroy the entire filesystem beyond repair.

I honestly am not sure how reliable that tool would be.
 
Old 06-22-2006, 09:46 PM   #5
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Quote:
Originally Posted by liquidtenmilion
Running fsck.msdos on the partition might help. Or it might destroy the entire filesystem beyond repair.

I honestly am not sure how reliable that tool would be.
lmao

Can't be any worse than 'chkdisk' in Windows....
 
Old 06-22-2006, 10:26 PM   #6
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Windows did run a check on it and it seems to work fine, but its still no good in Slackware.
 
Old 06-22-2006, 11:26 PM   #7
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
I put noauto on my fstab and added rw. I didn't get any errors when I booted. I mounted the drive and I can write to it.
 
Old 06-22-2006, 11:30 PM   #8
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
So, something with the auto setting then....

At least, you've narrowed it down.
Can you post your new fstab? And have you done any 'upgrading' lately?
Windows or Slackware. Windows is notorious for changing things on the hdd without letting you know....
Usually, it messes with NTFS, but you never know....

Last edited by cwwilson721; 06-22-2006 at 11:32 PM.
 
Old 06-22-2006, 11:42 PM   #9
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
My fstab:

Quote:
/dev/hda5 swap swap defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 1 1
/dev/hda1 /home/ntfs ntfs ro,umask=0222,users 0 0
/dev/hda7 /home/extra vfat noauto,rw,users,umask=000 0 0
/dev/hdc /mnt/cdrom iso9660 udf,noauto,owner,ro 0 0
/dev/hdd /mnt/cdrom2 iso9660 udf,noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
none /sys sysfs defaults 0 0
No, I havn't done any upgrading.

I think the problem started when I tried to mount the partition on Solaris. When I mounted it on Solaris it said "/mnt/extra might be busy" , but it still mounted. I didn't think that was the cause but it might have been.
I have been getting errors when I booted slackware since I installed it about a week ago. Everything worked ok so I didn't worry about it. Now I'm not getting any. I guess turning off the auto did help

Last edited by natewlew; 06-22-2006 at 11:45 PM.
 
Old 06-22-2006, 11:45 PM   #10
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Is there anyway possible to backup the data on that partition, and remake a fresh fat32, then reinstall the data? Don't know why, but something is rattling around in the old database in my skull....

The problems with screwing with these OS's since '73. The dust is terrible in there.

And don't underestimate the possibility of a MS virus on the superblock of that partition....

Last edited by cwwilson721; 06-22-2006 at 11:46 PM.
 
Old 06-23-2006, 02:26 PM   #11
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Yes I could do that, but it seems to be working ok.

The only files that I have on there are pictures and music that I have backed up.
 
  


Reply

Tags
fat32, filesystem, filesystems, mount, mounting


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 12:17 PM
Help me read FAT32 drive StarSage Linux - Newbie 3 12-12-2004 08:19 PM
can't even read from fat32 partition...except sometimes!? Sinope Linux - General 3 08-19-2004 02:59 PM
FAT32 Partition Read-only rhawi Linux - Newbie 5 07-23-2004 12:56 PM
Can't Right to my FAT32 Drive only read! Stevetgn Linux - Newbie 2 08-28-2003 04:03 PM


All times are GMT -5. The time now is 09:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration