LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Fast WAN slow LAN Slack 9.x - 10.x (http://www.linuxquestions.org/questions/slackware-14/fast-wan-slow-lan-slack-9-x-10-x-367652/)

Grunthos 09-27-2005 09:47 PM

Fast WAN slow LAN Slack 9.x - 10.x
 
This has been a problem (for me at least) for a while.

I have a slackware router with 2 NICs
On-Board: via-rhineII (100TX)
PCI: netgear fa310tx (LNE100TX)

The problem:

File transfers TO the router (scp/samba/ftp/http-from PC) are painflully slow. (<130kB)
File transfers FROM the router are perfect.
This problem did not appear until a second interface was added and it was used for pppoe

Using a switch: Lots of framing errors
Using a repeater: Lots of dropped packets (and the usual collisions)

netstat -i reports lots of RX-DRP (receive drops) (numbers like 70,000+)

so far:

-checked routing (default -> ppp0, localnet -> localNIC)
-swapped LAN for WAN
-replaced pci NIC
-flush iptables (and set default policies to ACCEPT)

Current setup:

VIA mini-ITX 1.0GHz
256M SDRAM
40G Disk
running iptables
slackware 10.1 (swaret upgraded to 10.2)
current kernel is still 2.4.29

Dlink 5 port 10/100 switch / Netgear 4 port 10/100 Repeater

Is it just my shoice of NIC/hub/switch hampering this ?

This behavior was also present on the "old" router with 2 of the netgear pci NICs and only started to happened when I moved back to slackware (9.1 at first)

If anyone could shed some light on this I would be grateful.

Cheers
-Grunthos

debianmike 09-27-2005 10:44 PM

im not great with slackware but do you have ethtool or mii-tool installed? Can you verify your duplex'ing speed on both nics?

Plugged into a hub, or cheap switch, most of the time the best setting for the NIC is autoneg, but see how they are set now and that might help.

Grunthos 09-27-2005 11:07 PM

As I am currently plugged into a repeater and an ADSL modem the conf is thus:

OnBoard: Hub 100Tx Half Duplex (as it should be) Auto Neg (via-rhineII)
PCI NIC: ADSL modem 100Tx Full duplex (again as it should be) Auto Neg

To Add to the list of things tried:
hard set eth0 and eth1 to their respective HD and FD. (no joy)

One thing that also springs to mind ( I might look at this when I get home) is the when I added the PCI nic it assumed eth0 and the on board became eth1. I know you can hard set this but could it be causing the problem ....some internal mix up .. ?


Cheers

-Grunthos

Grunthos 09-28-2005 01:59 AM

could be something like this .... will check it out...


https://bugzilla.redhat.com/bugzilla....cgi?id=129304

-Grunthos

Grunthos 09-28-2005 04:41 AM

I'll just keep talking to myself :P...

I installed the rhinefet module (now using kernel 2.4.31)

having removed the 2nd NIC (pci) the onboard reverts back to eth0.

download/build/install the rhinefet module as per the previous post.

On reboot it comes back up (phew) eth0 is using the new module (alias eth0 rhinefet in /etc/modules.conf).
Transfer to the box without 2nd NIC pushes SCP upto 700kB (massive improvement).

Plug second NIC back in and *gasp* the system does NOT push the onboard NIC to eth1 (so I have to swap the cables)
Wget from a windows host to the router now produces 835.68K/s .... ~6Mbits/s ... large improvement but is it what I should expect on a 100M Half duplex fom a 933MHz windows box running apache ?

Anyone ...

...anyone ?

-Grunthos

Grunthos 09-28-2005 04:58 AM

ok, 2 things I have noticed.

1>
old setup (eth0/eth1 swapped by system):
IRQ's were mismatched between lspci and ifconfig -a

2>
new setup (new driver module):
eth0/eth1 no longer swapped by system AND IRQ's match!!

I am thinking the IRQ mismatch prolly was't helping my cause. The addition of the new driver module has also helped (IMO).
I can almost be happy with the current state of things ...

I would still value any input from the wise (or at least funny).

-Grunthos


All times are GMT -5. The time now is 04:04 AM.