LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2014, 11:27 AM   #1
trist007
Member
 
Registered: May 2008
Distribution: Slackware
Posts: 979

Rep: Reputation: 56
Fan noise on new computer...


I bought a dell that had windows 8.1 preinstalled. I installed slackware64 14.1 off dvd media. Slackware boots great but I noticed that on idle, once the computer has been on several minutes, I can still hear my fans going, while on Windows 8.1 the fans would slow down to where I could not hear them.

Is there a good utility I can use to reduce the fan speed or is there a kernel tweak to tone down the fans.

I did have to add "acpi=off" to my boot parameters because I would get a blank screen when trying to startx after installing the nvidia-driver from Slackbuilds, which seems to have fixed it. I am not sure if that might be related.

-Tristan
 
Old 03-15-2014, 12:24 PM   #2
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 280

Rep: Reputation: 56
yes, it's related, setting acpi to off means the cpus never go in idle mode, that means you have to fix the video driver to have acpi again
 
Old 03-15-2014, 12:47 PM   #3
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 746

Rep: Reputation: 64
Slackware includes the fancontrol script in the lm-sensors package. But as said above, I assume you'll need acpi to work.
 
Old 03-15-2014, 01:44 PM   #4
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,712

Rep: Reputation: 1455Reputation: 1455Reputation: 1455Reputation: 1455Reputation: 1455Reputation: 1455Reputation: 1455Reputation: 1455Reputation: 1455Reputation: 1455
Instead of turning down the fan speed (which is dangerous), why not first try turning CPU frequency scaling on? Slackware's default setting is to turn it on only if you're running off a battery. See here for how to change that:

http://wiki.linuxquestions.org/wiki/...ncy_scaling.3F
 
Old 03-15-2014, 02:59 PM   #5
trist007
Member
 
Registered: May 2008
Distribution: Slackware
Posts: 979

Original Poster
Rep: Reputation: 56
Great this helped a lot.
 
Old 03-15-2014, 08:56 PM   #6
trist007
Member
 
Registered: May 2008
Distribution: Slackware
Posts: 979

Original Poster
Rep: Reputation: 56
After removing "acpi=off" from the boot parameters startx would work sometimes and them sometimes not. I used the slackbuilds for nvidia-driver and nvidia-kernel and libvpau. I uninstalled those and install the NVIDIA.run script from Nvidia's website. The 331.49 version gave me some errors. I went with the 325.15 and it went smoothly. Everything is working now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan Noise. Master Fox Linux - Software 12 07-20-2009 01:25 AM
Fan Noise problem - Xandros 3.0 ilovexandros Linux - Newbie 1 05-22-2006 10:10 PM
Fan noise problems... -=TRA=- Linux - Hardware 6 01-22-2006 02:55 PM
ACPI Problem? - Fan Noise das111 Linux - Newbie 2 06-28-2005 09:56 AM
Bootup fan noise really loud string Linux - Hardware 2 11-24-2004 09:59 AM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration