LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-06-2008, 04:41 PM   #1
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory


Hi all,

I'm getting this message...

Code:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
...when I try to use wpa_supplicant. It's looking for /var/run/wpa_supplicant as specified in the /etc/wpa_supplicant.conf.

/var/run/wpa_supplicant really doesn't exist.

I'm using the wpa_supplicant package from Eric's (Alien Bob) site.

I've got other questions on getting wireless to work, but this is my first.

Why am I getting that error, and how do I fix it?

Thanks,

-Drew
 
Old 01-06-2008, 08:44 PM   #2
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hi all,

A few more quick notes. I installed the Madwifi package from Alien Bob's site before trying to get WPA_supplicant working.

I've got a WEP-encrypted network.

To help things out a bit, here's what I added to my rc.inet1.conf:

Code:
# Added by Drew #
# Config information for ath0 (usng dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
And here's what I added to the rc.wireless.conf

Code:
00:15:E9:72:F2:92)
	INFO="D-LINK WNA-2330"
	ESSID="any"
	;;
Hopefully this will help debug the problem.
 
Old 01-06-2008, 08:59 PM   #3
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hi all,

Here's something else that may help. This is the output from ifconfig:

Code:
ath0      Link encap:Ethernet  HWaddr 00:15:E9:72:F2:92
          inet6 addr: fe80::215:e9ff:fe72:f292/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:720 (720.0 b)  TX bytes:0 (0.0 b)

eth0      Link encap:Ethernet  HWaddr 00:03:47:92:B2:D8
          inet addr:192.168.0.110  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::203:47ff:fe92:b2d8/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19831 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12219 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:27138045 (25.8 MiB)  TX bytes:1020192 (996.2 KiB)
          Interrupt:11

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:214 (214.0 b)  TX bytes:214 (214.0 b)

wifi0     Link encap:UNSPEC  HWaddr 00-15-E9-72-F2-92-65-74-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35927 errors:0 dropped:0 overruns:0 frame:3986
          TX packets:1391 errors:13 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199
          RX bytes:3371677 (3.2 MiB)  TX bytes:63317 (61.8 KiB)
          Interrupt:11
 
Old 01-07-2008, 12:49 AM   #4
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 767

Rep: Reputation: 92
Add the following line to your /etc/rc.d/rc.inet1.conf WLAN_WPACONF[1]="/etc/wpa_supplicant.conf"
right after
WLAN_WPADRIVER[1]="wext"
 
Old 01-07-2008, 02:41 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
You should post your /etc/wpa_supplicant.conf file (and edit out the private key) so that we can check if that file is at all correct.

Eric
 
Old 01-07-2008, 09:13 AM   #6
Road_map
Member
 
Registered: Jan 2007
Distribution: Slackware
Posts: 341

Rep: Reputation: 31
Add the next line in /etc/wpa_supplicant.conf file:
Code:
WPAOPTS="-Dwext -iath0 -c/etc/wpa_supplicant.conf"
P.S. In /etc/rc.d/rc.inet1.conf file. Sorry.

Last edited by Road_map; 01-07-2008 at 10:17 AM.
 
Old 01-07-2008, 06:14 PM   #7
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by vdemuth View Post
Add the following line to your /etc/rc.d/rc.inet1.conf WLAN_WPACONF[1]="/etc/wpa_supplicant.conf"
right after
WLAN_WPADRIVER[1]="wext"
Okay, I did that, and made a few changes to my wpa_supplicant.conf.

Here's that file:
Code:
# See /usr/doc/wpa_supplicant-0.5.8/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=wheel
eapol_version=1
ap_scan=1
fast_reauth=1

# WEP protected network:
network={
  scan_ssid=0
  ssid="Home Network"
  key_mgmt=NONE
  wep_key0="EDITED"
  priority=5
  auth_alg=SHARED
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
# You'll need a recent version of wireless-tools for this!
network={
  ssid="any"
  key_mgmt=NONE
  priority=2
}
So...now I don't get the original error message, but [pre]wpa_cli status[/pre] says the status is "scanning," and I'm not able to connect.

Any suggestions?

Thanks,

-Drew
 
Old 01-07-2008, 06:44 PM   #8
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hi all,

I may have found my (latest) problem: I had the wrong ssid in my wpa_supplicant.conf file.

I've made that change and I'll see if that fixes things, of if there's more I need to do.

EDIT: That only seemed to work halfway. I went through wpa_gui and it said I was connected, but:

(1) I couldn't connect to the Internet or open an SSL connection to my desktop computer, and

(2) I can only seem to connect as root. I can't even use wpa_cli or wpa_gui as an unpriviledged user -- even though I have my user in the wheel group.

I'm closer, but I still need help.

Thanks,

-Drew

-Drew

Last edited by Lufbery; 01-07-2008 at 08:09 PM.
 
Old 01-08-2008, 06:44 AM   #9
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hi all,

I'm at the point now where the wpa_gui status vacillates between "scanning" and "associating."

Any suggestions?

Regards,

-Drew
 
Old 01-08-2008, 10:17 AM   #10
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
I would skip the gui configuration for now.

go to a CLI and run

wpa_supplicant -dwu -Dwext -iath0 -c /etc/wpa_supplicant.conf

to see what wpa_supplicant is really doing. if it seems OK (no config parse errors) try dhcpcd -d ath0 in another terminal.

you can also try changing

ap_scan=1

to

ap_scan=2

this is helpful for ndiswrapper - I dunno if it applies to madwifi. Also wpa_supplicant offers a driver 'madwifi' (substitute for wext ?)

finally, I wonder if your key was generated correctly? did you use wpa_passphrase to make it?
 
Old 01-08-2008, 11:36 AM   #11
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
No, the key is text, and that's how I have it set up on the router. I'll look into other options, but this worked before with OpenSUSE 10.2 and knetworkmanager.

I'll try your other suggestions and see what happens.

Regards,

-Drew
 
Old 01-11-2008, 01:20 PM   #12
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hi all,

Here's an update. Initially I got everything connected, but wasn't getting an IP address from the router. Digging a little deeper, I figured out that the best (or at least easiest) way for me to address this problem was to assign a static IP address to my laptop using the router settings.

That's what I did, and everything is working perfectly now.

Most of the work I did was in my rc.inet1.conf file I'll post it and my wpa_supplicant.conf file this weekend; just in case other people want to see how I configured things.

Thanks for your help, everyone.

-Drew
 
Old 01-11-2008, 10:02 PM   #13
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
For the record, here's my /etc/wpa_supplicant.conf

Code:
# See /usr/doc/wpa_supplicant-0.5.8/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=wheel
eapol_version=1
ap_scan=1
fast_reauth=1

# WEP protected network:
network={
  scan_ssid=0
  ssid="Highland"
  key_mgmt=NONE
  wep_key0="EDITED"
  wep_tx_keyidx=0
  priority=5
  auth_alg=SHARED
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
# You'll need a recent version of wireless-tools for this!
network={
  ssid="any"
  key_mgmt=NONE
  priority=2
}
Here's my /etc/rc.d/rc.inet1.conf

Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Added by Drew #
# Config information for ath0 (usng dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="IBM-Laptop"
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
WLAN_WPACONF[1]="/etc/wpa_supplicant.conf"
WPAOPTS[1]="-Dwext -iath0 -c/etc/wpa_supplicant.conf"

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
#IPADDR[1]=""
#NETMASK[1]=""
#USE_DHCP[1]=""
#DHCP_HOSTNAME[1]=""

# Config information for eth2:
#IPADDR[2]=""
#NETMASK[2]=""
#USE_DHCP[2]=""
#DHCP_HOSTNAME[2]=""

# Config information for eth3:
#IPADDR[3]=""
#NETMASK[3]=""
#USE_DHCP[3]=""
#DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A0EAFAD563B268BAD01CAF TxRate=0"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=thekey TxRate=0"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (space-separated, see the
                                # example).
And here's my /etc/rc.d/rc.wireless.conf

Code:
# Wireless LAN adapter configuration
#
# Theory of operation :
#
# The script attempts to match a block of settings to the specific wireless
# card inserted, the *first* block matching the card is used.
# The address format is "hwaddr", with * as a wildcard.
# 'hwaddr' is the unique MAC address identifier of the wireless card.
# The MAC address is usually printed on the card, or can be found via ifconfig.
# Some examples here use only half of the MAC address with a wildcard to
# match a whole family of cards...
#
# All the Wireless specific configuration is done through the Wireless
# Extensions, so we will just call 'iwconfig' with the right parameters
# defined below.
# Of course, you need to have iwconfig installled on your system.
# To download iwconfig, or for more info on Wireless Extensions :
#       http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
#
# Note : you don't need to fill all parameters, leave them blank, in most
# cases the driver will initialise itself with sane defaults values or
# automatically figure out the value... And no drivers do support all
# possible settings...
#
# -- This is a modified '/etc/pcmcia/wireless.opts' script --
# -- I added sections for Prism/GT and Atheros based cards --
# --    (supported by the prism54 and madwifi drivers)     --
# --              16/sep/2004 * Eric Hameleers             --
#

VERBOSE=1

case "$HWADDR" in

## NOTE : Comment out the following five lines to activate the samples below ...
## --------- START SECTION TO REMOVE -----------
## Pick up any Access Point, should work on most 802.11 cards
#*)
#    INFO="Any ESSID"
#    ESSID="any"
#    ;;
## ---------- END SECTION TO REMOVE ------------


# Here are a few examples with a few Wireless LANs supported...
# The matching is done on the first 3 bytes of the MAC address

# SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter
00:04:E2:*)
    INFO="SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter"
    # ESSID (extended network name) : My Network, any
    ESSID="any"
    # NWID/Domain (cell identifier) : 89AB, 100, off
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="7"
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M,54M
    RATE="auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY=""
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
;;

# Multiband Atheros based 802.11a/b/g universal NIC cards
00:05:4E:*)
    INFO="Multiband Atheros based 802.11a/b/g universal NIC"
    # ESSID (extended network name) : My Network, any
    ESSID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="7"
    # Bit rate : auto, 1M, 11M,54M
    RATE="auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;

# Lucent Wavelan IEEE (+ Orinoco, RoamAbout and ELSA)
# Note : wvlan_cs driver only, and version 1.0.4+ for encryption support
00:60:1D:*|00:02:2D:*)
    INFO="Wavelan IEEE example (Lucent default settings)"
    ESSID="Wavelan Network"
    MODE="Managed"
    #RATE="auto"
    KEY="s:secu1"
    # To set all four keys, use :
    #KEY="s:secu1 [1] key s:secu2 [2] key s:secu3 [3] key s:secu4 [4] key [1]"
    # For the RG 1000 Residential Gateway: The ESSID is the identifier on
    # the unit, and the default key is the last 5 digits of the same.
    #ESSID="084d70"
    #KEY="s:84d70"
    ;;

# Cisco/Aironet 4800/3x0
# Note : MPL driver only (airo/airo_cs), version 1.3 or later
00:40:96:*|00:02:8A:*)
    INFO="Cisco/Aironet example (Cisco default settings)"
    ESSID="any"
    # To set all four ESSID, use iwconfig v21 and the same trick as above
    MODE="Managed"
    #RATE="11M auto"
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY="off"
    ;;

# Samsung MagicLan (+ some other PrismII cards)
# Note : Samsung binary library driver, version 1.20 or later
00:00:F0:*|00:02:78:*)
    INFO="Samsung MagicLan example (Samsung default settings)"
    ESSID="any"
    MODE="Managed"
    CHANNEL="4"
    RATE="auto"
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    #IWCONFIG="power on"
    ;;

# Raytheon Raylink/WebGear Aviator2.4
# Note : doesn't work yet, please use for debugging only :-(
00:00:8F:*|00:00:F1:*)
    INFO="Raylink/Aviator2.4 example (Aviator default ad-hoc setting)"
    ESSID="ADHOC_ESSID"
    MODE="Ad-Hoc"
    RATE="auto"
    IWPRIV="set_framing 1"
    ;;

# Old Lucent Wavelan
08:00:0E:*)
    INFO="Wavelan example (Lucent default settings)"
    NWID="0100"
    MODE="Ad-Hoc"
    FREQ="2.425G"
    KEY="off"
    ;;

# Netwave (Xircom Netwave/Netwave Airsurfer)
00:80:C7:*)
    INFO="Netwave example (Netwave default settings)"
    NWID="100"
    KEY="00"
    ;;

# Proxim RangeLan2/Symphony (what is the MAC address ???)
XX:XX:XX:*)
    INFO="Proxim RangeLan2/Symphony example"
    NWID="0"
    MODE="Master"
    CHANNEL="15"
    IWPRIV="setsubchan 1"
    ;;

# No Wires Needed Swallow 550 and 1100 setting (what is the MAC address ???)
XX:XX:XX:*)
    INFO="NWN Swallow example"
    ESSID="session"
    KEY="0000-0000-00 open"
    ;;

# Symbol Spectrum24 setting (what is the MAC address ???)
XX:XX:XX:*)
    INFO="Symbol Spectrum24 example"
    ESSID="Essid string"
    ;;

# Generic example (decribe all possible settings)
*)
    INFO="Fill with your own settings..."
    # ESSID (extended network name) : My Network, any
    ESSID=""
    # NWID/Domain (cell identifier) : 89AB, 100, off
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE=""
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL=""
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M
    RATE=""
    # Encryption key : 4567-89AB-CD, s:password
    KEY=""
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;

00:15:E9:72:F2:92)
        INFO="D-LINK WNA-2330"
        ESSID="any"
        ;;

esac

Last edited by Lufbery; 01-12-2008 at 07:32 AM.
 
Old 01-14-2008, 03:56 PM   #14
symatic
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 242

Rep: Reputation: 32
I had a similiar problem. I what I did was only use the inet1.conf file for the device and IP address. Then i entered the wpa information in the wireless.conf. Move your information in wireless.conf above the generic settings because it reads top to bottom(atleast for me it did). in wireless.conf essid, wpa, and wpadriver is all i used. this did the trick for me. hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsamixer: function snd_ctl_open failed for default: No such file or directory agts Linux - Newbie 16 04-01-2011 08:12 AM
fatal: libncurses.so.5: open failed: No such file or directory xpucto Solaris / OpenSolaris 8 09-08-2007 01:26 AM
bind9 failed - bindnamed: chroot(): no such file or directory rly74 Linux - Software 1 05-29-2007 03:16 PM
snmpd failed: No such file or directory kav Red Hat 8 04-09-2007 01:16 PM
error: stat of /var/log/ppp/connect-errors failed: No such file or directory Niceman2005 Linux - Newbie 0 01-20-2005 12:29 AM


All times are GMT -5. The time now is 05:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration