LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-30-2013, 09:37 AM   #1
Holering
Member
 
Registered: Feb 2010
Distribution: Slackware
Posts: 149

Rep: Reputation: 22
Fail to wake up from sleep in frame buffer console (Slackware64 14). Sleeps if busy.


Working in frame buffer console causes computer to sleep and not wake-up. Mouse and keyboard can't wake system and computer sleeps while working (using keyboard and mouse). Playing games such as chocolate doom and dosbox doesn't prevent sleep mode in terminal console; games start running choppy right before entering sleep mode and afterwards continue to run (can still hear sounds but monitor remains off forcing me to hit the power button).

My bios has no sleep timers available only S3 and ACPI modes are enabled (not sure about apm, need to double-check). High precision event timer is disabled.

My only option to stop framebuffer console from entering sleep is to let xserver run and log in to another tty (ctrl+alt+fkey (2-6)).

If I log into xserver, quit xserver, and remain in framebuffer console, system sleeps a lot sooner (takes maybe five minutes only).



Regards

Last edited by Holering; 04-30-2013 at 09:40 AM.
 
Old 04-30-2013, 01:32 PM   #2
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,019

Rep: Reputation: 157Reputation: 157
A shot in the dark, but would something like:

Code:
$ setterm -powersave off
help?

see man setterm for other possibilities.

Also, when experimenting with the xserver, perhaps $ xset -dpms, may accomplish something.

cheers,
 
Old 05-03-2013, 06:26 PM   #3
Holering
Member
 
Registered: Feb 2010
Distribution: Slackware
Posts: 149

Original Poster
Rep: Reputation: 22
That seems to work.

This might be a bug in one of the Slackware64 14 packages or the kernel. Actually, forgot to mention I'm running an updated kernel (not the stock Slackware 14 kernel). Doh!

Has anyone else experienced this problem (not able to wake machine from framebuffer console sleep) on stock Slackware64 14?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Frame Buffer Console michijo Slackware 11 05-08-2011 05:07 AM
Linux frame buffer console help needed ssenuta Linux - Hardware 0 09-20-2007 10:55 AM
console frame buffer @ 640x480 only edM Slackware 6 08-23-2004 09:29 AM
nvidia driver form nvida & frame buffer console dosen't work together linuxlah Linux - General 0 03-11-2004 08:38 PM
Problems with changing the frame buffer setting in console. adz Linux - Software 1 10-23-2003 02:25 AM


All times are GMT -5. The time now is 12:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration