LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-15-2004, 05:01 PM   #1
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Rep: Reputation: 15
External CD-RW mount problems


Hi guys,

i have external HP USB CDRW 8200 & i am having problems mounting it. i read some of the forums, but i couldn't figure it out. so i am asking you for help. when i run cdrecord-scanbus i get the following message:

root@darkstar:/home/stanislav# cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J￿rg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus1:
1,0,0 100) 'HP ' 'CD-Writer+ 8200f' '1.0A' Removable CD-ROM
1,1,0 101) *
1,2,0 102) *
1,3,0 103) *
1,4,0 104) *
1,5,0 105) *
1,6,0 106) *
1,7,0 107) *

that doesn't mean anything to me. i guess my drive is at sg0 but i am not sure. if you have any sugestions, please don't hesitate.

thank a lot, Shemeta
 
Old 01-15-2004, 05:13 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
I'd suggest you describe a problem? :)

I can't see any error messages or a description
of a problem you are facing?



Cheers,
Tink
 
Old 01-15-2004, 05:19 PM   #3
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Original Poster
Rep: Reputation: 15
well i can't mount my CDRW. i put that line in my fstab, but it doesn't work.

/dev/sg0 /mnt/cdrw auto noauto,user,owner,rw 0 0

& when i try to run mount /dev/sg0 i get the following message :

mount: /dev/sg0 is not a block device

now i hope that describes better my problem
 
Old 01-15-2004, 05:26 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
That's better :}

Try /dev/scd0 ... sg0 is the generic device, the
thing you talk to for burning ...

What's your native language, btw?


Cheers,
Tink
 
Old 01-15-2004, 05:34 PM   #5
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Original Poster
Rep: Reputation: 15
thanks for the quick reply. i think that helps. but now i get another message:

root@darkstar:/home/stanislav# mount /dev/scd0
/dev/scd0: Invalid argument
mount: block device /dev/scd0 is write-protected, mounting read-only
/dev/scd0: Invalid argument
mount: you must specify the filesystem type

what is the next step? what should i do?

My native language is bulgarian. just curious why did you ask?
 
Old 01-15-2004, 06:03 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Quote:
Originally posted by TheShemeta
root@darkstar:/home/stanislav# mount /dev/scd0
/dev/scd0: Invalid argument
mount: block device /dev/scd0 is write-protected, mounting read-only
/dev/scd0: Invalid argument
mount: you must specify the filesystem type

what is the next step? what should i do?
Try to use iso9660 instead of auto ... also,
what's the mount-point?

Quote:
My native language is bulgarian.
just curious why did you ask?
Because English and German(Austrian) use
a very similar order of words in many cases,
and some of your patterns didn't match :}

Like the omission of the article in
"i have external HP USB CDRW 8200"
Native English speakers would have put
the "an" before "external", and so would a
German native speaker (they might have
made the mistake to use an "a" instead
of an "an").

Or "now i hope that describes better my problem"
looks odd in both English and German.


Cheers,
Tink
 
Old 01-15-2004, 06:12 PM   #7
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Original Poster
Rep: Reputation: 15
i changed it to iso9660 & i get another message:

root@darkstar:/home/stanislav# mount /dev/scd0
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems

& the mount point is /mnt/cdrw

any other ideas?

Last edited by TheShemeta; 01-15-2004 at 06:15 PM.
 
Old 01-15-2004, 06:28 PM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Next question ... do you have an
internal CD-ROM as well, and are
you using ide-scsi for it? :}

In this case the burner might be scd1


Cheers,
Tink
 
Old 01-15-2004, 06:30 PM   #9
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Original Poster
Rep: Reputation: 15
yes, i have internal DVD-ROM , but i have no clue if it uses ide-scsi
 
Old 01-15-2004, 06:46 PM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Post all of /etc/fstab, please ...

And I'll be gone for a while, so don't expect
an answer too soon (not from me, anyway :})


Cheers,
Tink
 
Old 01-15-2004, 06:50 PM   #11
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Original Poster
Rep: Reputation: 15
ok here is my fstab:

/dev/hda4 swap swap defaults 0 0
/dev/hda3 / ext2 defaults 1 1
/dev/hda2 /mnt/disk_e vfat noauto,user,exec,nosuid,rw,umask=007 1 0
/dev/hda1 /mnt/disk_c ntfs noauto,user,ro,exec,nosuid,umask=007 1 1
/dev/sda1 /mnt/external vfat user,exec,noauto,codepage=850,iocharset=iso8859-1,quiet,umask=0 0 0 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,user,owner,ro 0 0
/dev/scd1 /mnt/cdrw iso9660 noauto,user,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,rw,exec 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
 
Old 01-15-2004, 08:25 PM   #12
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Doesn't give an indication for ide-scsi :}

Now, the thing you're trying to mount....
it wouldn't happen to be a blank CD-R? :)


Cheers,
Tink
 
Old 01-16-2004, 02:30 AM   #13
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Original Poster
Rep: Reputation: 15
Yup, you are right, i can't mount the drive with a blank cd in it. but it's working fine with regular cds. now the question is what should i do next? can you help me with that too?

thanks a lot, Shemeta
 
Old 01-16-2004, 02:53 PM   #14
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Sure, if you gave me an indication of what you're
trying to achieve? :)

I may be smart, but I'm not clairvoyant! ;}

Cheers,
Tink
 
Old 01-16-2004, 03:09 PM   #15
TheShemeta
Member
 
Registered: Jun 2003
Location: Austria
Distribution: Archlinux 0.7 + 2.6.9
Posts: 140

Original Poster
Rep: Reputation: 15
well what i am trying to do is burn cds, especially in mod2. but i can't figure out how? do i need to mount the burner , so i can burn cds or not? i tried eroaster, but it can't recognize the burner.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i mount external enclosures? thrustan Linux - Hardware 1 03-16-2005 05:16 PM
can't mount external usb hd jnsenit Linux - Hardware 2 12-03-2004 04:03 PM
mount external device ust Linux - Software 6 10-25-2004 02:08 PM
How to mount an external Harddrive Stargod Linux - Hardware 5 07-11-2004 01:37 PM
How to mount my external harddrive? lord_clarence Red Hat 4 04-07-2004 01:58 AM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration