LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Exception: Failed to initialize killswitch manager (GUI). (http://www.linuxquestions.org/questions/slackware-14/exception-failed-to-initialize-killswitch-manager-gui-4175444953/)

stf92 01-10-2013 03:59 AM

Exception: Failed to initialize killswitch manager (GUI).
 
OS: Slackware 14.0

Hi:
Code:

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: No hp: or hpfax: devices found in any installed CUPS queue. Exiting.
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/BasePlugin.py", line
65, in _load
    self.on_load(parent)
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/applet/KillSwitch.py", line 52, in on_load
    raise Exception("Failed to initialize killswitch manager")
Exception: Failed to initialize killswitch manager
Using file config backend
Using file config backend
Using file config backend
Deleting plugin instance <blueman.plugins.applet.KillSwitch.KillSwitch object at 0x29be810>

This is output produced by the GUI immediately upon entering it. CUPS I do not have it started at boot, so its a don't care. What I do care is the "killswitch manager" message. In the GUI exit menu, Switch User is disabled. Honestly, I do not even know where to start with fixing this problem. Any suggestion would be welcome.

STDOUBT 01-11-2013 01:00 AM

"killswitch manager" and Switch User in the logout menu are not related.

"blueman" is the bluetooth manager. Have a look at your devices. If your machine is equipped with a bluetooth device, make sure it's activated in BIOS. If it's not activated, and you want to keep it disabled, use your GUI (I assume KDE) to turn off the KDE bluetooth service.

To make the CUPS error go away, you might want to make sure the /etc/rc.d/rc.cups file is not executable.

stf92 01-11-2013 01:28 AM

Thanks. About CUPS, /etc/rc.d/rc.cups is not executable. About bluetooth, I have to investigate. Thanks again, STDOUBT.

mudangel 01-13-2013 07:23 AM

Code:

warning: No hp: or hpfax: devices found in any installed CUPS queue. Exiting.
Maybe hplip is trying to find a CUPS printer?

stf92 01-13-2013 07:48 AM

Quote:

Originally Posted by mudangel (Post 4868926)
Code:

warning: No hp: or hpfax: devices found in any installed CUPS queue. Exiting.
Maybe hplip is trying to find a CUPS printer?

I do not know. If I could get rid of only one of the error messages output by programs run in the GUI at startup, I could see further up in the F6 console, the console from where I start X. For the X messages, I have /var/log/Xorg.0.log. How do I know if lip is being run?

Snark1994 01-13-2013 07:56 AM

Quote:

Originally Posted by stf92 (Post 4868937)
I do not know. If I could get rid of only one of the error messages output by programs run in the GUI at startup, I could see further up in the F6 console, the console from where I start X.

Have you tried pressing Shift+Page Up? That normally scrolls the terminal upwards.

stf92 01-13-2013 08:32 AM

Of course I did. When getting back from another console the buffer is lost.

mudangel 01-13-2013 03:46 PM

Code:

startx > startx.log 2>&1
This will give you a file containing the output of startx


All times are GMT -5. The time now is 06:50 AM.