LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-10-2002, 09:10 AM   #16
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30

New problem: When I reboot plugged into the router, evrything goes back to not working. I have to do what I mentioned above in order to get everything to work. That's a hassel. Is there anything I can change to avoid doing this?
 
Old 07-10-2002, 11:22 AM   #17
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Is this a dialup connection or always on? Do you use ppp to connect? The only time I've none /etc/resolv.conf to change
is when ppp-go adds tempary entrys to it?

Please post the output from:
ifconfig -a
/etc/resolv.conf
 
Old 07-10-2002, 11:32 AM   #18
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
ifconfig -a:


eth0 Link encap:Ethernet HWaddr 00:E0:18:34:EC:1C
inet addr:12.253.187.163 Bcast:255.255.255.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17387 errors:0 dropped:0 overruns:0 frame:0
TX packets:7226 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:10441868 (9.9 Mb) TX bytes:1040229 (1015.8 Kb)
Interrupt:5 Base address:0x5000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:310 errors:0 dropped:0 overruns:0 frame:0
TX packets:310 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:15500 (15.1 Kb) TX bytes:15500 (15.1 Kb)


/etc/resolv.conf:
nameserver 216.148.227.68
nameserver 204.127.202.4
search attbi.com


Now if I were to reboot going throught the router, the resolv.conf ip becomes a 192 number.

Oh yeah, it's an always on connection...no dialup

Last edited by busbarn; 07-10-2002 at 11:33 AM.
 
Old 07-10-2002, 11:53 AM   #19
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
You might try putting the serch attbi.com on top.
The 12.253.187.163 is assigned by the ISP? And changes
every time you reconnect?

Please post what the 192. ip address are.
Is the 192. alway the same?

Could it be that thy are just kicking you off, after a certain
amount of time? or because you been inactive?

You might try :
ifconfig eth0 down
count to 10
ifconfig eth0 up

Check the ip they should be the different.
 
Old 07-10-2002, 09:43 PM   #20
zelgadis
Member
 
Registered: Apr 2002
Location: Venezuela
Distribution: slackware 8.0
Posts: 67

Rep: Reputation: 15
what is the model of the router?

it have some firewalling or DHCP capabilities?
 
Old 07-10-2002, 11:15 PM   #21
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
The 192 numbers are the ones I posted at the beginning of the thread. Whenever I change the resolv.conf file, it creates resolv.conf.sv and the regular resolv.conf stays the same. How can I change this and have it stick?

I know it's not kicking me off after a certain amount of time because it's broadband--it's supposed to be on all the time. It worked fine inder Suse 7.3 so I know it's possible, I just need to know where to go and what to fix.
 
Old 07-11-2002, 08:58 AM   #22
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Quote:
Originally posted by busbarn
I know it's not kicking me off after a certain amount of time because it's broadband--it's supposed to be on all the time.
Correct me if I'm wrong, you're using ATT Broadband services?

Now quoting from AT & T Broadbroad Internet page:

Configure Computer Settings with DHCP
What is DHCP?

Once assigned, the address stays with that computer for a certain time period and then returns to the pool if not used. This means that more users can be supported with fewer addresses, thus assisting in the implementation of uniform equipment and service requirements for the latest cable Internet service industry.

This falls under the RTFP ... Read the fine print

Now what YOU can do about it?

1. Don't worry about /etc/resolv.conf

2. Once the ip address is lost, then what:

Login in with your user account:
$ su - root
# ifconfig eth0
Check the ip address

# ifconfig eth0 down
# ifconfig eth0 up
Count to 10
# ifconfig eth0
Did you ip address changes? If so your "in like flint"
if no:
# tail -f /var/log/messages
Look for messages about DHCP, ip adress being assigned.

3. What can you do to try to "beat the sytsem"

You could try running script that sends at ping say every 30 minutes the script might look something like this:

(ping -i 1800 $5 &) >/dev/null 2>&1

If you want to getting a little trickier, you could write that script so that if the ping fails it run the ifconfig comands
for you. [/b] See the BASH scripting howto]/b] at
http://tldp.org for details.

You might also want to put that ping script in a file called:
/etc/rc.d/rc.pingme and call it from rc.local. so that when ever your system reboots it starts the ping for you.

Finally here is the link I was quoting:
http://help.broadband.att.com/faq.js...category_id=43

Last edited by pickledbeans; 07-11-2002 at 09:08 AM.
 
Old 07-11-2002, 09:07 AM   #23
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
OK, there is one other thing you could do ...but it won't be cheap... pay for business connection.

Last edited by pickledbeans; 07-11-2002 at 09:10 AM.
 
Old 07-11-2002, 11:37 AM   #24
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally posted by pickledbeans


Correct me if I'm wrong, you're using ATT Broadband services?

Now quoting from AT & T Broadbroad Internet page:

Configure Computer Settings with DHCP
What is DHCP?

Once assigned, the address stays with that computer for a certain time period and then returns to the pool if not used. This means that more users can be supported with fewer addresses, thus assisting in the implementation of uniform equipment and service requirements for the latest cable Internet service industry.

This falls under the RTFP ... Read the fine print
That's misleading..... and doesn't really clarify the DHCP.

When its not in use, like if they have their cable modem off or computer off, is when it will return the IP not in use. If you have a computer on or router connected, its always being used. AT&T and most other cable modem ISP's set a release time after they assigned an IP, usually 24 hours. When that time is up and the computer or router are still connected, they renew their IP address automatically.

busbarn,
You shouldn't be losing your connection at all, but don't worry, its not kicking you off like that, your just losing your IP or connections in other ways.

Also, they didn't happen to give you the option of a static IP did they ? When I had AT&T broadband, I got a static IP, but also could use DHCP if I wanted...

Last edited by trickykid; 07-11-2002 at 11:41 AM.
 
Old 07-11-2002, 02:22 PM   #25
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Your could well be right?
But once again RTFP, read the fine print on you service contract. If it was me I would be on the phone asking
for a clarification before I ruled it out.

If YOU rule out ATT, what does that leave you with, flakey
hardware?

Tricky --
What do you think about the PLAN A +B As listed above?
 
Old 07-11-2002, 03:35 PM   #26
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally posted by pickledbeans
Your could well be right?
But once again RTFP, read the fine print on you service contract. If it was me I would be on the phone asking
for a clarification before I ruled it out.

If YOU rule out ATT, what does that leave you with, flakey
hardware?

Tricky --
What do you think about the PLAN A +B As listed above?
Not sure what your asking pickled ?

And I could be right, I know I'm right.. cause I have had AT&T and I currently work for the Cable Company.. The only one that drops you that I know of due to inactivity is AOL Broadband, since they require you to login to connect. Which I have no idea why anyone would want that on a boradband connection
 
Old 07-11-2002, 06:45 PM   #27
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
What ever dude ------
Since you missed it the first time.
Question to orginal poster? How low between disconnects? Look in /var/log/messges there should be
messges when connection starts and when it ends.

Here is PLAN B:

Quote:
Originally posted by pickledbeans

Now what YOU can do about it?

1. Don't worry about /etc/resolv.conf

2. Once the ip address is lost, then what:

Login in with your user account:
$ su - root
# ifconfig eth0
Check the ip address

# ifconfig eth0 down
# ifconfig eth0 up
Count to 10
# ifconfig eth0
Did you ip address changes? If so your "in like flint"
if no:
# tail -f /var/log/messages
Look for messages about DHCP, ip adress being assigned.

3. What can you do to try to "beat the sytsem"

You could try running script that sends at ping say every 30 minutes the script might look something like this:

(ping -i 1800 $5 &) >/dev/null 2>&1

If you want to getting a little trickier, you could write that script so that if the ping fails it run the ifc



onfig comands
for you.
See the BASH scripting howto]/b] at
http://tldp.org for details.

You might also want to put that ping script in a file called:
/etc/rc.d/rc.pingme and call it from rc.local. so that when ever your system reboots it starts the ping for you.

Finally here is the link I was quoting:
http://help.broadband.att.com/faq.js...category_id=43
[/B]
 
Old 07-11-2002, 09:48 PM   #28
zelgadis
Member
 
Registered: Apr 2002
Location: Venezuela
Distribution: slackware 8.0
Posts: 67

Rep: Reputation: 15
You can connect to the internet only if you bypass the router?

A friend have a broadband connection (no cable but ADSL), he uses a Cisco 677 ADSL router. In the operation guide it say that the router have a DHCP server and client.

when you connect without the router you are assigned a ip address of 12.x.x.x

But when you are connected through the router you are assigned a number of the type 192.168.x.x . This range of address is reserved for use only in private Lans, so i think that the DHCP client in the slackware computer is receiving the ip address from the router and not from the ISP.

If this is correct you can check the configuration of the DHCP client in the Suse and Slackware boxs and compare.

Also if the clients are different you can try using in the slackware box the same that in the Suse.

If this fail check the router site in the web.

Hope this help . . . . . . ^_^
 
Old 07-11-2002, 10:17 PM   #29
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
Wow, lots of intructions that I have no clue of the meaning. As long as I leave my computer on I'm fine. BUt X crashed and I couldn't use any of the terminals (tty1-5). Keyboard locked. I tried alt-ctrl-del and the computer rebooted. When it rebooted, the ip adress changed from 12 to 192. So as long as I don't reboot. It's all cool.

I would have compared suse and slack but I only have one box and I wiped out suse. I would mount zip and suddenly all of my devices (floppy, cdrw, dvd, and zip) were busy and I couldn't save or load anything from them. Great--perfect time to try slack.

Lesson Learned: print out config files before total reboot for comparison sake.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot configure ethernet at work mehlkelm Debian 8 07-09-2005 08:13 PM
Getting Ethernet card to work Kensai Linux - Hardware 1 11-17-2004 07:29 AM
Modem and ethernet do not work matevzp Linux - Hardware 2 07-09-2004 03:56 AM
Will an ethernet router work? Sundance Linux - Newbie 5 12-31-2003 07:48 AM
How do I get my ethernet card to work? RJWMU Linux - Newbie 4 05-16-2003 01:27 PM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration