LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-25-2007, 04:31 PM   #1
Satriani
Member
 
Registered: Mar 2003
Location: The Netherlands
Distribution: Red Hat 7.3, Red Hat 9, Solaris8, Slackware 10, Slax on USB, AIX, FreeBSD, WinXP, AIX, Ubuntu
Posts: 418

Rep: Reputation: 30
eth1 does not dhcpcd automatically, eth0 does?


Hi all,

Just finished my fresh install of slack12 (i tried the upgrade from slack11, but that gave me hell, so it was time for a clean machine anyway )

However, several strange things I noticed... But the most annoying one is the not automatically getting my IP on boot.
It notices my eth0 (wired) is not connected (which is correct!) so it dhcpcd timeout is set to 10 sec (changed that to 3 )
however, eth1 (my wireless card) does not get an IP, while every other setting is correct (essid, keys etc)
When I manually run dhcpcd eth1, i instantly get an IP. This should automatically work on boot???
Any ideas?
Thanks...
 
Old 10-25-2007, 04:49 PM   #2
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
Quote:
Originally Posted by Satriani View Post
Any ideas?
Take a look at /etc/rc.d/rc.inet1.conf
Try: USE_DHCP[1]="yes" and USE_DHCP[0]=""

Btw is your name Joe? ;-)
 
Old 10-25-2007, 04:49 PM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Run 'netconfig eth1' and set it up to use DHCP. Or, yeah, do what mannyslack says, it's the faster way.
 
Old 10-25-2007, 05:02 PM   #4
Satriani
Member
 
Registered: Mar 2003
Location: The Netherlands
Distribution: Red Hat 7.3, Red Hat 9, Solaris8, Slackware 10, Slax on USB, AIX, FreeBSD, WinXP, AIX, Ubuntu
Posts: 418

Original Poster
Rep: Reputation: 30
Thanks... the tip manny gave was the trick.. netconfig does not do it.. It seems to only work on eth0??? strangeeeee....

But now it works! Have to figure out the rest of the unexpected errors I ran into... Maybe Ill post them here on the forum also...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
howto acess intrnet thru eth1(wireless card)in winXP via briging in linux(eth0-eth1) labhesh_popli Linux - Wireless Networking 1 09-21-2006 02:11 AM
Wireless network on eth1 diabled Ethernet eth0 and eth0 never comes back tadatoshi Linux - Wireless Networking 4 09-23-2004 06:57 PM
eth1 added, mysql connections FROM this machine are from eth1. Need bound to eth0??? kreese Linux - Networking 9 03-31-2004 01:12 PM
Kernel 2.4.22 finds eth0 and eth1 but 2.6.0 does not find eth1 coollink Linux - Networking 3 01-13-2004 08:32 PM
automatically turn off eth0 when wireless eth1 is in megaspaz Linux - Laptop and Netbook 0 01-08-2004 04:49 AM


All times are GMT -5. The time now is 09:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration