LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-30-2007, 09:19 PM   #1
q3noob
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
eth0, eth1, dhcp, slackware 11 problem


Hi guys

I'm trying to help a friend of mine to set up his router.

rc.inet1.conf:

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]="192.168.0.1"
NETMASK[1]="255.255.255.0"
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

eth0 is conected to a modem, and cant be set to static ip.

The problem is, when eth0 is plugged alone, it works,
when both eth0 and eth1 are plugged, after 30 or so seconds
eth0 loses its ip and dissapears.

Any ideas?
 
Old 07-30-2007, 10:05 PM   #2
davimint
Member
 
Registered: Jan 2006
Distribution: Slackware Current
Posts: 272

Rep: Reputation: 33
I'm still learning so forgive me if this sounds like a bad question.

What type of router and how is it being connected ?

For example is it a dsl connection or cable modem being used.

Is it wired like this:
cable modem > wireless router > wired pc's & wireless pc's
 
Old 07-30-2007, 10:17 PM   #3
sparc86
Member
 
Registered: Jul 2006
Location: Joinville, Southern Brazil
Distribution: Debian, CentOS
Posts: 296

Rep: Reputation: 31
Why don't you try to setup the eth0 using a static IP, like you did to eth1?

Please tell us if it worked for you.
 
Old 07-31-2007, 02:03 AM   #4
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
Quote:
Originally Posted by sparc86
Why don't you try to setup the eth0 using a static IP, like you did to eth1?

Please tell us if it worked for you.
As he said he can't. My ISP does the same, it changes IP-s very randomly, sometimes after a few weeks, sometimes after a month, and currently i've had the same IP for over 3 months now.

IPADDR[1]="192.168.0.1"

Set this to something else. This is usually the router/modems IP address.
 
Old 07-31-2007, 07:45 AM   #5
sparc86
Member
 
Registered: Jul 2006
Location: Joinville, Southern Brazil
Distribution: Debian, CentOS
Posts: 296

Rep: Reputation: 31
Why exactly he says that he cannot?

Troubles with dhcpcd, maybe? Tell him to put "no" at the option USE_DHCP[0]="yes"


Did it work?

Last edited by sparc86; 07-31-2007 at 07:48 AM.
 
Old 07-31-2007, 09:26 AM   #6
q3noob
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Original Poster
Rep: Reputation: 0
it seems it was the mac address of eth0 that causes the problem.

thank you guys for fast replies!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 and eth1 problem BCarey Linux - Wireless Networking 8 05-26-2007 09:23 PM
Dhcp eth0 and XP eth1 internet sharing props666999 Slackware 8 08-20-2005 09:48 AM
eth1 added, mysql connections FROM this machine are from eth1. Need bound to eth0??? kreese Linux - Networking 9 03-31-2004 12:12 PM


All times are GMT -5. The time now is 02:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration