LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-23-2004, 09:07 AM   #1
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Rep: Reputation: 64
Eterm startup in Fluxbox


Hi all,

I have Eterm starting up (through ~/.fluxbox/Apps) automatically when Fluxbox starts.
But somehow it starts too fast (?), I mean, Eterm starts before the background is set (with fbsetbg) so instead of the transparancy I would like to have, it shows up with a black background.

Whenever I start Eterm after that, it shows up transparent (=with my desktop background in it).

Here is a snap from the XFree86 log file:

> BScreen::BScreen: managing screen 0 using visual 0x22, depth 16
> Eterm: Error: Unable to locate desktop window. If you are running Enlightenment, please
> restart. If not, please set your background image with Esetroot, then try again.

BTW: i am not using Enlightenment, and I the background image is set with Esetroot (as fbsetbg -i is telling me)

can anyone tell me what the above-mentioned BScreen means?

So, please anyone who has a workaround to make Eterm correctly detect my desktop image when it startsup??

Cheers, Leon.
 
Old 03-05-2004, 08:53 AM   #2
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Original Poster
Rep: Reputation: 64
Ok, I will provide the answer myself ;-)

Just set the background with fbsetbg -l in ~/.xinitrc and all is fine!

Leon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Esetroot (Eterm) error - starting Eterm in transparent mode? nimcha Linux - Software 2 07-14-2007 05:58 AM
fluxbox and .xinitrc Eterm, Esetroot at 1280*1024 res darkleaf Linux - Software 11 03-06-2005 05:55 AM
fluxbox and Eterm jacksmash Linux - Software 1 10-16-2004 08:40 AM
fluxbox startup moneyshotz Linux - Software 18 07-18-2003 12:36 PM
fluxbox & Eterm newbieME Linux - Newbie 6 04-25-2003 10:40 AM


All times are GMT -5. The time now is 11:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration