LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /etc/X11/xinit/.Xmodmap; run level 4 won't init script (http://www.linuxquestions.org/questions/slackware-14/etc-x11-xinit-xmodmap%3B-run-level-4-wont-init-script-385800/)

Potatopopper 11-23-2005 07:48 AM

/etc/X11/xinit/.Xmodmap; run level 4 won't init script
 
I have a Logitech 510mx mouse and I needed to remap some of the keys by adding this line to
"/etc/X11/xinit/.Xmodmap"

pointer = 1 2 3 6 7 4 5

But if I set /etc/inittab to run level 4, when I log into kde the keys are not remaped; so I guess the script doesn't get run, but I'm not sure though. Just wondering why this is. Thanks for any help.

malo_umoran 11-23-2005 08:11 AM

you can remap the buttons in /etc/X11/xorg.conf:

Option "ZAxisMapping" "1 2 3 6 7 4 5"


maybe, KDM is ignoring Xmodmap. you could make a autostart script which runs this:
$ xmodmap -e "pointer = 1 2 3 6 7 4 5"

M.

Potatopopper 11-23-2005 08:58 AM

oh cool, thanks. I'll do the first option you said since it is quicker. I was under the impression that the ZAxisMapping was just for mapping the mouse wheel, so that never even occured to me. Thanks again.

malo_umoran 11-23-2005 09:03 AM

mouse wheel is just a button ... np.

M.

Erik_FL 11-26-2005 01:23 PM

I had similar problems with that.

The only file that reliably executes with a graphical login is "~/.xprofile" or "/etc/xprofile".

This link may be helpful.
http://www.linuxquestions.org/questi...89#post1885989

Potatopopper 11-27-2005 07:37 PM

Thanks Erik, that did the trick...now it works!


All times are GMT -5. The time now is 09:30 AM.