LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-20-2005, 11:00 PM   #1
Kocil
Member
 
Registered: Feb 2003
Distribution: Redhat since 5.2, Slackware since 9.0, Vector since 4.0
Posts: 209

Rep: Reputation: 31
/etc/udev/permissions.d on Slack ?


Hi Slackers.

I'm trying to install jack audio connection kit and oss2jack on Slack 10.2,
unfortunatelly, using the HOWTO for Gento/Ubuntu.

http://fort.xdas.com/~kor/oss2jack/install.html


The howto said, we need to put a permission file for fusd
in the /etc/udev/permissions.d folder.

I can't find it on Slack. So where is the proper place ?


Thanks.

P.S.
I could make the system works by manually using:
chgrp audio /dev/fusd/*

The permission file is suppossed to do it automatically.
 
Old 11-21-2005, 06:33 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Try add in yout /etc/udev/rules.d/udev.rules or better in a custom
rules file, with a number in filename so it is loaded before any rules,

for example : /etc/udev/rules.d/10_kocil.rules
Code:
SUBSYSTEM="fusd", GROUP="audio"
KERNEL="control", NAME="fusd/%k", MODE="0660"
KERNEL="status", NAME="fusd/%k", MODE="0660"
 
Old 11-21-2005, 06:51 AM   #3
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 36
Pretty sure permission.d files are used by PAM which Slackware does not use. Have absolutely no experience with your device or messing with udev but if you have a rescue disk handy in the event the following fubars your system try:

Quote:
Most modern distributions have a special directory that is searched for udev rules. This path (and the permissions path) is specified in the udev configuration file. On Ubuntu, this is at /etc/udev/rules.d/. Rather than editing the main rules file (which could be overwritten by the distribution), it is better to create a new file in the rules directory. Create a file named fusd.rules in your rules directory, containing the following line:
The next section refers to control and status so try adding two lines to your new file /etc/udev/rules.d/fusd.rules :
Code:
SUBSYSTEM="fusd" , KERNEL="control" , NAME="fusd/%k" , GROUP="audio" , MODE="660"
SUBSYSTEM="fusd" , KERNEL="status" , NAME="fusd/%k" , GROUP="audio" , MODE="660"
Keep that rescue disk handy cause I'm winging it here

good luck
 
Old 11-29-2005, 03:57 AM   #4
Youdaman
LQ Newbie
 
Registered: Feb 2005
Location: Sydney, Australia
Distribution: CRUX
Posts: 2

Rep: Reputation: 0
I'm running CRUX 2.1 (converted from devfs to udev) and I have fusd subsystem working using the following in /etc/udev/rules.d/fusd.rules:
Code:
# /etc/udev/rules.d/fusd.rules

SUBSYSTEM=="fusd", NAME="fusd/%k", GROUP="users"
KERNEL=="control", NAME="fusd/%k"
KERNEL=="status", NAME="fusd/%k"
It's basically a mix of the line from the oss2jack page, the posts above, and the format of the existing /etc/udev/rules.d/50-udev.rules on my system (note the "==" for the first entry on each line).
I added
Code:
modprobe kfusd
to my /etc/rc.local to load the fusd module at boot time, and commented out
Code:
#modprobe sound-service-0-3
because on my system sound-service-0-3 is an alias for the snd-pcm-oss module and according to the oss2jack installation you shouldn't have it loaded.
I then run:
Code:
jackd -d alsa &
oss2jack &
as a regular user (note the "GROUP" is set to "users" above) which creates a /dev/dsp device. I can play quake3 whilst listening to mp3s now! I have noticed using oss2jack is that there are momentary pauses when accessing menus in firefox and things like that which might require some extra processing power and thus interrupt oss2jack a little. One thing I still have to get working is ventrilo or teamspeak. oss2jack was supposedly a solution to the game+voip problem with dodgy sound cards (mine's a intel8x0, otherwise known as an ac97). At the moment I can't hear any output from ventrilo (I can without fusd/jackd/oss2jack -- with the old oss/alsa pcm drivers, but not now). It's probably something simple in the settings of one of the above, so I'll keep trying.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/sound/* permissions reset using udev ratman96 Linux - General 0 05-04-2005 02:13 PM
Slackware 10.1 + Udev Permissions and USB Drives rignes Slackware 3 03-07-2005 10:12 PM
udev-054 user permissions henno Slackware 1 03-03-2005 07:19 AM
udev permissions.d not read jonman364 Linux - Software 1 02-21-2005 05:08 PM
udev : framebuffer device (/dev/fb0) default permissions keefaz Slackware 6 07-04-2004 07:54 PM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration