LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-17-2013, 08:02 AM   #1
Ratmonkey
Member
 
Registered: Jul 2012
Location: Notre Dame, Indiana
Distribution: Slackware
Posts: 58

Rep: Reputation: Disabled
/etc/rc.d/rc.hald missing


Trying to get my iPhone to connect with Amarok on Slackware 14. Installed usbmuxd and libimobiledevice, but at the end of libimobiledevice install, I got "chroot: failed to run command '/etc/rc.d/rc.hald': No such file or directory. I did some searching and didn't find much that was helpful on the forums or Google. I did find an rc.hald file I think for version 11 from Alian Bob's site, but not sure what I would do with it? Can I simply place that in the rc.d directory?

http://taper.alienbase.nl/mirrors/sl...em/hal/rc.hald

Thanks.
 
Old 01-17-2013, 08:18 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,256

Rep: Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050
No more hal in Slackware 14.0, so rc.hald would do nothing anyway.

Where/how did you get/install usbmuxd and libimobiledevice? And what makes you think those are necessary?
 
Old 01-17-2013, 08:20 AM   #3
Stephen Morgan
Member
 
Registered: Feb 2011
Location: England
Distribution: Slackware
Posts: 148

Rep: Reputation: 15
That script just starts hald, which is no longer included in Slackware, as of the most recent version.
 
Old 01-17-2013, 08:24 AM   #4
Ratmonkey
Member
 
Registered: Jul 2012
Location: Notre Dame, Indiana
Distribution: Slackware
Posts: 58

Original Poster
Rep: Reputation: Disabled
Didier,

http://slackbuilds.org/repository/14...imobiledevice/

When I plug my iPhone in, it is seen as a camera. Amarok doesn't even know it's there. Googling it, I found that I needed libimobiledevice... are there other suggestions on how to get it working?
 
Old 01-17-2013, 08:33 AM   #5
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,256

Rep: Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050
Quote:
Originally Posted by Ratmonkey View Post
OK then, you should first report the problem to the maintainer of the SlackBuilds, as he is certainly aware that hal is not included in Slackware 14.0.

Or you could stop by #slackbuilds on IRC where you may get an even faster answer.

When doing so, post the end of the build log where you see the error messages (on IRC you could use pastebin.com to paste it and then include the link to it in your message).

Last edited by Didier Spaier; 01-17-2013 at 08:37 AM.
 
Old 01-17-2013, 08:33 AM   #6
Ratmonkey
Member
 
Registered: Jul 2012
Location: Notre Dame, Indiana
Distribution: Slackware
Posts: 58

Original Poster
Rep: Reputation: Disabled
Or is it that it is no longer needed for the package to work? Maybe I'll try a reboot =P
 
Old 01-17-2013, 08:41 AM   #7
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,256

Rep: Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050
Following file: http://slackbuilds.org/slackbuilds/1...vice/doinst.sh is obsolete. Maybe a reboot will be enough. In any case please report to the SlackBuild's maintainer so he make the needed update.
 
Old 01-17-2013, 08:55 AM   #8
Ratmonkey
Member
 
Registered: Jul 2012
Location: Notre Dame, Indiana
Distribution: Slackware
Posts: 58

Original Poster
Rep: Reputation: Disabled
I'm going to mark this thread as solved, since rc.hald is not a part of Slackware 14. I'll start a second thread related to my issues with my iPhone.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hald does not start randomly? ReeRD Linux - Hardware 1 05-19-2010 01:10 AM
Hald not running rlarion Linux - Newbie 1 03-16-2010 06:42 AM
what is hald-runner? invader44 Linux - Newbie 2 01-02-2009 08:11 AM
What are rc.messagebus and rc.hald for? FreeTinker Slackware 9 03-10-2008 03:53 PM
hald underscorelinux Linux - Software 0 10-07-2005 09:12 AM


All times are GMT -5. The time now is 09:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration